88VA Eternal Grafx

88VA Eternal Grafx

このヘルプは「ねこープロジェクトII」のヘルプをもとに作成中です。 PC-9801エミュレーション時にしかあてはまらない説明には[98]マークを付けて示していますが、一部マークを付けられていない箇所があります。

88VA Eternal GrafxはPC-88VAエミュレータです。PC-9801エミュレータとしての機能も合わせ持ちます。

PC-88VAエミュレーション時とPC-9801エミュレーション時とで使用可能な機能、使用方法に一部違いがあります。該当箇所はVA98のマークを付けて説明を区別しています。

  • 88VA Eternal Grafxについて
  • エミュレートするマシンの機能仕様

導入方法

  • インストール
  • 起動とリセット
  • 基本設定
  • ディスクイメージ
  • ハードディスクイメージ
  • ディップスイッチ等
  • アンインストール

エミュレーションウィンドウ

  • キー操作
  • System Menu Emulate Replay FDD1 FDD2 HardDisk Screen Device Other
  • Configure
  • Newdisk - FDD HDD
  • Screen option - Video Chip Timing
  • Serial option - COM1 PC-9861K CH.1 CH.2
  • MIDI option - MPU-PC98II
  • Sound option - Mixer PC-9801-14 26K 86 Speak Board JoyPad
  • Calendar

ツールウィンドウ

  • ツールウィンドウ
  • スキン


88VA Eternal Grafxについて

PC-88VAエミュレータです。V3モードのみエミュレートします。

PC-9801エミュレータ ねこープロジェクトII をベースに開発しており、PC-9801エミュレーション機能もそのまま残しています。

動作環境

  • 486DX2以上のプロセッサ
  • Windows 95, NT 4.0 以降
  • Direct X3以上
  • 画面の表示色として16ビット, 24ビット, 32ビットのいずれか表示可能なこと。(24ビットは動作未確認)
  • Windowsキーのある日本語キーボード
  • IE4.01以上 (ヘルプの表示に必要)

謝辞

本ソフトウェアには、PC-9801エミュレータ ねこープロジェクトII のソースを全面的に使用させていただいています。

また、本ソフトウェアのZ80エミュレーション処理には、PC-8801エミュレータM88のソースを使用させていただいています。

各ソフトウェアの作者の方々に心より感謝いたします。

著作権表示

Neko Project II (c) NP2 developer team, 1999-2001,2003,2004

M88 - PC8801 Series Emulator
Copyright (C) by cisc 1998, 2002.

88VA Eternal Grafx (c) Project VA-EG, 2005-2007

  • 使用許諾条件


ねこープロジェクトIIについて

基本コンセプト

ねこープロジェクトIIの開発スタート時には、出来の良いPC-98/PC-286エミュレータもありました。
しかしトリッキーな物のエミュレーションには弱く、細かい挙動には満足できるものではありませんでした。

ねこープロジェクトIIでは、i386やプロテクトモード等のCPUエミュレーション部分を捨て、周辺チップ等のハードウェアに強いエミュレータを目指し開発しました。

特徴

  • マルチプラットホーム(Windows9x/NT/CE, MacOS9/X, X system, Zaurus...)
  • QVGAサポート
  • ３タイプのディスプレイ(標準/プラズマ/液晶)
  • セミグラ・ブリング・バーチカルライン
  • GDCによる可変サイズスクリーン
  • ラスタ処理による17色以上の表示
  • 正確なBEEP-PCM/PSG-PCM
  • 複数のサウンドカード
  • MIDIインタフェイス、およびソフトウェアMIDI音源
  • オリジナルITFによるソフトディップスイッチ


導入方法 - インストール

導入方法/インストール

インストール

適当なフォルダに vaeg????.zip を解凍します。

インストーラはありません。

ROMイメージの用意

VA

実機のROMの内容を保存したファイル(ROMイメージ)が必要です。vaeg.exeと同じフォルダにおいてください。

ROMイメージはPC-88VA上で専用のツール (GETROMVAまたはXDISK2VA)を使って作成します。

ファイル名 | サイズ | 内容
VAFONT.ROM | 320KB | システムメモリエリアバンク8, 9 (9はA0000-AFFFF)
VADIC.ROM | 512KB | システムメモリエリアバンクC, D
VAROM00.ROM | 512KB | ROMエリア0バンク0～7
VAROM08.ROM | 128KB | ROMエリア0バンク8～9
VAROM1.ROM | 128KB | ROMエリア1バンク0, 1
VASUBSYS.ROM | 8KB | FDDサブシステムのROM

バージョンアップボード(PC-88VA-91)をエミュレートする場合は、バージョンアップボードのROMイメージが必要です。vaeg.exeと同じフォルダにおいてください。

ROMイメージはバージョンアップボードが装着されたPC-88VA上で専用のツール (GETROMVA)を使って作成します。

ファイル名 | サイズ | 内容
VUDIC.ROM | 512KB | システムメモリエリアバンクC, D*1
VUROM00.ROM | 512KB | ROMエリア0バンク0～7*1
VUROM08.ROM | 128KB | ROMエリア0バンク8～9*1
VUROM1.ROM | 128KB | ROMエリア1バンク0, 1*1

*1バージョンアップボードはシステムメモリエリア、ROMエリア0/1にそれぞれ2バンク、10バンク、2バンクのROMをもっており、その切り替えは本体のバンク切り替え(ポート152h)とは別のポート(ポートFF2h)で行います。ここに記載のバンク番号は、ポートFF2hでのバンク番号です。

98

88VA Eternal Grafx単体でもそれなりの動作をしますが、実機BIOS等のファイルを用意すると より実機に近づきます。すべてvaeg.exeと同じフォルダに置いて下さい。

ファイル | 内容
bios.rom | 実機のBIOS ROMをファイル化した物です。GETBIOSでファイル化して下さい。
font.rom | 実機のフォント ROMをファイル化した物です。GETBIOSでファイル化して下さい。 font.romの他に BMP形式のフォントファイルも使用できます。
sound.rom | サウンドボードに搭載されるBIOS ROMをファイル化した物です。GETBIOSでファイル化して下さい。

リズム音源音声データの用意

OPNAに搭載されているリズム音源を wave形式で録音したファイルです。44KHz 16bit モノラル 無圧縮形式である必要があります。vaeg.exeと同じフォルダに置いて下さい。

サウンドボード2、PC-88VA2/3内蔵音源などのOPNAが搭載されている音源ボードをエミュレートしてリズム音源を再生する場合に必要です。リズム音源音声データがない場合はリズム音源が再生されません。

ファイル名 | 対応する音色
2608_bd.wav | バスドラム
2608_sd.wav | スネアドラム
2608_top.wav | シンバル
2608_hh.wav | ハイハット
2608_tom.wav | タム
2608_rim.wav | リムショット

Fakerhutmを利用することも可能です。


導入方法 - 起動とリセット

導入方法/起動とリセット

起動

vaeg.exeまたはvaegd.exeを実行します。

vaegd.exeは、デバッグ用にコンパイルしたものです。メインウィンドウとは別にconsoleウィンドウが表示されます。通常はvaeg.exeを使用してください。

リセット

[Emulate - Reset]を選択します。実機でリセットボタンを押したのと同じ状態になります。設定でデバイスの構成を変更した場合はリセット後に有効になります。


導入方法 - 基本設定

導入方法/基本設定

基本設定

Emulate - Configure...

[Emulate - Configure...]を選択し 設定ダイアログを表示します。

エミュレーションするマシンとCPUを設定します。

VA

通常は、[CPU]に3.9936MHz x 2を設定します。

98

PentiumII以下のマシンでは処理落ちするケースが多いのでクロック数を下げてください。Celeron以降のマシンにおいても、アプリケーションにより処理落ちしたり フレームスキップが発生して充分にエミュレートできない場合があります。その場合は、CPU動作設定のクロック数を下げてください。

続いてサウンド設定を行います。
マシンパワーがあれば 44KHzへ変更すると良いでしょう。
Bufferの値は 処理が追い付く最低の値を設定します。値を小さくするほど、サウンドが再生されるまでの遅延を小さくすることができます。
環境によりますが、速いマシンであれば 200ms～300ms, 通常で 500msくらいが目安です。

98Resumeをチェックしておくと、PC-98NOTEのようにレジュームが働くようになります。好みによりチェックして下さい。

設定変更後は[Emulate - Reset]でリセットしてください。


導入方法 - ディスクイメージ

導入方法/ディスクイメージ

ディスクイメージ

88VA Eternal Grafxでは、直接FDDからデータの読み書きは行なわず、ディスクイメージ(仮想ディスクファイル)よりデータの読み書きを行います。対応しているディスクイメージの形式は、ベタ形式 および D88形式です。

PC-88VAシリーズでは、XDISK2VA、PC-8801シリーズ(およびPC-88VAのV1/V2モード)ではXDISK2、PC-9801シリーズの場合はmake_hd、PC-ATマシンではDITTで D88形式でディスクイメージを作成して下さい。

Windows95では ベタ形式のみですが VFIC、ディスク イマージュをご利用下さい。

ディスクイメージの作成方法

※ イメージ化する場合には必ずライトプロテクトをして下さい。

make_hdを用いて D88形式で作成

  1. make_hdの存在するディレクトリに移動します。
  2. ドライブにイメージ化するフロッピーディスクを挿入します。
  3. make_hdを実行します。
    2HDディスクをイメージ化するには「make_hd ドライブ -w -fファイル名.d88 -h」とタイプします。
  4. 作成したイメージファイルをWindowsマシンへ転送します。

ディスク イマージュを用いて ベタ形式で作成

PC-ATマシンでは 3モードドライブが搭載されている事が必要です。
2モードドライブでの2HDディスクは 1.44MB形式だけしかイメージを作成する事ができません。

  1. ディスク イマージュを起動し設定します。
    フロッピーディスクを挿入したドライブと ディスクタイプ(MS-DOSの1.2MBフォーマットは 1.25MB)を指定して FD -> HDをクリックします。
  2. ファイル名を指定します。
    保存するファイル名指定のダイアログが表示されますので 保存するファイル名を指定します。
  3. 拡張子を変更します。
    ディスクイマージュの拡張子は標準で binとなっていますが、一般的なベタイメージの拡張子は xdf, dup等ですので、これらに変更します。

ベタイメージは ファイルサイズが 1,261,568バイトのイメージファイルを指します。
拡張子はあまり意味はありませんが、88VA Eternal Grafxでは xdf, dup等にしておくとディスクイメージ選択が容易に行なえます。


導入方法 - ディスクイメージ

導入方法/ハードディスク

ハードディスクイメージの作成

88VA Eternal Grafxでは、フロッピーディスク同様にハードディスクも仮想ディスクファイルよりデータを読み書きを行います。

VA

  1. NewDiskを選択し、ファイルの種類(T)から Anex86 harddisk image files (*.HDI)を選択し保存します。
  2. ハードディスクサイズの選択ダイアログが表示されたらサイズを選択します。
  3. 作成したハードディスクイメージを [HardDisk - SASI1 - Open] で選択します。
  4. [Emulate - Reset]を選択して、リセットをかけます。

以上の操作によりSASIハードディスクが接続された状態になり、PC-EngineやMS-DOSからSASIハードディスクが使用可能になります。

98

  1. MS-DOSをディスクイメージにします。
  2. NewDiskを選択し、ファイルの種類(T)から T98 harddisk image file (*.THD)を選択し保存します。
  3. ハードディスクサイズの選択ダイアログが表示されたら 20～128程度の 適当な値を設定してします。
  4. MS-DOSのディスクイメージを[FDD1 - Open...]で、
    作成したハードディスクイメージを [HardDisk - SASI1 - Open] で、それぞれ選択します。
  5. [Emulate - Reset]を選択して、リセットをかけます。
  6. MS-DOSが起動後に表示されるメニューより、MS-DOSのマニュアルに従いハードディスクをフォーマットします。

MS-DOS ver6.20の場合、インストール時に CPUが80286以下と表示され、インストーラは利用できません。
この場合には、MS-DOSシステム転送済みディスクに FORMAT.EXE, HDFORMAT.EXEをコピーし プロンプトで FORMATを実行して ハードディスクを初期化して下さい。


導入方法 - ディップスイッチ等

導入方法/ディップスイッチ等

ディップスイッチ

VA

基本的にエミュレーションに影響しないため、ディップスイッチの設定は不要です。 設定する必要がある場合は非公開機能を参照しDipSw_VAを設定してください。

98

PC-9801シリーズと同様のシステムセットアップメニューを内蔵しています。

この画面を呼び出すには、PC-9801シリーズと同様に HELP (End)キーを押しながらリセットしてください。

セットアップモード

VA

PC-88VAシリーズ同様にPCキー(Windowsアプリケーションキー)を押しながらリセットします。


導入方法 - アンインストール

導入方法/アンインストール

アンインストール

レジストリは使用していません。
以下のファイルを削除してください。

  • vaeg.exe
  • vaegd.exe
  • vaeg.chm (本ヘルプファイル)
  • vaeg.ini
  • vaeg.bmp
  • vabkupmem.dat (PC-88VAのバックアップメモリの内容)
  • headoff.wav
  • headon.wav
  • seek.wav
  • seek1.wav


キー操作

エミュレーションキー

PC-8801シリーズ、PC-9801シリーズとAT互換機とでキーボードレイアウトが異なる為に、一部のキーは以下のとおり対応付けています。

キー | エミュレーションで対応するキー
GRPH | Alt(左) / Alt(右)*2
STOP | Break / F12*1
COPY | F12*1
CLR/HOME CLR | Home
HELP | End
テンキー = [イコール] | F12*1 / Alt(右)*2
テンキー , [カンマ] | F12*1 / Alt(右)*2
テンキー [RET] | テンキー Enter
SHIFT(右) | Ctrl(右)
PC*3 | Windows アプリケーションキー
全角*3 | 漢字(半角/全角) / F12*1 / Alt(右)*2
決定/NFER | 無変換
変換/XFER | 変換
ユーザーキー*4 | F12*1 / Alt(右)*2

*1 F12キーのキー割り当ては メニューより選択して下さい。
*2 Alt(右)キーのキー割り当ては メニューより選択して下さい。
*3 VAPC-88VAエミュレーション時のみ有効です。
*4 仮想的なキーです。キーを押したときの動作は後述のkey.txtで指定します。

※ 複数のキーを同時に押した場合、キーボードによっては、一部のキーが認識されない場合があります。

Windows割り当てキー

ALT, F10キー等、通常 Windowsユーザーインターフェイスとして割り当てられてるキーもエミュレーションで使用する為、以下の通りに変更されています。

キー | Window操作
F11 | メニューをアクティブにする(F10キー相当)
ALT+F4 | 88VA Eternal Grafxの終了*
ALT+ENTER | ウィンドウ-フルスクリーンの切替え*

* メニューより設定できます。

キーの置き換え

vaeg.exeと同じフォルダにkey.txtという名前でテキストファイルを作成して、以下のフォーマットでキー設定を記述してください。

keyname = key1 key2 ...
keyname <TAB> key1 key2 ...
* <TAB>はTAB文字です。

keyname, keynには、キーの名前を書きます。keynameのキーを押したときに、keynに置き換わります。右辺に複数のキーを書いた場合は、キーの同時押しになります。userkey1, userkey2には最大15個、その他のキーは最大3個の同時押し設定が可能です。[=] キーを記述する場合は、 = で区切られてしまうので TABで区切るか [EQU]として下さい。

キーの名前には以下を指定します。

種類 | キー名
フルキー | 0～9 A～Z - ^ \ @ [ ] ; : , . / _ STOP COPY ESC TAB BS RET SPC XFER NFER INS DEL RLUP RLDN HMCL HELP PC*1 ZEN(全角)*1
ファンクションキー | F1～F10 VF1～VF5*2
テンキー | [0]～[9] [-] [/] [*] [+] [=] [,] [.] [RET]*1
シフト | SHIFT CAPS KANA GRPH CTRL SFTR(右SHIFT)*1
ユーザーキー*3 | userkey1 userkey2
*1 VAPC-88VAエミュレーション時のみ有効です。
*2 98PC-9801エミュレーション時のみ有効です。
*3 左辺にのみ記述できます。

key.txtの記述例です。

W = UP                 (ダイアモンドキーをカーソルにしてみたり…)
S = LEFT
D = RIGHT
X = DOWN
[7] = [4] [8]          (テンキー斜め同時押しにしてみたり…)
[9] = [6] [8]
[1] = [4] [2]
[3] = [6] [2]
userkey1 = CTRL XFER   (CTRL+XFER FEP切り替え)
userkey2 = D O A Z     (D+O+A+Z 同時押し)


メニュー - システムメニュー

System Menu Emulate Replay FDD1 FDD2 HardDisk Screen Device Other

メニュー | 機能
Tool Window | ツールウィンドウを開きます。
Key Display | キーディスプレイウィンドウを開きます。
Soft Keyboard | ソフトウェアキーボードウィンドウを開きます。
Centering | エミュレーションウィンドウをデスクトップの中央に表示します。
Window Snap | エミュレーションウィンドウの移動時にデスクトップの境界近くで引っ張られます。
Background | エミュレーションウィンドウがバックグラウンドになっても、エミュレートを続行させます。
Background Sound | エミュレーションウィンドウがバックグラウンドになっても、サウンドを再生します。
320x200 | エミュレーションウィンドウを 320x200にします。
480x300 | エミュレーションウィンドウを 480x300にします。
640x400 | エミュレーションウィンドウを 640x400にします。
800x500 | エミュレーションウィンドウを 800x500にします。
960x600 | エミュレーションウィンドウを 960x600にします。
1280x600 | エミュレーションウィンドウを 1280x800にします。


メニュー - Emulate

System Menu Emulate Replay FDD1 FDD2 HardDisk Screen Device Other

メニュー | 機能
Reset ハードウェアリセットします。
実機でリセットボタンを押した時の状態になります。
Configure | エミュレーション設定ダイアログを開きます。
NewDisk ブランクイメージを作成します。
未フォーマット状態のフロッピーディスクイメージとハードディスクイメージを作成する事ができます。
Font エミュレーションで表示するフォントファイルを指定します。
テキストRAM上のデータは即反映されますが、グラフィックRAM上のデータはソフトウェアに依存されてしまいます。
Exit | ねこープロジェクトIIを終了します。


メニュー - Replay

System Menu Emulate Replay FDD1 FDD2 HardDisk Screen Device Other

メニュー | 機能
Stop | プレイ記録の再生、作成を停止します。
Play | プレイ記録を選択して再生を開始します。
Multi play | プレイ記録を複数選択して連続再生を開始します。ファイル選択ダイアログが連続して表示されるので、必要なだけ選択を繰り返します。キャンセルボタンで選択を終了します。最大10個まで選択できます。
Record | プレイ記録の作成を開始します。
Repeat | プレイ記録の再生を繰り返します。

[VA]

ゲームなどのプレイ状況を記録し、後から再生することができます。プレイ状況は拡張子OPRのファイル(プレイ記録)に保存されます。以下の操作が記録できます。

  • キーボード
  • ジョイパッド
  • フロッピーディスクイメージの挿入、取り出し

プレイ記録を再生するには以下の条件が必要です。逆に、以下の条件がそろえば別のマシンで作成したプレイ記録を再生することもできます。

  • プレイ記録を作成したのと同じリリースのVA-EGを使うこと。異なるリリースのVA-EGで再生できる場合もありますが、常に再生できるとは限りません。
  • プレイ記録を作成したときに使用したのと同じROMイメージを使うこと(ROMイメージは初代VAとVA2/3の2種類あります)。
  • プレイ記録を作成したときに使用したディスクイメージと同じ内容のディスクイメージがあること。
    プレイ記録にはFDDに挿入したディスクイメージのファイル名が記録されています。このファイルが再生時に見つからなかった場合、ファイル選択ダイアログが表示されますので、代わりに使用するディスクイメージ(プレイ記録作成時に使用したのと内容が同じもの)を選択してください。
  • VA-EGのデバイスの設定(IOバンクメモリの構成、マウスポートへの接続デバイス、HDDの有無)がプレイ記録を作成したときと同じであること。

以上の条件が満たされない場合、場合によっては思わぬ操作が実行されイメージの破損に繋がる恐れもありますので注意してください。


メニュー - FDD1

メニュー/FDD1

System Menu Emulate Replay FDD1 FDD2 HardDisk Screen Device Other

メニュー | 機能
Open | ドライブ１にディスクイメージを挿入します。 ベタイメージ(.XDF .DUP等)と D88形式(.D88 .D98)が利用できます。
Eject | ドライブ１のディスクイメージを取り出します。


メニュー - FDD2

メニュー/FDD2

System Menu Emulate Replay FDD1 FDD2 HardDisk Screen Device Other

メニュー | 機能
Open | ドライブ２にディスクイメージを挿入します。 ベタイメージ(.XDF .DUP等)と D88形式(.D88 .D98)が利用できます。
Eject | ドライブ２のディスクイメージを取り出します。


メニュー - HardDisk

メニュー/HardDisk

System Menu Emulate Replay FDD1 FDD2 HardDisk Screen Device Other

メニュー |  | 機能
SASI-1 | Open | SASIハードディスク１に接続するハードディスクイメージを選択します。
 | Eject | ハードディスク１を未接続状態にします。
SASI-2 | Open | SASIハードディスク２に接続するハードディスクイメージを選択します。
 | Eject | ハードディスク２を未接続状態にします。
SCSI #0 | Open | SCSIハードディスク(ID:0)に接続するハードディスクイメージを選択します。
 | Eject | SCSIハードディスク(ID:0)を未接続状態にします。
SCSI #1 | Open | SCSI #0と同様、SCSIハードディスク(ID:1)を操作します。
 | Eject
SCSI #2 | Open | SCSI #0と同様、SCSIハードディスク(ID:2)を操作します。
 | Eject
SCSI #3 | Open | SCSI #0と同様、SCSIハードディスク(ID:3)を操作します。
 | Eject

設定変更はリセット後に有効になります。

VA

SASIハードディスクにはAnex86形式(.HDI)が利用できます。
SCSIハードディスクは利用できません。

98

SASIハードディスクにはT98形式(.THD)と Anex86形式(.HDI)が利用できます。
SCSIハードディスクにはVirtual98形式(.HDD)が利用できます。


メニュー - Screen

System Menu Emulate Replay FDD1 FDD2 HardDisk Screen Device Other

メニュー | 機能
Window | エミュレーションウィンドウを窓表示にします。
FullScreen | エミュレーションウィンドウをフルスクリーンで表示します。
Normal | エミュレーションウィンドウの回転を標準に戻します。
Left Rotated | エミュレーションウィンドウを左へ90度回転します。
Right Rotated | エミュレーションウィンドウを右へ90度回転します。
Disp Vsync 画面の表示タイミングを変更します。
チェックすると垂直同期信号発生タイミングで、
チェックを外した場合は垂直同期期間終了時に 画面を更新します。
スクロールがズレたりチラツく場合は、このスイッチを変更して下さい
Real Palettes [98]
アナログ16色の機種で 17色以上表示する場合に使用します。
対象ソフトは アプロス・ドラッケン・レミングス・ライムスター等です。
この機能を使うと処理が多少重くなりますので、通常はチェックを外して下さい。
チェックした場合、フルスクリーンモード時には 65536色モードに変更されます。
No Wait CPUの全力疾走モードです。
全くタイミングを取らなくなります。
Auto frame | 表示する描画枚数を自動的に決定します。
Full frame | 全てのフレームを描画します。
1/2 frame | ２回に１度描画します。
1/3 frame | ３回に１度描画します。
1/4 frame | ４回に１度描画します。
Screen option | スクリーン設定ダイアログを開きます。


メニュー - Device

メニュー/Device

System Menu Emulate Replay FDD1 FDD2 HardDisk Screen Device Other

メニュー |  | 機能
Keyboard | Keyboard | キーボードを通常モードで使用します。
 | JoyKey-1 | テンキー及びZXキーをジョイパッド1に割り当てます。
 | JoyKey-2 | 98テンキー及びZXキーをジョイパッド2に割り当てます。
 | Mechanical SHIFT | シフトキーを押下の度にLock/Unlockします。
 | Mechanical CTRL | コントロールキーを押下の度にLock/Unlockにします。
 | Mechanical GRPH | グラフキーを押下の度にLock/Unlockにします。
 | F12 = Mouse | F12キーにマウス切替えを割り当てます。
 | F12 = Copy | F12キーにCopyキーを割り当てます。
 | F12 = Stop | F12キーにStopキーを割り当てます。
 | F12 = tenkey [=] | F12キーにテンキーの=(イコール)キーを割り当てます。
 | F12 = tenkey [ , ] | F12キーにテンキーの,(カンマ)キーを割り当てます。
 | F12 = Zenkaku (VA) | VAF12キーに全角キーを割り当てます。
 | F12 = User1 | F12キーにユーザーキー1を割り当てます。
 | F12 = User2 | F12キーにユーザーキー2を割り当てます。
 | Alt(R) = GRPH | Alt(右)キーにGRPHキーを割り当てます。
 | Alt(R) = tenkey [=] | Alt(右)キーにテンキーの=(イコール)キーを割り当てます。
 | Alt(R) = tenkey [ , ] | Alt(右)キーにテンキーの,(カンマ)キーを割り当てます。
 | Alt(R) = Zenkaku (VA) | VAAlt(右)キーに全角キーを割り当てます。
 | Alt(R) = User1 | Alt(右)キーにユーザーキー1を割り当てます。
 | Alt(R) = User2 | Alt(右)キーにユーザーキー2を割り当てます。
 | Alt(R) = No Wait | Alt(右)キーを押している間、タイミングを取らずに高速実行します。
Sound | Beep off | Beepを再生しません。
 | Beep low | Beep音量を小にします。
 | Beep mid | Beep音量を中にします。
 | Beep high | Beep音量を大にします。
 | Disable boards | サウンドボードを使用しません。
 | Sound Board 2 (VA) | VAPC-88VA2/3内蔵音源またはサウンドボード2 (PC-88VA-12)を使用します。
 | PC-9801-14 | 98PC-9801-14(ミュージックジェネレータボード)を使用します。
 | PC-9801-26K | 98PC-9801-26Kを使用します。
 | PC-9801-86 | 98PC-9801-86を使用します。
 | PC-9801-26 + 86 | 9826Kと86を使用します。
 | PC-9801-86 + Chibi-oto | 98PC-9801-86とちびおとを使用します。
 | PC-9801-118 | 98PC-9801-118を使用します。
 | Speak board | 98スピークボードを使用します。
 | Spark board | 98スパークボードを使用します。
 | AMD-98 | 98AMD-98を使用します。
 | JAST SOUND | 98JAST SOUNDを使用します。
 | Seek Sound | FDDのシーク音、ヘッドロード音を再生します。 98モードでbios.romがない場合はヘッドロード音は再生されません。 98モードでbios.romがない場合、この項目をチェックした場合のみシーク時のウェイトが入ります。(それ以外の場合はこの項目のチェックによらずシーク時のウェイトが入ります。)
Memory | 640KB | 98メインメモリのみを使用します。
 | 1.6MB | 98メインメモリに加え、拡張メモリを1MB使用します。
 | 3.6MB | 98メインメモリに加え、拡張メモリを3MB使用します。
 | 7.6MB | 98メインメモリに加え、拡張メモリを7MB使用します。
IO Bank Memory |  | IOバンクメモリ設定ダイアログを開きます。
Mouse |  | Windowsのマウスを占有して、マウスエミュレーションを有効にします。 ３ボタンマウスでは中ボタンクリックでも切替えが可能です。
Mouse Port (VA) | Joy Stick | VAマウスポートにジョイパッドを接続します。
 | Mouse | VAマウスポートにマウスを接続します。(マウスを操作するには[Device - Mouse]でマウスエミュレーションを有効にする必要があります。)
Version Up Board (VA) |  | VAバージョンアップボード(PC-88VA-91)を使用します。[Emulate - Configure]でArchitectureにPC-88VA1が選択されている場合のみ有効です。
Serial option |  | シリアル設定ダイアログを開きます。
MIDI option |  | MPU-PC98II設定ダイアログを開きます。
MIDI Panic |  | エミュレーション中のMIDI音源をすべて消音します。
Sound option |  | サウンド設定ダイアログを開きます。


メニュー - Other

System Menu Emulate Replay FDD1 FDD2 HardDisk Screen Device Other

メニュー | 機能
BMP save エミュレーション画面をBMP形式で保存します。
BMP saveではプラズマディスプレイモード固定で保存します。
S98 logging OPN, OPNAのサウンドログを記録します。
ログ保存中に終了するには もう一度選択してください。
Calendar | カレンダー設定ダイアログを表示します。
Shortcut
Key 		ALT+Enter 画面モード切替え(ALT+Enter)を有効にします。
ALT+F4 | アプリケーション終了(ALT+F4)を有効にします。
Clock Disp | キャプション(タイトル)に実行クロック数を表示します。
Frame Disp | キャプション(タイトル)に１秒間の描画回数を表示します。
Joy Reverse | ジョイスティックのボタンを反転します。
Joy Rapid | ジョイスティックのボタンを連打状態にします。
Mouse Rapid | マウスのボタンを連打状態にします。
Use SSTP | あれ以外の何か with "任意" のSSTP機能を使用し、一部のダイアログ処理が "任意"側で制御されます。
Help | 本ヘルプファイルを表示します。
About | バージョン名と 動作状態ダイアログを表示します。


Configure

Base Clock

CPUスピードのベースクロックを指定します。
1.9968で 4/8MHz系、 2.4576で 5/10MHz系になります。
CPUスピードは この値に倍率を掛けた物になります。

※設定変更はリセット後に有効になります。

Multiple

CPUスピードの倍率を決めます。
CPUスピードは この値にベースクロックを掛けた物になります。

※設定変更はリセット後に有効になります。

Architecture

エミュレーションモデルを指定します。

・PC-9801VX … i286以降のCPUを搭載向け仕様となります。システム起動時にFM音源がリセットされます。
・PC-286 … EPSON互換機仕様となります。EPSON BIOSで使用されるRAM(アドレス: D4000～DFFFF)が開放されます。

Sampling Rate

サウンドエミュレートの出力サンプリング周波数を指定します。
一般に設定値高いほど再現率が高くなりますが、CPUパワーが必要になります。

※設定変更はリセット後に有効になります。

Buffer

サウンドエミュレートの出力バッファサイズをミリ秒で指定します。
100～1000msの間を指定してください。

値が少ないほどサウンドの延滞が短くなりますが、CPUパワーが必要になります。
通常は200ms～500msを指定します。

※設定変更はリセット後に有効になります。

Disable MMX

チェックすると MMX命令を使用しません。

Comfirm Dialog (on Reset / Exit)

チェックすると リセット・終了時に確認ダイアログを表示します。

Resume

チェックすると レジューム機能が有効になります。


Newdisk - Create New FD image

Create New FD image

Disk Label

作成するD88ディスクイメージの名前を指定します。(半角16文字まで)

Disk Type

作成するD88ディスクイメージのメディアを指定します。


Newdisk - Create New HD image

Create New HD image

HDD size

作成するハードディスクイメージのサイズを指定します。


Screen option - Video

Liquid Crystal Display

チェックすると PC-9801LT互換の白黒15階調表示になります。
デジタルモードの場合は98NOTEと等価です。

LCD Reverse

白黒15階調表示の時に 白黒反転します。

Use skipline revisions

チェックすると スキップラインを中間色で埋め、15KHzディスプレイのような表示を行います。

Ratio

スキップラインの明るさを決めます。
0で黒、255でいわゆる擬似400ラインモードになります。


Screen option - Chip

Graphic Display Controller

エミュレーションするGDCの設定をします。

チップ 機能・搭載機種
μPD7220 グラフィックのスクロール分割が４つです。
主にi386以下のPC-9801シリーズ
μPD72020 グラフィックのスクロール分割が２つです。
主にi486以降のPC-9801 / PC-9821
Graphic Charger

エミュレーションするグラフィックチャージャータイプを指定します。

チップ 機能・搭載機種
None 使用しません。
初代PC-9801等
GRCG GRCGを使用します。
PC-9801VM
GRCG+ GRCGと CG-Windowを使用します。
実際にはこのタイプのマシンは存在しません
EGC EGCを使用します。(動作が重くなります)
PC-9801VX以降

PC-9801VM,VX以降の製品はGRCGはほぼ必須です。
EGCは市販ソフトではあまり使われませんが、逆にフリーソフト・同人ソフトでは EGCを要求するものが多数あります。
また、EGCの搭載を判定して GRCGとEGCを使い分けるソフトウェアもあります。

Enable 16color

チェックをすると16色ボードを使用します。

PC-9801VMではオプション(PC-9801-24)ボードとして存在しています。
PC-9801VX以降では標準で装備されています。


Screen option - Timing

T-RAM

テキストRAMへのアクセス時のウェイトクロックを指定します。

V-RAM

グラフィックRAMへのアクセス時のウェイトクロックを指定します。

条件にも依りますが、実機のグラフィックRAMへのアクセスはかなりの時間が掛かります。
スクロールが速すぎる場合、大きめの値に設定して下さい。

GRCG

GRCG動作中のグラフィックRAMへのアクセス時のウェイトクロックを指定します。

RealPalettes Adjust

Real Palettes動作中のパレット変更タイミングを調節します。
数値はライン数で指定します。


Serial option - COM1

Port

接続デバイスを選択します。

COM1～COM4

Speed

Windows-デバイス間の通信速度を指定します。
14.4kbps以上のモデムの場合には、エミュレーション中の設定以上の通信速度を、
それ以外のシリアルデバイスが接続されている場合には、エミュレーション中の設定と同じ通信速度を指定し、Char size, Parity, Stop bitも同様に指定してください。

Char size

通信を行なうキャラクタサイズを指定します。

Parity

通信のパリティを指定します。

Stop bit

通信のストップビット長を指定します。

MIDI

Device

使用するMIDIデバイスを指定します。

Device | 対応するMIDIデバイス
N/C | 未接続状態になります。
MIDI MAPPER | WindowsのデフォルトMIDIデバイスを使用します。
VERMOUTH | MIDI再生にVermouthを使用します。
MIDIデバイス名 | 指定した MIDIデバイスを使用します。
Module

Windowsに接続しているMIDI音源を指定します。
この指定は、エミュレーションリセット・終了・MIDI Panicに置いて MIDI音源をリセットするために使用されます。

Use program define file

MIMPI DEFファイルを指定して、音色番号の振り替えを行ないます。
この機能により音色番号が異なる音源間で音色を合せる事ができます。


Serial option - PC-9861K

Enable

チェックするとPC-9861Kを使用します。

Speed

チャネルごとにエミュレーション中の送信速度を設定します。

INT

チャネルごとに割り込み番号を設定します。

Mode

チャネルごとに送受信のモードを指定します。

モード | 機能
Start-Stop | 調歩同期モード
ST1 | ST1同期モード
ST2 | ST2同期モード
RD-Sync | 同期刻時モード
DIP-SW

PC-9861Kボード上のディップスイッチ及びジャンパです。
ディップスイッチやジャンパをクリックしても設定ができます。


Serial option - CH.1

PC-9861KのCH.1のシリアル設定です。

COM1と同様に通信ポートを設定します。


Serial option - CH.2

PC-9861KのCH.2のシリアル設定です。

COM1と同様に通信ポートを設定します。


MPU-PC98II

I/O port

MPU-PC98IIのI/Oポートを設定します。

Interrupt

MPU-PC98IIの割り込み番号を設定します。

DEF

MPU-PC98IIの設定を工場出荷状態に戻します。

DIP-SW

MPU-PC98IIボード上のディップスイッチ及びジャンパです。
ディップスイッチやジャンパをクリックしても設定ができます。

MIDI-OUT

MIDI-OUTのデバイスを指定します。

Device | 対応するMIDI-OUTデバイス
N/C | 未接続状態になります。
MIDI MAPPER | WindowsのデフォルトMIDIデバイスを使用します。
VERMOUTH | MIDI再生にVermouthを使用します。
MIDI-OUTデバイス名 | 指定した MIDI-OUTデバイスを使用します。
MIDI-IN

MIDI-INのデバイスを指定します。

Device | 対応するMIDI-INデバイス
N/C | 未接続状態になります。
MIDI MAPPER | WindowsのデフォルトMIDIデバイスを使用します。
MIDI-INデバイス名 | 指定した MIDI-INデバイスを使用します。
Module

Windowsに接続しているMIDI音源を指定します。
この指定は、エミュレーションリセット・終了・MIDI Panicに置いて MIDI音源をリセットするために使用されます。

Use program define file

MIMPI DEFファイルを指定して、音色番号の振り替えを行ないます。
この機能により音色番号が異なる音源間で音色を合せる事ができます。


Sound option - Mixer

FM

FM(OPN/OPNA)の音量を指定します。

PSG

PSGの音量を指定します。

ADPCM

ADPCM(OPNA)の音量を指定します。

PCM

86PCM(PC-9801-86)とWSS(PC-9801-118)の音量を指定します。

Rhythm

OPNAのリズムの音量を指定します。

DEF

音量の設定を標準に戻します。


Sound option - PC-9801-14

Left

チャネル1,2の左音量を指定します。

right

チャネル1,2の右音量を指定します。

f2

チャネル3～8のフィート2音量を指定します。

f4

チャネル3～8のフィート4音量を指定します。

f8

チャネル3～8のフィート8音量を指定します。

f16

チャネル3～8のフィート16音量を指定します。


Sound option - PC-9801-26K

I/O port

PC-9801-26Kのポートを指定します。

Interrupt

サウンド割り込み番号を指定します。

ROM

サウンドＲＯＭのアドレスを指定します。

DEF

PC-9801-26Kの設定を工場出荷状態に戻します。

Jumper

PC-9801-26Kボード上のジャンパです。
ジャンパをクリックしても設定ができます。


Sound option - PC-9801-86

I/O port

PC-9801-86のポートを設定します。

Interrupt

サウンド割り込み番号と割り込みの有無を指定します。
チェックでサウンド割り込みを使用します。

Sound ID

サウンドＩＤを指定します。

ポート | 設定値
188 | 4x
288 | 5x

参照: サウンドＩＤ一覧

ROM

チェックをするとサウンドＲＯＭを使用します。

DEF

PC-9801-86の設定を工場出荷状態に戻します。

DIP-SW

PC-9801-86ボード上のディップスイッチです。
ディップスイッチをクリックしても設定ができます。


Sound option - Speak Board/SparkBoard

 Mixer PC-9801-14 PC-9801-26K PC-9801-86 JoyPad

Sound option - SpeakBoard/SparkBoard

I/O port

Speak Boardのポートを指定します。

Interrupt

サウンド割り込み番号を指定します。

ROM

サウンドＲＯＭのアドレスを指定します。

DEF

Speak Boardの設定を工場出荷状態に戻します。

Jumper

Speak Board上のジャンパです。
ジャンパをクリックしても設定ができます。

Reversed channel

チェックをすると左右の出力を逆転します。
Speak Boardでは左右の出力が逆転しています。


Sound option - JoyPad

Use JoyPad-1

チェックするとジョイパッドを使用します。

Trigger-1
Trigger-2

ジョイパッドのボタンアサインを指定します。

Trigger-1,2はエミュレート中の音源に接続中の、
A/B/C/DはWindowsマシンに接続されているパッドのボタンです。

Rapid

チェックしておくと連射状態になります。


Calendar

Real

エミュレーション中のカレンダにローカルタイムを使用します。

常にWindowsマシンの時間をエミュレーションで使用します。
エミュレーションで設定した時刻は反映されません。

Virtual Calendar

エミュレート内のカレンダに仮想カレンダを使用します。

エミュレーション中の時間は現実時刻と別にカウントされ、時間経過はエミュレーションに依存します。

Now

エミュレート内の仮想カレンダを現在時刻にセットします。


ツールウィンドウ

ツールウィンドウとは、フロッピーディスクの入れ換えを容易に行なうための機能です。

この機能を使用するためには、エミュレーションウィンドウのシステムメニューより Tool Windowを選択します。

コントロール | 機能
ドロップダウンリスト | 挿入されているフロッピーディスクが表示されています。 リストには過去８ファイルが記録されており、最近使ったファイルを容易に選択できます。 またディスクイメージファイルをドロップして選択することもできます。
...ボタン | ディスクイメージを挿入します。
Ejectボタン (ドライブレバー) | ディスクイメージを取り出します。

システムメニュー・ポップアップメニュー

メニュー |  | 機能
Skin | Select Skin | ツールウィンドウのスキンを選択します。
 | <Base Skin> | 標準のスキンを呼び出します。
Close |  | ツールウィンドウを閉じます。


ツールウィンドウ - スキン

ツールウィンドウはスキンファイルを作成することにより、自由にカスタマイズができます。

スキンのファイル形式は、Windows標準 .INIテキストファイルです。

iniアプリ名は 「ToolWindow」です。必ず指定して下さい。

レイアウト

キー名 指定値
MAIN 背景ビットマップファイルを指定します。
ツールウィンドウは、このビットマップファイルと同じ大きさになります。
ビットマップファイルは iniと同じフォルダに置きます。
FONT ツールウィンドウで使用するフォント名です。
デフォルトは ＭＳ Ｐゴシックで、変更する場合のみ指定して下さい。
FONTSIZE ツールウィンドウで使用するフォントサイズです。
デフォルトは12ドットです。
この設定は、ドロップダウンリストの表示サイズに影響されます。

アクセスランプ/モードLED

キー名 | 指定値
HDDACC | HDDアクセスランプの位置・サイズ
FD1ACC | FDD1のアクセスランプの位置・サイズ
FD2ACC | FDD2のアクセスランプの位置・サイズ
V1MODE | V1モードLEDの位置・サイズ
V2MODE | V2モードLEDの位置・サイズ
V3MODE | V3モードLEDの位置・サイズ

位置とサイズは コンマで区切って記述して下さい。

key=posx,posy,width,height

例) HDDACC=10,20,8,3
BMPの座標(10,20) サイズ 8x3
width, heightが 0の場合には非表示となります。

ファイルリスト

キー名 | 指定値
FD1LIST | FDD1のディスクリストの位置・サイズ
FD2LIST | FDD2のディスクリストの位置・サイズ

リストボックスの高さheightは リストの大きさです。
表示サイズはフォントサイズより決定されます。

ファイルリストには 第５パラメータがあります。
通常は 無指定もしくは0を指定して下さい。
ツールウィンドウがアクティブになった場合のみファイルリストを表示させたい場合には extend=2として下さい。

ボタン

キー名 | 指定値
FD1BROWSE | FDD1のブラウズボタンの位置・サイズ
FD1EJECT | FDD1のイジェクトボタンの位置・サイズ
FD2BROWSE | FDD2のブラウズボタンの位置・サイズ
FD2EJECT | FDD2のイジェクトボタンの位置・サイズ
RESETBTN | リセットボタンの位置・サイズ
POWERBTN | パワーボタンの位置・サイズ

ボタンリソースには 第５パラメータがあります。

key=posx,posy,width,height(,extend)

通常は 無指定もしくは0を指定して下さい。
Windowsのボタンを表示しない場合には extend=1として下さい。
ツールウィンドウがアクティブになった場合のみボタンを表示させたい場合には extend=2として下さい。

POWERBTN=193,112,14,14 (Windows ボタンを使用する)
POWERBTN=193,112,14,14,1 (Windows ボタンを表示しない)

スキン定義サンプル

例としてねこープロジェクトIIに内蔵されているスキンファイルを表示します。

[ToolWindow] | ; アプリ名、必ず指定
MAIN=np2tool.bmp | ; bmpファイル
HDDACC=49,44,8,3 | ; HDDアクセスランプ (49,44) 8x3
FD1ACC=93,19,8,3 | ; 以下、各アイテムの座標指定
FD1BROWSE=352,7,18,17
FD1EJECT=370,7,34,17
FD2ACC=93,41,8,3
FD2LIST=104,28,248,160
FD2BROWSE=352,29,18,17
FD2EJECT=370,29,34,17


べるもっと

べるもっととは、組み込み系をターゲットとしたTimidity互換のソフトウェアシンセサイザーです。
これを用いると MIDI音源がない環境でも MIDIを再生させることができます。

べるもっとを利用するには Timidityの音色ファイル(GUSファイル)が必要です。
ねこープロジェクトIIと同じフォルダに timidity.cfgというファイルとGUSファイルを置き、MPU-PC98II RS-MIDIのドライバでVermouthを指定してください。


非公開機能

88VA Eternal Grafxでは iniファイルを操作することにより、非公開機能を操作することができます。

キーはvaeg.iniの [VA-EG]へ追加してください。
これらの機能は基本的に無保証・無サポートです。
予告なしに変更・削除する可能性があります。

88VA Eternal Grafx 共通スイッチ

キー名 | 機能
ITF_WORK | FALSEでITFエミュレーションを抑制する。(デフォルト:TRUE) [98]
xspeaker | TRUEで左右出力を反転する
BG_COLOR | 液晶モードのバックグラウンドの色(RRGGBB 24bit値)
FG_COLOR | 液晶モードのフォアグラウンドの色(RRGGBB 24bit値)
USE144FD | TRUEでFDDを３モードに(1.44MBをサポート)する。[98]
FDDRIVE3 | TRUEでドライブ３を有効にする。[98]
FDDRIVE4 | TRUEでドライブ４を有効にする。[98]
Sub_Mock TRUEでFDDサブシステムをモックアップ版にする。[VA]
モックアップ版を使用することで処理速度が向上しますが、FDDサブシステムで独自のプログラムを実行するソフトは動作しません。
DipSw_VA ディップスイッチの設定を16進数2桁で指定する。[VA]
bit0がSW1に、1がONに対応する。現在、SW1(CRTモード ON:24KHz, OFF:15KHz)のみが有効。
Seek_Vol | [Device]-[Sound]-[Seek Sound]をオンにした場合のシーク音、ヘッドロード音の音量を指定する。最大100。デフォルト85。

88VA Eternal Grafx Windows版スイッチ

キー名 | 機能
np2title | 88VA Eternal Grafxのキャプション文字列の指定
np2winid 88VA Eternal Grafxのクラス名(半角３文字)
複数起動を許すためのスイッチです。
paddingx | クライアント境界の横サイズ(0～32)
paddingy | クライアント境界の縦サイズ(0～32)
keyboard キーボードの固定指定(通常は自動判定)
PC-98 … PC-9821キーボード / PCAT … 106キーボード / KEY101 … 101キーボード
clock_up | フルスクリーンの時計の色１(RRGGBB 24bit値)
clock_dn | フルスクリーンの時計の色２(RRGGBB 24bit値)
force400 | TRUEでフルスクリーン時640x400にする。
STATSAVE | TRUEでどこでもセーブを10スロット追加する。*1
xrollkey | TRUEでROLLUP(PgDn)と ROLLDOWN(PgUp)キーを入れ換える。
I286SAVE | TRUEでデバガを有効にする。

*1 セーブしたデータは、88VA Eternal Grafxがバージョンアップした際に、使用できなくなる場合があります。


こまった時に - エミュレーション

特定ソフトウェアが起動しない

  • メモリを 640KBにしてみてください。
  • 実機よりBIOS.ROMを作成して、BIOSを使用するようにしてください。
  • プロテクトが掛かっているかどうか確認し、プロテクトを解除してください。

特定ソフトウェアの動作が遅い

  • CPUクロックを調節してください。
  • EGCが必須ではない場合には GRCGを選択してください。
  • サウンドボードを使用しない、もしくは PC-9801-26Kを選択してください。

GDCクロックを変更したい

  • 一部のソフトウェアでは、GDCクロックを指定しなければならないことがあります。
    ソフトウェアディップスイッチで変更してください。

描画が崩れる

  • [Screen - Disp Vsync] で表示タイミングを変更してください。
  • グラフィックコントローラをμPD7220にしてください。
  • 386以降のBIOSを使用している場合には EGCを選択してください。

色が変です

  • [Screen - Real Palettes]を指定すると改善されることがあります。

漢字ROMを認識しません

  • フォントの形状をチェックして、漢字ROMを認識するソフトウェアがあります。
    この場合には 実機よりFONT.ROMを作成して、導入してください。
    昔LOCUSより出てた ウィザードリィ・コレクションはこれが原因で漢字が表示されなかった…

サウンドが再生されない

  • サウンドカードが接続されているか確認してください。
  • DirectX3.0以上が正常にインストールされているか確認してください。(Windows95の場合)
  • メモリスイッチでサウンドボードを使用するになっているか確認してください。
  • 実機よりSOUND.ROMを作成して、SOUND BIOSを使用するようにしてください。

サウンドが音飛びする

  • Sampling Rateを22kHzにしてください。
  • Bufferの値を調節してください。
  • DirectXを更新してください。
  • サウンドカードのドライバを最新のものに更新してください。
  • 実機よりSOUND.ROMを作成して、SOUND BIOSを使用するようにしてください。

マウスが動かない

  • [Device - Mouse]、マウスの中ボタンを押してマウス占有モードに切替えてください。
    占有されていない場合にはエミュレーションのマウスは不動として扱われます。

ディップスイッチを変更したい

  • システムセットアップメニューより変更してください。

メモリスイッチを変更したい

  • システムセットアップメニューより変更してください。
  • N88-BASICのswitch.n88を使用してください。(N88(86)-BASICのマニュアルも参照してください。)

1.44MB形式のフロッピーを扱いたい

  • 標準状態ではサポートしていません。
    非公開機能を参考にしてください。

リアルタイムセーブを使いたい

  • 基本的にサポートはしませんが、非公開機能を設定することで使用可能になります。
    但し、アプリケーションの整合性が合わなくなったり、イメージの破損に繋がる恐れもありますので注意して下さい。

フルスクリーンのディスプレイサイズを640x400にしたい

  • 非公開機能で強制的に変更することができます。
    しかし、PC-9801シリーズの一般的なスクリーンサイズは640x400なのですが、一部のソフトウェアで CRTCを制御して 変則的なスクリーンサイズを表示しますので、フルスクリーンのサイズを640x400にすることは推奨いたしません。


こまった時に - ウィンドウズ

システムメニューって何？

常に表示されているメニューバーのものとは別のメニューです。

システムメニューをアクティブにするには…

システムメニュー | システムメニュー | システムメニュー
アイコンをクリック | キャプション上で右クリック | タスクバーで右クリック

キーボードでは ALT, F10キーのメニューバーよりアイコンを選択、もしくはALT+SPACEでもアクティブにすることができます。
しかし、ねこープロジェクトIIのエミュレーションウィンドウは これらのキーをエミュレーション側へ通知してしまう為にこれらのキーを使用してシステムメニューをアクティブにすることができません。
F11キーでメニューバーをアクティブしてシステムメニューを選択してください。

使用できるウィンドウショートカットキー

原則として 他アプリケーションとの切替えキー以外は エミュレーション側へ通知するために利用できません。

キー操作 | 機能
ALT+TAB
(Shift+ALT+TAB) 		アプリケーションの切替え
CTRL+ESC | スタートメニューを開く
Shift+CTRL+ESC | タスクマネージャを開く(WindowsNT)


機能仕様

動作モード |  | VAモード | 98モード
CPU |  | μPD70116相当品(*1) クロック4～80MHz | μPD70116相当品(*1) クロック2～50MHz i80286相当品(リアルモードのみ) クロック2～50MHz
ROM |  | メインROM 768KB 辞書ROM 512KB フォントROM 288KB FDDサブシステムROM 8KB (いずれも外部ファイルより供給) | BIOS ROM 96KB ITF-ROM 32KB サウンドROM 16KB (N88-BASIC(86)/モニタROM/サウンドROMは外部ファイルより供給)
メモリ |  | メインメモリ 512KB テキスト用VRAM 256KB グラフィック用VRAM 256KB バッテリバックアップRAM 16KB IOバンクRAM 最大32MB (*2) FDDサブシステムRAM 8KB | メインメモリ 512KB テキスト用VRAM 12KB グラフィック用VRAM 256KB IOバンクRAM 最大32MB (*2) EMS 最大7MB (*3)
ディスプレイ |  | 水平走査周波数: 15.98kHz / 15.73kHz / 24.8kHz アナログディスプレイ | 水平走査周波数: 15.98kHz / 24.83kHz 垂直走査周波数: 61.22Hz / 56.42Hz (40.8～65.7Hz) アナログディスプレイ, プラズマディスプレイ, 液晶ディスプレイ いずれか選択。
表示 | テキスト表示 | 80/40文字x25/20/12/10行 リバース・ブリンク・シークレット・アンダーライン等(キャラクタ単位に指定可) カラー4096色中16色(キャラクタ単位に指定可) 画面水平４分割、水平垂直スクロール(スムーズスクロール可能) | 80/40文字x25/20行 リバース, ブリング, シークレット (キャラクタ単位に指定可) カラー8色 (キャラクタ単位に指定可)
 | グラフィック表示 | 640/320x404/400/202/200ドット 65536色、256色、4096色中32/16/1色(*6) 画面水平３分割、水平垂直スクロール(スムーズスクロール・ラップアラウンドスクロール可) 独立2画面合成表示可能 | 640x200ドット (モノクロ16画面, カラー4画面) 640x400ドット (モノクロ8画面, カラー2画面) カラー 8色 (デジタル RGBディスプレイ使用時) 4096色中16色 (アナログ RGBディスプレイ使用時)
 | スプライト表示 | カラースプライト 8x4～256x256ドット (ドットごとに4,096色中16色指定) モノクロスプライト 32x4～256x256ドット (ドットごとに4,096色中1色指定) カラースプライト、モノクロスプライト混在可能 最大32個表示可能 スプライト間の衝突検出機能あり(*4) | -
 | 画面合成 | テキスト画面・スプライト画面・グラフィック画面２画面を優先順位付きで合成可能。 透明色指定、画面マスク機能あり。 | テキスト画面・グラフィック画面を合成可能。
 | 日本語表示 | JIS第１水準漢字 2965字 JIS第２水準漢字 3384字 JIS非漢字 453字 NEC非漢字 443字 ユーザ定義文字 188字 | JIS第１水準漢字 2965字 JIS第２水準漢字 3384字 非漢字 885種 ユーザ定義文字 118種 (外部フォントファイルにより変更可能)
グラフィック描画 |  | グラフィック描画カスタムプロセッサ(SGP) 任意図形の転送描画、直線描画、ペイント補助 (*5) | グラフィック専用カスタムLSI (GDC, EGC)
キーボード |  | JIS標準配列準拠 (但し @ ^ キーは ATキーボードに従う)
５インチミニ フロッピィディスク |  | 2ドライブ内蔵(2HD/2DD/2D兼用) | 2ドライブ内蔵(2HD(1MB)/2DD(640KB)兼用) (設定により 3モード(1.44MB)対応)
マウスインタフェース |  | 内蔵
プリンタインタフェース |  | -
シリアルインタフェース |  | RS-232C規格に準拠(但しWindowsの制限あり) RS-MIDI対応
カレンダ時計 |  | プログラム可能カレンダ
サウンド |  | PC-88VA2/3内蔵音源, サウンドボード2(PC-88VA-12) | PC-9801-14, PC-9801-26K, PC-9801-86, PC-9801-118 Speak Board, Spark Board, AMD98, ちびおと
拡張スロット | MIDI | - | Roland MPU-PC98II
 | Serial | - | PC-9861K
 | SASI | PC-88VA-21, PC-9801-27
 | SCSI | - | PC-9801-55
 | その他 | バージョンアップボード(PC-88VA-91) | -

(*1) V30固有命令は一部未実装。
(*2) バンク切り替えポートは00ECh (PC-9801用)、01D0h (PC-88VA-01/02)から選択可能。
(*3) PC-9801-53相当
(*4) 未実装
(*5) ペイント補助は未実装
(*6) 4096色中1色は未実装


ディップスイッチ

目的 | ON | OFF
SW1-1 | ディスプレイ選択 | 専用高解像度ディスプレイ | 標準ディスプレイ
SW1-2 | スーパーインポーズ *1 | 使用する | 使用しない
SW1-3 | プラズマディスプレイ | 使用する | 使用しない
SW1-4 | 内蔵フロッピィディスク *2 | ＃３，＃４ | ＃１，＃２
SW1-5 RS-232Cモード
5 | 6 | 同期モード | 5 | 6 | 同期モード
ON | ON | BCI同期 | OFF | ON | 同期刻時機構
ON | OFF | ST2同期 | OFF | OFF | 調歩機構
SW1-6
SW1-7 | 未使用
SW1-8 N88-BASIC(86)の
グラフィック機能選択 		拡張グラフィックモード 標準グラフィックモード
(PC-9801E/F/M互換)

目的 | ON | OFF
SW2-1 | BASICモード | N-BASIC (未搭載) | N88-BASIC
SW2-2 | ROM起動時の設定 | ターミナルモード | BASICモード
SW2-3 テキスト画面の
キャラクタ表示 		80文字／行 40文字／行
SW2-4 | 25行／画面 | 20行／画面
SW2-5 | メモリスイッチ | 保持する | 初期化する
SW2-6 | 内蔵HDD | 切り離す | 使用する
SW2-7 | 未使用
SW2-8 | GDCクロック | 5MHzモード | 2.5MHzモード

目的 | ON | OFF
SW3-1 | 内蔵フロッピィディスクの動作設定 *3 | 固定モード | 自動切替モード
SW3-2 | 640KBモード | 1MBモード
デスクトップ | SW3-3 | 内蔵HDDのDMA*4 | ＃１ | ＃０
SW3-4 | フロッピィモータ制御*5 | する | しない
ノート *6 | SW3-3 | LCD | ２段調 | ８段調
SW3-4 | LCD反転 | ノーマル | リバース
SW3-5 | DMAモード *7 | 互換モード | 高速モード
SW3-6 | メインメモリ *8 | 512KB | 640KB
SW3-7 | メモリウェイト *9 | ノーウェイト | １ウェイト (EPSONマシンのみ)
SW3-8 | CPUの指定 | 8086/80286/80386 | V30

Neko Project IIでの動作

*1 スーパーインポーズ機能はサポートしていません。
*2 内蔵フロッピィドライブは常に＃０，＃１になります。
*3 常に自動切替1MBモードになります。(PC-98後期タイプ)
*4 内蔵IDEタイプには意味がありません。(内蔵SCSI用)
*5 モータは制御しません。
*6 98ノート型ディップスイッチには対応していません。(Screen Optionで設定します)
*7 DMAモードは変更出来ません。(1動作/命令)
*8 常に640KBになります。
*9 常にノーウェイトになります。


Vermouth Implementation Chart

+ - +
| Function... | Transmitted | Recognized | Remarks |
- + - + - + -
Basic Default | X | 1 - 16 |
- + - + - + -
Note | X | 0 - 127 |
Number : True voice ********** 0 - 127
- + - + - + -
Velocity Note ON | X | O 9nH, v=1-127 |
Note OFF ********** X
- + - + - + -
After Key's | X | O |
Touch | Ch's | X | O
- + - + - + -
Pitch Bender | X | O 0-24 semi |
- + - + - + -
Control
Change 		0,32 | X | O | Bank Select
7,10,11 | X | O
6,38 | X | O | Data Entry
100,101 | X | O | PRN LSB,MSB
- + - + - + -
Prog | X | O 0 - 127 |
Change : True # **********
- + - + - + -
System Exclusive | O | O |
- + - + - + -
Aux : Local ON/OFF | X | X |
: All Notes OFF | X | O (123-127)
Message | X | X
+ - +
O : Yes
X : No


サウンドボード

PC-9801-14

ミュージックジェネレータボードと呼ばれ FM音源登場前のサウンドボードです。

Texas Instruments社のTMS2631-RI104が搭載され PSG 8チャンネルの発声が可能です。
1,2チャンネルはセンター(調節可能)、3～5チャンネルは右、6～8チャンネルは左固定ながらステレオです。
3～8チャンネルは４オクターブ同時出力ができ、エレクトーンのように音色を変更できるようになっています。

PC-9801-26/PC-9801-26K

かなり普及した一般的なFM音源ボードです。
26と26Kの違いは 80286の対応の有無でエミュレータではあまり関係ありません。

Yamaha社のYM-2203(OPN)が搭載され FM3音・PSG3音の発声が可能です。
PSGの音量がまちまち(一般にNEC純正は大きく、サードパーティ製は小さい)で、使用ソフトによっては PSGが大きすぎる事や全く聞こえない事がありました。
FM・PSGのバランス設定は Mixerダイアログで調節が可能です。

PC-9801-86

26音源ボード以後 OPNAの搭載したPC-9801-73音源が発売されましたが、高価だった為あまり普及されませんでした。
PC-9801-86は 73音源よりDSP機能を取り除いた廃価版です。

Yamaha社のYM-2608(OPNA)が搭載され FM6音・PSG3音・リズム6音の発声が可能です。
但し OPNA内蔵のADPCM機能は停止されられ、その代わりに独自PCM(一般に86PCMと呼ばれています)が搭載されています。

ちびおと

サークル MAD FACTORYより販売された、86音源ボードのADPCM機能を有効にするエナーブラキットです。
これを用いるとスピークボードと同等のADPCMを利用する事ができます。

PC-9801-118

Windows向けに作られたサウンドボードです。
FM音源チップがYMF-288となり 効果音モードが削除され、86PCMのかわりに WSSが搭載されています。

スピークボード

アイドルジャパン株式会社から発売された、PC-9801-86以前にOPNAを使用したサウンドボードです。

Yamaha社のYM-2608(OPNA)が搭載され FM6音・PSG3音・リズム6音・ADPCMの発声が可能です。
PC-88のサウンドボードIIと同機能で PC-88の時代から音楽を作成していた方々にはデータがそのまま利用でき、支持が集まったボードです。

スパークボード

スピークボードの上位ボードで 音美ちゃんと同機能です。

Yamaha社のYM-2608とYM-3438が搭載され FM12音・PSG3音・リズム6音・ADPCMの発声が可能です。

AMD-98

システムサコム社から発売されたサウンドボードです。

ステレオPSG9音+ドラム4音の発声が可能です。
この音源に対応されたゲームは殆どありません。


Sound ID 一覧

値 | 対応機種・設定
0x | PC-98DO+内蔵音源
1x | PC-98GS内蔵音源
2x | PC-9801-73 ポート188
3x | PC-9801-73 ポート288
4x | PC-9801-86 ポート188
5x | PC-9801-86 ポート288
6x | PC-9821Nシリーズ内蔵音源
7x | PC-9821Xシリーズ内蔵音源
8x | PC-9821Cシリーズ内蔵音源


ツール

ROMイメージ作成

GETROMVA
PC-88VA上で動作し、PC-88VA、バージョンアップボード(PC-88VA-91)のROMイメージを作成します。VAEGTOOLに含まれています。
関連webpage: 88VA Eternal Grafx
XDISK2VA
PC-88VAとWindowsマシンをRS-232Cクロスケーブルで接続することにより、Windows上からPC-88VAのROMイメージを取得します。また、PC-88VAのディスクドライブを読んでディスクイメージを作成します。
関連webpage: 88VA Eternal Grafx
GETBIOS
PC-98x1のMS-DOS上で動作し、PC-9801のBIOS.ROM、フォントROM、SOUND.ROMのイメージを作成します。
関連webpage: ねこープロジェクトII の「NP2 tool」

ディスクイメージ作成

make_hd
ぶるー氏作のPC-9801シリーズ上でフロッピーディスクをD88形式でファイル化するツールです。
PC-8801mkIISRエミュレータ P88SRに含まれます。
関連webpage: ぶるー牧場
DITT
cisc氏作のPC-ATマシン上でフロッピーディスクをD88形式でファイル化するツールです。
関連webpage: M88のページ
XDISK2
cisc氏作のツールで、PC-8801シリーズとWindowsマシンをRS-232Cクロスケーブルで接続することにより、PC-8801のディスクドライブを読んでディスクイメージを作成します。
関連webpage: M88のページ
XDISK2VA
PC-88VAとWindowsマシンをRS-232Cクロスケーブルで接続することにより、Windows上からPC-88VAのROMイメージを取得します。また、PC-88VAのディスクドライブを読んでディスクイメージを作成します。
関連webpage: 88VA Eternal Grafx
Virtual Floppy Image Converter
RED氏作のディスクイメージコンバートツールです。
ディスクイメージをコンバートするツールですが、実ディスクからのコンバートも可能です。
関連webpage: Vector - Virtual Floppy Image Converter
ディスク イマージュ
長谷川氏作のWindows95/98用のディスクイメージ化ツールです。
PC-9801シリーズで一般的に使用する1.2MBディスクをPC-ATでイメージ化する場合 3モードドライブが必要です。
関連webpage: Vector - ディスク イマージュ

リズム音源音声データ

Fakerhythm


使用許諾条件

使用許諾

88VA Eternal Grafxは、個人的使用においては制限なく使用することができます。

知的財産権

本ソフトウェアの著作権、その他の知的財産権は、以下の者が所有しています。
(実際にはバイナリ配布者が所有することになります)

  • ねこーぷろじぇくとIIのソースコードについては、ねこさん開発ちーむが所有しています。
  • M88のソースコードについては、cisc氏が所有しています。
  • 88VA Eternal Grafxで追加されたソースコードについては、Project VA-EGが所有しています。

ソースコード

88VA Eternal Grafxのソースコードは、M88に由来する部分を除き、修正BSDライセンスとします。

コア部分とWindows/MacOS9部分については 再配布時の著作権表示の義務はありません。

M88に由来するソースコードには、M88の規定が適用されます。

営利目的での利用に関して

88VA Eternal Grafxの雑誌掲載等の営利目的での利用は 承諾なく行なえます。

ただし、88VA Eternal Grafxのバイナリを雑誌CD-ROMに収録するなどの、営利目的でのバイナリ再配布の場合には事前の連絡をお願いします。連絡先はWebサイトで確認してください。


Webサイト

http://www.pc88.gr.jp/vaeg/


簡単な導入方法 - 外部ファイル

簡単な導入方法 / 外部ファイル

外部ファイル

[VA]
実機のROMを保存したファイルが必要です。vaeg.exeと同じフォルダにおいてください。

[98]
88VA Eternal Grafx単体でもそれなりの動作をしますが、実機BIOS等のファイルを用意すると より実機に近づきます。
全てvaeg.exeと同じフォルダに置いて下さい。

Neko Project II Folder

VA????.ROM [VA]

実機のROMを保存した以下のファイルです。
専用のツール (getromva.exe) でファイル化して下さい。

VAFONT.ROM (320KB) システムメモリエリア バンク8,9(9はA0000-AFFFF)
VADIC.ROM (512KB) システムメモリエリア バンクC,D
VAROM00.ROM(512KB) ROMエリア0 バンク0～7
VAROM08.ROM(128KB) ROMエリア0 バンク8～9
VAROM1.ROM (128KB) ROMエリア1 バンク

bios.rom [98]

実機のBIOS ROMをファイル化した物です。
専用のツールでファイル化して下さい。

ダウンロード: getbios.lzh (PC-98シリーズ MS-DOS用)

font.rom [98]

実機のフォント ROMをファイル化した物です。
専用のツールでファイル化して下さい。

ダウンロード: getbios.lzh (PC-98シリーズ MS-DOS用)

font.romの他に BMP形式のフォントファイルも使用できます。

sound.rom [98]

サウンドボードに搭載されるBIOS ROMをファイル化した物です。
専用のツールでファイル化して下さい。

ダウンロード: getbios.lzh (PC-98シリーズ MS-DOS用)

2608_bd.wav ～ 2608_rim.wav

OPNAに搭載されているリズム音源を wave形式で録音したファイルです。
ねこープロジェクトIIで使用するには 44KHz 16bit モノラル 無圧縮形式である必要があります。

OPNAに搭載されているリズムは以下の通りです。

ファイル名 | 対応する音色
2608_bd.wav | バスドラム
2608_sd.wav | スネアドラム
2608_top.wav | シンバル
2608_hh.wav | ハイハット
2608_tom.wav | タム
2608_rim.wav | リムショット


PC-98x1シリーズ

かなり抜けがあります。

PC-9801 DESKTOP

Year | Name | CPU1 | CPU2 | Memory (KB) | VRAM (Text/Video/Other)
1982 | PC-9801 | 8086 5MHz |  | 128 | 8/96
1983 | PC-9801F1 | 8086-2 5/8MHz |  | 128 | 12/192
 | PC-9801F2 | 8086-2 5/8MHz |  | 128 | 12/192
 | PC-9801F3 | 8086-2 5/8MHz |  | 256 | 12/192
 | PC-9801E | 8086-2 5/8MHz |  | 128 | 12/192
1984 | PC-9801M2 | 8086-2 5/8MHz |  | 512 | 12/192
 | PC-9801M3 | 8086-2 5/8MHz |  | 512 | 12/192
1985 | PC-98XA model1 | 80286 8MHz |  | 512 | 12/512/GRCG
 | PC-98XA model2 | 80286 8MHz |  | 512 | 12/512/GRCG
 | PC-98XA model3 | 80286 8MHz |  | 512 | 12/512/GRCG
 | PC-9801U2 | uPD70116 8MHz |  | 128 | 12/96/GRCG
 | PC-9801VF2 | uPD70116 8MHz |  | 256 | 12/192/GRCG
 | PC-9801VM0 | uPD70116 8/10MHz |  | 384 | 12/192/GRCG
 | PC-9801VM2 | uPD70116 8/10MHz |  | 384 | 12/192/GRCG
 | PC-9801VM4 | uPD70116 8/10MHz |  | 384 | 12/192/GRCG
1986 | PC-9801UV2 | uPD70116 8/10MHz |  | 384 | 12/256/GRCG
 | PC-9801VX0 | 80286 8/10MHz | uPD70116 8MHz | 640 | 12/256/EGC
 | PC-9801VX2 | 80286 8/10MHz | uPD70116 8MHz | 640 | 12/256/EGC
 | PC-9801VX4 | 80286 8/10MHz | uPD70116 8MHz | 640 | 12/256/EGC
 | PC-98XL model1 | 80286 8/10MHz | uPD70116 8MHz | 1152 | 12/512/EGC
 | PC-98XL model2 | 80286 8/10MHz | uPD70116 8MHz | 1152 | 12/512/EGC
 | PC-98XL model4 | 80286 8/10MHz | uPD70116 8MHz | 1152 | 12/512/EGC
1987 | PC-9801VX01 | 80286 8/10MHz | uPD70116 8MHz | 640 | 12/256/EGC
 | PC-9801VX21 | 80286 8/10MHz | uPD70116 8MHz | 640 | 12/256/EGC
 | PC-9801VX41/Win | 80286 8/10MHz | uPD70116 8MHz | 640 | 12/256/EGC
 | PC-98XL2 | 80386 16MHz | uPD70116 8MHz | 1664 | 12/512/EGC
 | PC-9801UX21 | 80286 10MHz | uPD70116 8MHz | 640 | 12/256/EGC
 | PC-9801UX41 | 80286 10MHz | uPD70116 8MHz | 640 | 12/256/EGC
1988 | PC-9801CV21 | uPD70116 8/10MHz |  | 640 | 12/256/GRCG
 | PC-9801RA2 | 80386 16MHz | uPD70116 8MHz | 1664 | 12/256/EGC
 | PC-9801RA5 | 80386 16MHz | uPD70116 8MHz | 1664 | 12/256/EGC
 | PC-9801RX2 | 80286 10/12MHz | uPD70116 8MHz | 640 | 12/256/EGC
 | PC-9801RX5 | 80286 10/12MHz | uPD70116 8MHz | 640 | 12/256/EGC
1989 | PC-98RL model2 | 80386 16/20MHz | uPD70116 8MHz | 1664 | 12/512/EGC
 | PC-98RL model5 | 80386 16/20MHz | uPD70116 8MHz | 1664 | 12/512/EGC
 | PC-98RL model 21 | 80386 16/20MHz | uPD70116 8MHz | 1664 | 12/512/EGC
 | PC-98RL model 51 | 80386 16/20MHz | uPD70116 8MHz | 1664 | 12/512/EGC
 | PC-9801EX2 | 80286 8/12MHz | uPD70116 8MHz | 640 | 12/256/EGC
 | PC-9801EX4 | 80286 8/12MHz | uPD70116 8MHz | 640 | 12/256/EGC
 | PC-9801ES2 | 386SX 16MHz | uPD70116 8MHz | 1664 | 12/256/EGC
 | PC-9801ES5 | 386SX 16MHz | uPD70116 8MHz | 1664 | 12/256/EGC
 | PC-9801DO | uPD70116 8/10MHz | uPD70008C(Z80) | 640 | 12/256/GRCG
 | PC-9801RX21 | 80286 10/12MHz | uPD70116 8MHz | 640 | 12/256/EGC
 | PC-9801RX51 | 80286 10/12MHz | uPD70116 8MHz | 640 | 12/256/EGC
 | PC-9801RA21 | 80386 16/20MHz | uPD70116 8MHz | 1664 | 12/256/EGC
 | PC-9801RA51 | 80386 16/20MHz | uPD70116 8MHz | 1664 | 12/256/EGC
 | PC-9801RS21 | 386SX 16MHz | uPD70116 8MHz | 640 | 12/256/EGC
 | PC-9801RS51 | 386SX 16MHz | uPD70116 8MHz | 640 | 12/256/EGC

1990 | PC-9801DO+ |
 | PC-9801DX2 |
1991 | PC-9801DA2 | PC-9801DA5 | PC-9801DA7 |
 | PC-9801DA/U2 | PC-9801DA/U5 | PC-9801DA/U7 |
 | PC-9801DS2 | PC-9801DS5 | PC-9801DS/U2 | PC-9801DS/U5
 | PC-9801UR |
 | PC-9801UF |
 | PC-9801CS2 | PC-9801CS5 | PC-9801CS5/W |
 | PC-98GS model 1 | PC-98GS model 2 |
1992 | PC-9801FA2 | PC-9801FA5 | PC-9801FA7 |
 | PC-9801FA/U2 | PC-9801FA/U5 | PC-9801FA/U7 |
 | PC-9801FX2 | PC-9801FX5 | PC-9801FX/U2 | PC-9801FX/U5
 | PC-9801FS2 | PC-9801FS5 | PC-9801FS7 |
 | PC-9801FS/U2 | PC-9801FS/U5 | PC-9801/U7 |
 | PC-9801US | PC-9801US40 | PC-9801US80 |
1993 | PC-9801BX/U2 | PC-9801BX/M2 | PC-9801BX/U6 |
 | PC-9801BA/U2 | PC-9801BA/M2 | PC-9801BA/U6 |
---- | PC-9801BX2/U2 | PC-9801BX2/M2 | PC-9801BX2/U7 |
 | PC-9801BA2/U2 | PC-9801BA2/M2 | PC-9801BA2/U7 |
 | PC-9801BX3/U2 | PC-9801BX3/U2W |
 | PC-9801BA3/U2 | PC-9801BA3/U2W |
 | PC-9801BX4/U2 | PC-9801BX4/U2/C |
 | PC-9801BX4/U2-P | PC-9801BX4/U2/C-P |
 | PC-9801BS2/U2 | PC-9801BS2/M2 | PC-9801BS/U7 |

PC-9801 NOTEBOOK

1989 | PC-9801N |
1990 | PC-9801NS |
 | PC-98HA |
 | PC-9801NV |
1991 | PC-9801NS/E |
 | PC-9801NC |
1992 | PC-9801NS/T | PC-9801NS/T 40 | PC-9801NS/T 80
 | PC-9801NS/L |
 | PC-9801NA | PC-9801NA 40 | PC-9801NA 120
 | PC-9801NA/C | PC-9801NA/C 40 | PC-9801NA/C 120
1993 | PC-9801NS/R | PC-9801NS/R 40 | PC-9801NS/R 120
---- | PC-9801NL/A | PC-9801NL/A 120 | PC-9801NL/A 260A
 | PC-9801NL/R |
 | PC-9801NS/A | PC-9801NS/A 120 | PC-9801NS/A 340
 | PC-9801NX/C | PC-9801NX/C 120 |

PC-9801 LAPTOP

1986 | PC-98LT
1988 | PC-9801LV
1989 | PC-9801LS2
 | PC-9801LX2
1990 | PC-9801TW2

PC-H98 series

1990 | PC-H98 model 60 | PC-H98 model 70 | PC-H98 model 100
1991 | PC-H98S model 8 |
 | PC-H98 model 80-002 | PC-H98 model 80-040 | PC-H98 model 80-100
 | PC-H98 model U80-002 | PC-H98 model U80-040 | PC-H98 model U80-100
 | PC-H98 model 90-002 | PC-H98 model 90-040 | PC-H98 model 90-100
 | PC-H98 model U90-002 | PC-H98 model U90-040 | PC-H98 model U90-100
1992 | PC-H98T |
 | PC-H98 model 105-100 | PC-H98 model 105-300 |
 | PC-H98 model U105-100 | PC-H98 model U105-300 |

PC-9821 series (1993-1996)

PC-9821 model S1 | PC-9821 model S2 |
PC-9821Ae/M2 | PC-9821Ae/M7 |
PC-9821Ae/U2 | PC-9821Ae/U7 |
PC-9821Af/M9W | PC-9821Af/U9W |
PC-9821An/M2 | PC-9821An/U2 |
PC-9821An/U8W | PC-9821An/C9T |
PC-9821Ap/M2 | PC-9821Ap/M7 |
PC-9821Ap/U2 | PC-9821Ap/U7 | PC-9821Ap/U9
PC-9821Ap/M7W | PC-9821Ap/U7W | PC-9821Ap/U9W
PC-9821Ap2/M2 | PC-9821Ap2/U2 |
PC-9821Ap2/U8W | PC-9821Ap2/C8P | PC-9821Ap2/C9W
PC-9821Ap3/M2 | PC-9821Ap3/U2 |
PC-9821Ap3/C8W | PC-9821Ap3/C9W |
PC-9821As/M2 | PC-9821As/M7 |
PC-9821As/U2 | PC-9821As/U7 | PC-9821As/U8
PC-9821As/M7W | PC-9821As/U7W | PC-9821As/U8W
PC-9821As2/M2 | PC-9821As2/U2 | PC-9821As2/U7W
PC-9821As2/U7P | PC-9821As2/U8W | PC-9821As2/U8P
PC-9821As3/M2 | PC-9821As3/U2 | PC-9821As3/C8W
PC-9821Be/U7W |
PC-9821Bf/U8W |
PC-9821Bp/U7W | PC-9821Bp/U8W |
PC-9821Bs/U7W |
PC-9821Cb model 2 | PC-9821Cb model 2D | PC-9821Cb model 2F
PC-9821Cb2/A | PC-9821Cb2/B |
PC-9821Cb2/M | PC-9821Cb2/T |
PC-9821Cb3/T model A | PC-9821Cb3/T model B |
PC-9821Cb10/T model A | PC-9821Cb10/T model B |
PC-9821Ce model S1 | PC-9821Cb model S2 |
PC-9821Cb2 model S1 | PC-9821Ce2 model S2 | PC-9821Ce2 model S2D
PC-9821Cb2 model T2 | PC-9821Cb2 model T2D |
PC-9821Cf model S3 |
PC-9821Cr13/T model A | PC-9821Cr13/T model B |
PC-9821Cs2 model S2 | PC-9821Cs model S3 |
PC-9821Ct16/F model A | PC-9821Ct16/F model B |
PC-9821Ct20/A model A | PC-9821Ct20/A model B |
PC-9821Cu10/D model A | PC-9821Cu10/D model B |
PC-9821Cu13/E model A | PC-9821Cu13/E model B |
PC-9821Cu16/H model A | PC-9821Cu16/H model B |
PC-9821Cx model S2 | PC-9821Cx model S3 |
PC-9821Cx2/S15B | PC-9821Cx2/S17B |
PC-9821Cx2/S15T | PC-9821Cx2/S17T |
PC-9821Cx3/S5T model A | PC-9821Cx3/S5T model B |
PC-9821Cx3/S7 model A | PC-9821Cx3/S7 model B |
PC-9821Cx13/S5T model A | PC-9821Cx13/S5T model B |
PC-9821Cx13/S7M model A | PC-9821Cx13/S7M model B |
PC-9821Es/340U | PC-9821Es/340N |
PC-9821Es/340NL | PC-9821Es/540N |
PC-9821La7/D5 model A | PC-9821La7/D5 model B |
PC-9821La10/5 model A | PC-9821La10/5 model B |
PC-9821La10/8 model A | PC-9821La10/8 model B |
PC-9821La10/S8 model C | PC-9821La10/S8 model D |
PC-9821Ld/260 | PC-9821Ld/350A | PC-9821Ld/350A2
PC-9821Lt/260 | PC-9821Lt/350A | PC-9821Lt/540A
PC-9821Lt2/3A | PC-9821Lt2/3D | PC-9821Lt2/7A
PC-9821Na7/H3 | PC-9821Na7/H7 | PC-9821Na7/HC7
PC-9821Na9/H8 |
PC-9821Na12/H8 | PC-9821Na12/H10 |
PC-9821Na13/H10 | PC-9821Na13/C10 |
PC-9821Na15/X14 |
PC-9821Nb7/D5 | PC-9821Nb7/C8 |
PC-9821Nb10/S8 | PC-9821Nb10/S10F |
PC-9821Nd | PC-9821Nd/340W | PC-9821Nd/810W
PC-9821Nd2 | PC-9821Nd2/3 | PC-9821Nd2/5
PC-9821Ne | PC-9821Ne 120/W |
PC-9821Ne2 | PC-9821Ne2/340W |
PC-9821Ne3 | PC-9821Ne3/3 | PC-9821Ne3/5
PC-9821Nf/340W | PC-9821Nf/810W |
PC-9821Nm | PC-9821Nm/340 |
PC-9821Np/340W | PC-9821Np/540W | PC-9821Np/810W
PC-9821Nr12/D10 |
PC-9821Nr13/D10 model A | PC-9821Nr13/D10 model B |
PC-9821Nr15/S10 | PC-9821Nr15/S14F |
PC-9821Ns/340W | PC-9821Ns/540W | PC-9821Ns/810W
PC-9821Nx/3 | PC-9821Nx/C7 |
PC-9821Ra20/N12 |
PC-9821St20/L16 |
PC-9821Ts | PC-9821Ts 120/W |
PC-9821V7/C4K model A | PC-9821V7/C4K model B |
PC-9821V7/S5K model A | PC-9821V7/S5K model B |
PC-9821V7/S7K model A | PC-9821V7/S7K model B |
PC-9821V10/C4R model A | PC-9821V10/C4R model B |
PC-9821V10/C4R model E | PC-9821V10/C4R model F |
PC-9821V10/S5K model A | PC-9821V10/S5K model B |
PC-9821V10/S5K model C | PC-9821V10/S5K model D |
PC-9821V10/S7K model A | PC-9821V10/S7K model B |
PC-9821V10/S7K model C | PC-9821V10/S7K model D |
PC-9821V12/S5R model A | PC-9821V12/S5R model B |
PC-9821V12/S7R model A | PC-9821V12/S7R model B |
PC-9821V13/S5R model A | PC-9821V13/S5R model B |
PC-9821V13/S5R model C | PC-9821V13/S5R model D |
PC-9821V13/S7R model A | PC-9821V13/S7R model B |
PC-9821V13/S7R model C | PC-9821V13/S7R model D |
PC-9821V13/M7 model C2 | PC-9821V13/M7 model D2 |
PC-9821V13/S5 model C2 | PC-9821V13/S5 model C3 |
PC-9821V13/S5 model D2 | PC-9821V13/S5 model D3 |
PC-9821V13/S5 model E2 | PC-9821V13/S5 model F2 | PC-9821V13/S5 model G3
PC-9821V16/M7 model C2 | PC-9821V16/M7 model C3 |
PC-9821V16/M7 model D2 | PC-9821V16/M7 model D3 |
PC-9821V16/S5 model C2 | PC-9821V16/S5 model D2 |
PC-9821V20/M7 model C2 | PC-9821V20/M7 model C3 |
PC-9821V20/M7 model D2 | PC-9821V20/M7 model D3 |
PC-9821V20/M7 model E2 | PC-9821V20/M7 model E3 |
PC-9821V20/M7 model F2 | PC-9821V20/M7 model F3 |
PC-9821V20/S5 model C3 | PC-9821V20/S5 model D3 |
PC-9821V20/S7 model C3 | PC-9821V20/S7 model D3 |
PC-9821Xa/U8W | PC-9821Xa/C9W | PC-9821Xa/C10W
PC-9821Xa7/C4 | PC-9821Xa7/C8 |
PC-9821Xa7e/S15 | PC-9821Xa7e/S17 |
PC-9821Xa9/C4 | PC-9821Xa9/C8 |
PC-9821Xa10/C4 | PC-9821Xa10/C12 |
PC-9821Xa10/K8 | PC-9821Xa10/K12 |
PC-9821Xa12/C8 | PC-9821Xa12/C12 |
PC-9821Xa12/K8 | PC-9821Xa12/K12 |
PC-9821Xa13/K12 | PC-9821Xa13/K16 | PC-9821Xa13/W12
PC-9821Xa16/R12 | PC-9821Xa16/R16 |
PC-9821Xa16/W16 | PC-9821Xa16/W30 |
PC-9821Xb10/J8 |
PC-9821Xc13/M7 | PC-9821Xc13/S5 |
PC-9821Xe/U7W |
PC-9821Xe10/C4 | PC-9821Xe10/S15 |
PC-9821Xe10/4 | PC-9821Xe10/4-P | PC-9821Xe10/C4-P
PC-9821Xf/U8W | PC-9821Xf/U9W |
PC-9821Xn/U8W | PC-9821Xn/U9W |
PC-9821Xp/U8W | PC-9821Xp/C9W |
PC-9821Xs/U7W | PC-9821Xs/U7WL | PC-9821Xs/C8W
PC-9821Xt/C10W |
PC-9821Xt13/C12 | PC-9821Xt13/K12 |
PC-9821Xt16/R16 |
PC-9821Xv13/R16 | PC-9821Xv13/W16 |
PC-9821Xv20/W30 |

EPSON PC-286 DESKTOP

1987 | PC-286 |
 | PC-286U |
 | PC-286V STD | PC-286V H20 |
1988 | PC-286VE |
 | PC-286X |
 | PC-286US |
1989 | PC-386 STD | PC-386 H20 | PC-386 H40
 | PC-286VS |
 | PC-286VF |
 | PC-386V STD | PC-386V H20 | PC-386V H40
 | PC-286UX |
1990 | PC-286VX |
 | PC-386M STD | PC-386M H40 |
 | PC-386VR STD | PC-386VR H40 |
 | PC-286VG STD | PC-286VG H40 |
 | PC-286C(PC CLUB) |
 | PC-386S STD | PC-386S H40 | PC-386S F1
 | PC-386G STD | PC-386G H100 | PC-386G F1
1991 | PC-386GE 2 | PC-386GE 3 | PC-386GE 5
 | PC-386GE 2E | PC-386GE 5E |
 | PC-386GS 2 | PC-386GS 3 | PC-386GS 5
 | PC-386GS 2E | PC-386GE 5E |
 | PC-286VJ |
 | PC-386P |
1992 | PC-486GR 2 | PC-486GR 3 | PC-486GR 5
 | PC-486GR 2E | PC-486GR 5E |
 | PC-486GF 2 | PC-486GF 3 | PC-486GF 5
 | PC-486GF 2E | PC-486GF 5E |
1993 | PC-486P 2 | PC-486P 2E | PC-486P WIN
 | PC-486GR+ 2 | PC-486GR+ 3 | PC-486GR+ 5
 | PC-486GR+ 2E | PC-486GR+ 5E |
 | PC-486GR Super 2 | PC-486GR Super 3 | PC-486GR Super 5
 | PC-486GR Super 2E | PC-486GR Super 5E |
---- | PC-486FE 1GW | PC-486FE 2 |
 | PC-486FR 1GW | PC-486FR 2 |
 | PC-486FS 1HW | PC-486FS 2 |
 | PC-486HG 2 | PC-486HG 3 | PC-486HG 5
 | PC-486HG 2GW |
 | PC-486HX 2 | PC-486HX 3 | PC-486HX 5
 | PC-486HX 2GW | PC-486HX 3JW |
 | PC-486ME 1LM | PC-486ME 1VM |
 | PC-486MR 2 | PC-486MR 2GW |
 | PC-486MS 2 | PC-486MS 2IW |
 | PC-486MU 2GW | PC-486MU 2GWM | PC-486MU 2IWM2
 | PC-486MV 2J | PC-486MV 2JM | PC-486MV 2JVM
 | PC-486RS 2 |
 | PC-486SE 2 |
 | PC-486SR 2 |

EPSON PC-286 NOTEBOOK

1989 | PC-286NOTE |
1990 | PC-286NOTE F |
 | PC-286BOOK |
1991 | PC-386NOTE A |
 | PC-386BOOK L |
 | PC-386NOTE W |
 | PC-386BOOK LC |
 | PC-386NOTE AE |
 | PC-386BOOK LX |
1992 | PC-386NOTE WR |
 | PC-386NOTE AR |
 | PC-386NOTE ARC |
1993 | PC-386NOTE ARX |
---- | PC-486NOTE AS 2 | PC-486NOTE 1D |
 | PC-486NOTE C2 | PC-486NOTE X2 |
 | PC-486NOTE AS | PC-486NOTE D2 |
 | PC-486NOTE AU 2 | PC-486NOTE AU C2 |
 | PC-486NOTE AU X2 | PC-486NOTE AU 2HT |
 | PC-486NOTE AU 2HT | PC-486NOTE AU C2HW | PC-486NOTE AU X2HW
 | PC-486NOTE AV 2 | PC-486NOTE AV C2 |
 | PC-486NOTE AV X2 | PC-486NOTE AV X1JW |


システムセットアップメニュー

ねこープロジェクトIIでは、PC-9801シリーズと同様のシステムセットアップメニューを内蔵しています。

この画面を呼び出すには、PC-9801シリーズと同様に HELP(End)キーを押しながらリセットしてください。