 ■ごあいさつ
■MSX規格の詳細
■主な特徴
■ヴァージョン履歴
■クレジット
■連絡と問い合わせ
■スタートアップガイド
■インストール編
■起動方法
■ロムイメージの起動方法
■ロムイメージメニュー
■外部ロムデータベース
■コナミ系ロムの組み合わせ詳細
■コナミのゲームを１０倍楽しむカートリッジ
■コナミの新１０倍カートリッジ
■ディスクイメージの起動方法
■ディスクドライブメニュー
■v-DRIVE
■テープイメージの起動方法
■カセットメニュー 詳細
■blueDECK (テープ/カセットエミュレーション）
■外部カセットデータベース
■その他の特殊機能
■コマンドライン詳細
■メニュー詳細
■ツールバー詳細
■左パネル部分詳細
■右パネル部分詳細
■ステータスバー詳細
■エミュレーション設定
■汎用機種
■C-BIOS 機種
■MSX以外の機種
■ビデオ設定
■サウンド設定
■PSG
■SCC
■MSX-MUSIC
■MSX-AUDIO
■MoonSound
■PCM
■コントロール設定
■キーボードの仕様
■ジョイスティックとマウスの仕様
■標準ショートカット構成 詳細
■パフォーマンス設定
■ファイル設定
■ポート設定
■その他設定
■言語選択
■マシン構成編集
■スロット構成編集
■メモリ構成編集
■チップ設定
■エキストラ設定
■ショートカット構成編集
■テーマの基礎
■controls(制御）
■triggers （トリガー）
■actions （アクション）
■トレイナー詳細
■メモリー内部の探索
■改造コードの使用方法
■デバッガ メニュー
■デバッガ詳細
■デバッガ ツールバー
■デバッガ ショートカット一覧
■トレースロッガー
■使用許諾条件


blueMSX はじめに

■ はじめに

blueMSXはMSXパソコンをエミュレーションする事の出来るウィンドウズアプリケーションです。　MSXのハードウェアの仕様などをソフトウェアでシミュレートします。　実際のMSXのような動作をし、MSX専用に開発された多くのソフトウェアを走らせる事ができます。

MSXパソコンは８０年代初期から９０年代中期まで多くの国（日本、韓国、ヨーロッパとして南米）で使用され、ユーザーに愛された機種です。　メーカー専用機種とは違い、MSX規格に準じてメーカーが独自の技術を生かし、個性あふれる互換機の商品開発を進められたのも人気のひとつと言えます。

MSXは互換性を保ちつつ、飛躍的に進化して行った機種でもあります。　現在blueMSXではMSX,MSX2とMSX2+を再現するようにデザインされており、v2.0から新たに待望のturbo-Rのサポートしました。　blueMSXのもうひとつの特徴として、MSX規格の先駆けとも言える、Spectravideo社のSVI-318とSVI-328への対応を実現した事です。　最近ではハード的に近い性能を有するColecovisionのサポートも実現でき、MSXを中心にしつつも、その枠を超えたエミュレーションを提供出来るようになりました。

blueMSXはDaniel Vikにより、２００３年の９月から開発がスタートしました。　２００４年の４月には開発メンバーも増え、Daniel Vik,Benoit Delvaux,Tomas Karlsson,Johan van LeurとRay Zero を中心に現在でも積極的に開発が進められるています。　同時に多くの方々から得たアドバイスやサポートのおかげで、飽きる事なく開発を続けてこられたと思います。　開発に援助いただい方々はクレジットのページにて、ご紹介させていただいております。


blueMSX MSX規格の詳細

■ MSX規格の詳細

こちらでは一般的に知られているMSXのスペックについて、世代別に紹介していきます。

machine configurations
第0世代 ColecoVisionとSVI318/328 | - ColecoVisionはMSX1と同じ種類のCPUとVDPを搭載していました。 - サウンドチップにはMSXのPSGとは比較的近い存在のTexas Instrument社の SN76489を搭載していました。 - MSX規格が誕生するきっかけとなった機種です。 - CPU、ビデオ生成チップ、PSG音源チップなどほぼMSXと同じ物を採用していました。 - SVI-BASICはMSX-BASICに非常に近い仕様です。
第1世代 MSX1 | MSX1規格の主要な仕様：: - CPU Zilog Z80A 3,579 MHz (8-bit) - 搭載RAMは 8 Kb から 64 Kb - MSX BASIC version 1.0 - ビデオ生成チップ(VDP) : Texas Instruments TMS-9918/TMS-9928/TMS-9929 - ビデオメモリ (VRAM) 16kB - 音源チップ: General Instruments AY-3-8910 Programmable Sound Generator.
第2世代 MSX2 | MSX2規格の主要な仕様：: - CPU Zilog Z80A 3,579 MHz (8-bit) - 搭載RAMは 64 Kb から 256 Kb (拡張可） - MSX BASIC version 2.0 / 2.1 - ビデオ生成チップ(VDP) : Yamaha V9938 - ビデオメモリ (VRAM) 16kB または 128Kb - 音源チップ: - General Instruments AY-3-8910 Programmable Sound Generator.
第3世代 MSX2+ | MSX2規格の主要な仕様：: - CPU Zilog Z80A 3,579 MHz (8-bit) 一部のマシンでは5.369 Mhzへ切り替え可能 - 搭載RAMは 64 Kb (拡張可） - メモリマッパシステム - MSX BASIC version 3.0 - ビデオ生成チップ(VDP) : Yamaha V9958 - ビデオメモリ (VRAM) 128Kb - 音源チップ: - General Instruments AY-3-8910 Programmable Sound Generator. - 多くの機種でMSX-MUSIC(Yamaha OPLL YM-2413)を標準搭載
第4世代 MSX Turbo-R | MSX Turbo-Rの主要な仕様：: - RISC CPU R800 (DAR800-X0G), 7. 159 MHz (16-bit) - CPU Zilog Z80A 3,579 MHz (8-bit) - 搭載RAMは 256Kb と 512Kb (拡張可） - メモリマッパシステム - MSX BASIC version 4.0 / 4.1 - ビデオ生成チップ(VDP) : Yamaha V9958 - ビデオメモリ (VRAM) 128Kb - 音源チップ: - General Instruments AY-3-8910 Programmable Sound Generator. - MSX-MUSIC(Yamaha OPLL YM-2413)を内臓 - PCM シンセサイザー 8bit (サンプルレート16kHz) - Turbo GTは標準でMSX-MIDIを搭載


blueMSX 主な特徴

■ 主な特徴

blueMSXv2.0からはfMSXのソースコードをすべて排除しましたが、それ以前のバージョンはMarat Fayzullin氏のfMSX2.7をベースにしています。　こちらの一覧ではblueMSXの特徴的な部分をご紹介させていただきます。

machine configurations blueMSX独自の機能
- 実際のカセットデッキの使い勝手を再現するために設けられた機能。　テープの取り出した箇所の記憶や、ロードを開始したいテープ位置をファイル名で指定するなど、他のエミュレーターにはない強力なテープマネージメント機能を搭載しています。
- わかりやすいGUIで難しいマシン構成編集などを使い易くサポート。
- エミュレーションの動作速度も自由自在に変えられます。　押している間だけ加速する、早回し機能もウリの一つ。
- 古めのTVの懐かしい雰囲気を再現するモニターモードを２種類用意し、主流の液晶モニターでも古いTVの再現ができます。
- バーチャルFDD機能の利用で、ディスク枚数の多いソフトのディスク交換を楽にサポート。

machine configurations 基本エミュレーション部分
 | 新しくウィンドウの仕様やインターフェースにテーマ性を導入。 エミュレーターの動作状況をインタラクティブにヴィジュアライゼーションガ可能になりました。
 | ユーザーによるテーマの新規作成とカスタマイズも自由にできます、
new | プラグイン構成の導入による、外部DLLの動作。 デバッガーとトレイナーはなどがすでに実装済み
improved | 多言語サポート
new | Turbo-R、SVI318/328とColecoVisionをサポート
updated | すぐに使えるようにセットアップされた標準機能
 | エミュレーション及、CMOSにおけるメモリレイアウトの最適化
 | 独自のMSXハードウェア構築が可能なマシン構成機能を搭載
updated | あらゆるロムとメガロムタイプをサポート
 | SRAM搭載ソフトへの対応
new | 拡張プリンターへのサポート
 | 自由にカスタマイズ可能なショートカット編集機能を導入、ほぼすべてのショートカットの割り当てと変更が可能。 もちろんショートカットをジョイパッドのボタンに割り当てる事も可能です。
updated | 多彩なショートカットキーにより、快適な操作をサポート
 | クイックセーブ機能搭載。 ファイルのネーミングとセーブ番号の改善
 | ステートセーブ機能の大幅改善 マシン構成の内容などすべてを保存し、より正確な復元継続が可能と同時に今度のバージョンとの互換性を向上。 要領節約のために自動的に圧縮保存します。
 | ウィンドウ位置の記憶
improved | 動作中にスクリーンセーバーやウィンドウズキーや変換キーなどを無効化できるオプション追加
improved | 動作中の安定性が見直され、再現性や正確性のあるエミュレーションを目指すため、新たにM1ウェイティングステートを導入、Z80、VDPとMSX-AUDIOのタイミングの改良が大幅におこなわれました、
improved | CPUの使用を最小限に留める様、最適化

machine configurations ビデオ関連
 | DirectDraw のハードウェアアクセラレーションを導入、VRAMとシステムメモリを併用し、パフォーマンスを改善。（恩恵を受けられるかどうかはご使用の環境に左右されます。
 | 16 and 32 bit 画面の両方での動作をサポート
 | DirectX 対応
 | PAL規格をサポート。３種類の画質再現モードから選択できます。 - 非PALモード - ノイズ無しのクリアモード - 不鮮明＋ノイズの有無 液晶ディスプレイでも、よりコンポジット出力らしい画像が再現できます。
 | 調整設定に ガンマ、明るさ、コントラススト、彩度を追加
 | 全画モニターエミュレーションに水平と垂直ストレッチモードを追加
 | スキャンラインと擬似RFモジュレーターエフェクトをスライダーによる調整が可能
 | インターレースモード
 | Scale2x モニターエミュレーション
improved | Hq2x と Hq3x モニターエミュレーション
 | フルスクリーンモード時の解像度の選択
 | 複数のビデオソースの自動認識
improved | タイミングの見直しと最適化により、Almost Real、Metal Limit、Turnix 2 やUnknown Realityなどのデモの再現性を向上。
 | オーバースキャン対応
 | MSX1と MSX2/2+それぞれの特有のパレットを正しく再現
 | 画面キャプチャー機能機能
 | FDDアクセス時の音への再現

machine configurations サウンド関連
 | MSX-AUDIOをカートリッジレベルで再現(パナソニックのカートリッジにおけるスイッチにも対応！
improved | PSG (AY8910とSN76489 音源チップ)再現、同期とDAエミュレーションの改善
 | PCMミュレーションのサポート
 | Moonsoundのサポート
 | SCC音源のサポート
improved | FM-PAC (YM2413 音源チップ) エミュレーション
improved | MSX-AUDIO (Y8950 音源チップ) エミュレーション
 | モノラルとステレオをサポート、切り替えも可能
 | ミキサーによる、各音源チップのボリュームとパンの制御
 | 音源の録音とWAVファイルへの出力が可能
 | オーバーサンプリング機能搭載、任意の音源にx8/x4/x2/x1の倍率で適応できます

machine configurations ファイル関連
updated | 多彩なマッパーに対応
updated | ロムの種類を自動認識
improved | ユーザーからも変更可能にすべく、外部にロムをデータベースを配置
updated | 外部ロムデータベース 旧式ファーマットと*.xmlフォーマット両方をサポート
updated | 外部テープイメージデータベース
 | ROM/DSK/CASとSTAファイルのドラッグ＆ドロップで一発起動
 | ファイルの関連付けで、ダブルクリックからの起動に対応
 | Dir as Dsk 機能搭載
 | ヴァーチャルFDDにより、複数のディスク入れ替えをファイルメニューを開く事無く、瞬時に切り替え可能
 | fMSX-DOSとfMSX98/ATとSVI318/328フォーマットへの読み書きをサポート
 | CASファイルへのセーブ機能追加
 | '最近使ったファイル'から、スピーディーなファイル選択
 | '最近使ったファイル'の記録数の設定と歴史の消去
 | ZIPによる圧縮されたROM/DSK/CASファイルの読み込みが可能。もし複数のイメージがZIPに含まれる場合は専用ウィンドウから選択可能。

machine configurations 操作関連
improved | 国別のキーボードに対応
 | ヴァーチャルキーボード搭載
 | キーボード構成編集
improved | ジョイスティックとマウスに対応


blueMSX ヴァージョン履歴

■ ヴァージョン履歴

machine configurations
blueMSXのヴァージョン履歴情報です。
blueMSX v2.3.1 06/24/05

リリースしたばかりですが、放置したくないバグが発覚してしまったので、デバッガの機能追加と修正を合わせて早めにリリースする事になりました。

デバッガーの更新内容：
- デバッガで日本語化をサポートしました。
- CPUレジスタウィンドウにアセンブリスタイルフラッグを追加
- ブレイクポイント/セットのダイアログでアドレスとシンボルを受け付けるようにしました。
- BiFi氏のブレイクポイントをアップデート（詳しい情報は後日公開との事）
- BiFi氏のデバッグコマンド追加
- ブロックコマンド上でステップオーバーが機能するようにしました。(ldir, cpir, otir, ....)

その他の修正点：
- ASCII SRAMマッパのバグを修正
- デバッガ用のショートカットにおけるバグを修正
- 大きな値でメモリアドレス入力が可能する様に変更
- デバッガ利用時にメモリとレジスタへの書き込みが失敗するバグを修正
- 一部の環境でデバッガのドロップダウンメニューの表示がおかしくなるのを修正
- VDPのバグによって、ゲーム’FEEDBACK'のイントロが失敗するのを修正。（スクリーンスプリット後に、コマンドエンジンがちゃんと継続して実行されます。）
- VDPにおけるPSETコマンド上のバグを修正。（FEEDBACKで星の表示が異常だったのを修正）
- フル画面モード時にメニューと同時にF12(リセット）を押すと起こる不都合を修正

ゲーマーに朗報です、blueMSX 2.2.0からトレイナープラグインが搭載されましたが、それと互換性のある改造ファイルをBiFi氏とVampier氏から提供していただきました。現在242個のゲーム用の改造ファイルが収録されおり、blueMSXと一緒に配布させていただいています。（両者に感謝！）

blueMSX v2.3.0 06/18/05

プリンターのサポート：
- MSX用プリンターとエプソンFX-80プリンターのエミュレーションの実装。
- テキストファイルへの出力も可能。
- プリンターポートをサウンドデバイスとして使用する事も可能。（SiMPLE/Covox DAC)

デバッガーの機能拡張：
- シンボルファイルのサポート(tniASM, asMSX, ...):
* ディスアセンブラーのシンボルの表示/非表示が可能
* メモリウィンドウにてシンボル名からアドレスの参照が可能
- スタックウィンドウ追加
- 'step into' 機能追加
- 'step out'　機能追加
- ブレイクポイントの有/無をオプションに追加
- メモリウィンドウに任意のアドレス又はシンボルにgotoダイアログを追加
- ヴィジブルメモリへの書き込みをサポート
- asMSXのデバッグコマンドのサポート（トレースロッガーに表示されます。）
- シンボルファイルとBiFi's氏のBREAKPOINTコマンドのサポート。（アセンブラーからbpをセット）
- デバッガーにおけるショートカット処理の修正

その他の変更点と追加：
- 日本語版バイナリでキーボードのレイアウトを日本語に標準化
- 新たにドイツ語とポーランド語をサポート
- イタリア語サポートの更新
- C-BIOS v0.21へのアップデート
- ブラジル系のMSX1とMSX2マシン構成の修正。（物理ドライブ１とロジカルドライブ２構成）
- MSX-MUSICの更新（Mitsutaka Okazaki氏のYM2413コアを新たにサポート）
- FDC音のサンプルをサポート。（もっと良い録音環境で収録した物を募集しています。　サンプル可能な方は是非ご連絡ください、日本語のメールでも受付ています。）
- テトリス2スペシャルの特殊ドングルのサポート
- 日本語キーにおいて、エミュレータ起動中に特殊キーを正常に無効化する機能を追加
- MSX-AUDIOにおける正しい周波数を実装。（現在50Khzで動作）
- ColecoVisionにおける正しいnoiseをサポート
- Hq2xとHq3xモードに発生していたパレットのバグ修正
- VDPにおける水平スクロールのバグを修正　(テトリス2スペシャル）
- VDPのアドレッシングにおけるバグの修正　(F-Nano 2）
- スプライトのコリジョン（接触）認識のバグを修正
- Screen 2のアドレッシングのバグ修正
- ジョイスティックの設定がリセット後”なし”に戻ってしまうバグを修正
- サブディレクトリにおける、”読み込みのみ”時のバグを修正

- その他軽微な不具合を修正しました
blueMSX v2.2.0 03/19/05

今回はエミュレーターの構成における自由度がさらに強化され、同時に互換性と安定性にも着目してみました。
- キーボードのマッピングを自由に変更できる構成編集機能を搭載。（ジョイパッドのボタンもキーとして割り当てられます。）
- プラグイン構成を導入し、外部DLLへのアクセスを可能にしました。　これにより、デバッガーとトレイナー（改造ユーティリティー）を実現しました。
- マルチページ構成をテーマに導入、システム構成、ミキサー、ビデオ設定やバーチャルキーボードなどをサポート
- 複数の(別々または同一）サウンドチップを搭載するために、音源の内部構造を大胆に改造しました。
- フルスクリーンモードにて、解像度の変更をかのうにしました。 （HWではなくDirectDraw時にて、液晶でもストレッチなしのクッキリした画像が表示できます。）

先日リリースされたopenMSX 0.5.1とのromデータベースを共有するため、XMLを使用した新しい構成を導入しました。　古いデータベースも使用可能ですが、blueMSXランチャー1.2はまだ新しい構成に未対応です。（旧フォーマットは次のバージョンから使えなくなる予定。）

その他の主な修正点と更新です：
- C-BIOSのｖ0.20を同封
- 汎用MSX2構成におけるFM-PACをMSX2+のチップにPAC構成に変更しました
- PSG搭載のみの汎用MSX2を追加
- 汎用マシン構成をより、実際の機種に近い構成んに変更。（注意：MSX2,MSX2+,Turbo-Rはすべて、メモリのみ512kbにはしてあります。）
- オランダと韓国版のMSX-MUSICカートリッジの新マッパーを搭載
- Sony HBI55 カートリッジをサポート
- 正確なSVI-32のFDCをサポート
- ビデオソースの自動認識を搭載し、SVI-806ビデオカード(80行対応CRTC6845)をサポート。（将来的なGFX9000の再現への第一歩です。）
- V9958チップの192kb VRAMをサポート
- フロッピードライブのタイミングの無効化を最適化
- モニターの色選択にアンバー色を搭載
- Hq2xスケーラーを搭載（1024x768以上の解像度にてHq3xに自動的に切り替わります。）
- 色むらの再現する、RF-モジュレーター機能を搭載。
- SCC,MSX-MUSICとMSX-AUDIOのフィルタリングの向上。（とくにSCCは複数の実機からの録音とヒアリングを繰り返し参考にしました。）
- パラレルとシリアルポートの搭載
- セーブステートにブレビュー画像を追加
- コレコビジョン用の*.col拡張子ファイルをサポート
- PSG音源におけるバグ修正
- セーブステートの不都合を修正
- MSX-AUDIOの初期化におけるバグ修正
- メニューを使用した際のパフォーマンスロスの不都合を修正
- MSX2版ドラゴンクエストIIのタイトルのスプライトの抜けを修正
- 他、色々修正＆最適化
blueMSX v2.1.0 12/25/04

クリスマスという事で2つサプライズを用意してました、我々からのプレゼントだと思ってください。
- まず一つ目は正式にColecoVisionへの対応をした事です、こちらもSVI同様MSXに大変似たところがあるために再現できました。
- 二つ目は同時Sam Elsharif氏の作成したblueMSX Launcher V1.1を公開出来る事です。
その他の主な修正点と更新です：

- フロッピードライブのタイミングを無効化するオプションを追加
- レジストリへの設定保存の有無が選択可能、標準は使わないようになっています。
- ディスクメディアの認識率の向上。
- マシン構成ファイルのアップデート、C-BIOS 0.19への対応と搭載
- GT上でA1内蔵ソフトからV-SHELLへの復帰の不都合を修正
- 一部のパナソニック系マシンにおける、パナソニックROMマッパーに不都合を修正
- EIDOLON(ポニカ)における、VDPコマンドエンジンにおける画像破損を修正
- スクリーン3におけるレンダリングのバグを修正。
- GIGAMIXのソフトにおける、インタレースのバグを修正
- Sex Bomb BunnyでPSGが暴走するのを修正
- ROM Disk Magazinesにおけるマウスのバグを修正
- PCMの再生速度が条件によって遅く再生される問題を修正
- ファイルへの関連付けが新しくインストールした方に割り当てられないの不都合を修正
- カセットのファイル経歴から選択した際の”挿入後の自動巻き戻し”が機能しない不都合を修正
- コマンドライン命令でcasとcaszipが機能しない問題を修正
- カセット専用のフォルダーが作成されないため、情報がちゃんと保存されない問題を修正
- R800の周波数選択メニューの不都合を修正
- カセットでセーブした際に、作成されたファイルにゴミが含まれる問題を修正
- ドラッグ＆ドロップした際に、ネーミングに空白があるファイルで読み込みが失敗する現象を修正。
blueMSX v2.0.0 11/20/04

ついにblueMSXのv2.0のリリースです！　約２ヶ月間の開発期間を経て、Turbo-Rのサポートを実現させる事ができました。もちろんPCMの再生（のみ）やTurbo-R専用S-RAMもしっかりサポートしています。 MIDIへの対応はまた次回になる予定です。 えーと今回のアップグレードはそれでだけに留まりません！　なんと、MSXの原型といわれる、Spectravideoの名機SVIシリーズのエミュレーション機能も搭載。　今回新たに開発メンバーに加わったTomas Karlssonの全面的な協力から実現できた、SVI-318とSVI-328のエミュレーション機能です。

- パナソニックのFDDコントローラーのタイミング修正
- 新たにWestern DigitalののFDDコントローラーを搭載、更に4つのマッパーを追加：ナショナル/Daewoo、フィリップス/ソニー、MicrosolとSVI-738
- 基本構成機種として新たに：ドイツ仕様のMSX1/スウェーデン仕様のMSX1/スペイン仕様のMSX2
- マシン構成種類の拡張、ドライブ未搭載の機種など
- 既存のマシン構成をすべて更新し、適したFDDコントローラーを使用するように変更
- 新しくマッパーにデジタルからアナログにコンバートする物を搭載：新世Sizer・牌の魔術師などに対応
- MSX-AUDIOのDACをサポート
- ポーズスイッチの搭載
- 外部拡張RAMマッパーに対応
- ビデオ周波数の選択を可能にしました。
- 描画モードにモニターモードを追加。（Turbo-RのS端子出力を想定して）
- ショートカットから最小化が可能になりました。
- MSX-MUSIC/MSX-AUDIO/MOONSOUND各種に対してオーバーサンプリングを適応できるようになりました。
- エミュレーターに割当てるプライオリティブーストの選択を追加。
- FDDの搭載数を一基または二基から選択が可能。（マシン構成編集から変更）
- Z80/R800各プロセッサーの周波数の設定が可能。（マシン構成編集から変更）
- コマンドラインの定義を新しく追加。
- ショートカットから、CPUのトレースを利用するか選択が可能。（開発者向け）
- テープイメージのデータベースを新しく追加し、ロムデータベースは内容の更新がされました。
- VDPのタイミングにおける複数のバグ修正。
- CPUにおけるオーバーフローの探知のバグ修正

- 今後の互換性の向上のためにセーブステート機能のコードを全面的に書き直しを行いました。（テープイメージの位置記憶も可能）
- テーマ規格を2.0に変更、新たに複数のトリガーとアクションの追加。　スライダーのサポートやシステムフォントの使用、ウィンドウの枠組みを排除するなどの機能が追加されました。
- 最後にfMSXのコードをすべて廃止し、オリジナルもしくはオープンソースの物と書き換えを行いました。

blueMSX v1.7.0 9/20/04

- M1ウェイトステートの導入でZ80,VDPとMSX-AUDIOのタイミングの最適化が行われました。　これにより、動作の全体的な正確性や再現性の向上が大幅に図られました。　再現性においてはかなり多くの部分が改善され、一部で他エミュレーターより実機に近い動作をすると思います。

- 新たにパナソニックTC8566AFフロッピードライブコントローラーのエミュレーションを搭載。　パッチで動作していたfMSX特有のDISK.ROMの必要が無くなくなり、制限されていた多数のソフトの動作が実機に限りなく近くなったため互換性が格段と向上しました。 (ラプラスの魔、正規版SD-Snatcher/Snatcher、Fony Demo Disk 2などが正常に動作するようになりました。）

- Dir as Dir機能の搭載
- ウィンドウの配置の記憶
- ユーザーによる、テーマ(スキン)の新規作成やカスタマイズが自由に行えるようになりました。
- 真のインターレースモードを採用
- 8kbのロムマッパーの自動認識率を向上
- Screen8の画質とMSX2+上の画質向上
- ロムマッパーの選択ドロップダウンメニューの改善
- Moonsoundの見直し、openMSX開発チームのWouter Vermaelen氏の協力をいただきました。（こちらのバグフィックスは時期openMSXにも採用されるそうです。）
- SCC/SCC+ のオプションの削減と見直し
- MSX-AUDIOとMoonsoundにおけるバグ修正
- MSX2+上の水平スクロールげ生じたバグを修正
- VDP上で発生して様々なバグの除去
- Super Pierrot mapper (ascii16nf)で起きていたバグを修正
- メニューの書き換えの際に起きていたバグを修正
- 空dsk/casイメージの作成の際に無反応になるバグ修正
- カセットの位置セットの際にファイル名が正しく表示されないバグを修正
- slot1とslot2のファイルダイアログの表示が正しくなかったのを修正
- 階層を含むZIP書庫の使用時に画面キャプチャーが失敗する現象を修正
blueMSXのヴァージョン履歴情報です。
blueMSX v2.0.0 11/20/04

ついにblueMSXのv2.0のリリースです！　約２ヶ月間の開発期間を経て、Turbo-Rのサポートを実現させる事ができました。もちろんPCMの再生（のみ）やTurbo-R専用S-RAMもしっかりサポートしています。 MIDIへの対応はまた次回になる予定です。 えーと今回のアップグレードはそれでだけに留まりません！　なんと、MSXの原型といわれる、Spectravideoの名機SVIシリーズのエミュレーション機能も搭載。　今回新たに開発メンバーに加わったTomas Karlssonの全面的な協力から実現できた、SVI-318とSVI-328のエミュレーション機能です。

- パナソニックのFDDコントローラーのタイミング修正
- 新たにWestern DigitalののFDDコントローラーを搭載、更に4つのマッパーを追加：ナショナル/Daewoo、フィリップス/ソニー、MicrosolとSVI-738
- 基本構成機種として新たに：ドイツ仕様のMSX1/スウェーデン仕様のMSX1/スペイン仕様のMSX2
- マシン構成種類の拡張、ドライブ未搭載の機種など
- 既存のマシン構成をすべて更新し、適したFDDコントローラーを使用するように変更
- 新しくマッパーにデジタルからアナログにコンバートする物を搭載：新世Sizer・牌の魔術師などに対応
- MSX-AUDIOのDACをサポート
- ポーズスイッチの搭載
- 外部拡張RAMマッパーに対応
- ビデオ周波数の選択を可能にしました。
- 描画モードにモニターモードを追加。（Turbo-RのS端子出力を想定して）
- ショートカットから最小化が可能になりました。
- MSX-MUSIC/MSX-AUDIO/MOONSOUND各種に対してオーバーサンプリングを適応できるようになりました。
- エミュレーターに割当てるプライオリティブーストの選択を追加。
- FDDの搭載数を一基または二基から選択が可能。（マシン構成編集から変更）
- Z80/R800各プロセッサーの周波数の設定が可能。（マシン構成編集から変更）
- コマンドラインの定義を新しく追加。
- ショートカットから、CPUのトレースを利用するか選択が可能。（開発者向け）
- テープイメージのデータベースを新しく追加し、ロムデータベースは内容の更新がされました。
- VDPのタイミングにおける複数のバグ修正。
- CPUにおけるオーバーフローの探知のバグ修正

- 今後の互換性の向上のためにセーブステート機能のコードを全面的に書き直しを行いました。（テープイメージの位置記憶も可能）
- テーマ規格を2.0に変更、新たに複数のトリガーとアクションの追加。　スライダーのサポートやシステムフォントの使用、ウィンドウの枠組みを排除するなどの機能が追加されました。
- 最後にfMSXのコードをすべて廃止し、オリジナルもしくはオープンソースの物と書き換えを行いました。

blueMSX v1.7.0 9/20/04

- M1ウェイトステートの導入でZ80,VDPとMSX-AUDIOのタイミングの最適化が行われました。　これにより、動作の全体的な正確性や再現性の向上が大幅に図られました。　再現性においてはかなり多くの部分が改善され、一部で他エミュレーターより実機に近い動作をすると思います。

- 新たにパナソニックTC8566AFフロッピードライブコントローラーのエミュレーションを搭載。　パッチで動作していたfMSX特有のDISK.ROMの必要が無くなくなり、制限されていた多数のソフトの動作が実機に限りなく近くなったため互換性が格段と向上しました。 (ラプラスの魔、正規版SD-Snatcher/Snatcher、Fony Demo Disk 2などが正常に動作するようになりました。）

- Dir as Dir機能の搭載
- ウィンドウの配置の記憶
- ユーザーによる、テーマ(スキン)の新規作成やカスタマイズが自由に行えるようになりました。
- 真のインターレースモードを採用
- 8kbのロムマッパーの自動認識率を向上
- Screen8の画質とMSX2+上の画質向上
- ロムマッパーの選択ドロップダウンメニューの改善
- Moonsoundの見直し、openMSX開発チームのWouter Vermaelen氏の協力をいただきました。（こちらのバグフィックスは時期openMSXにも採用されるそうです。）
- SCC/SCC+ のオプションの削減と見直し
- MSX-AUDIOとMoonsoundにおけるバグ修正
- MSX2+上の水平スクロールげ生じたバグを修正
- VDP上で発生して様々なバグの除去
- Super Pierrot mapper (ascii16nf)で起きていたバグを修正
- メニューの書き換えの際に起きていたバグを修正
- 空dsk/casイメージの作成の際に無反応になるバグ修正
- カセットの位置セットの際にファイル名が正しく表示されないバグを修正
- slot1とslot2のファイルダイアログの表示が正しくなかったのを修正
- 階層を含むZIP書庫の使用時に画面キャプチャーが失敗する現象を修正
blueMSX v1.6.0 7/27/04

- ショートカットのカスタマイズを支援する専用エディターを搭載：　ユーザーは自由にショートカットの割り当て、編集が可能。　ジョイスティック/ジョイパッドのボタンに対してもショートカットを割り当てる事ができます。　複数のプロファイルに分けて保存ができます。　標準でNLMSXとParaMSXから移植したショートカットプロファイルを同封、他エミュレーターのショートカットに慣れたユーザーをフォロー。

- 新たな追加オプションとして、インタフェースのテーマ化を採用。テーマ第一弾として、"DIGIblue"を搭載し、動作中のマシンの種類やイメージファイル情報の表示、オーディオ出力などをビジュアルを通じて確認することが出来るようになりました。（マシンのリソースをほとんど消費しません。）

その他の変更点：
- インターフェースに新たに韓国語を追加
- ジョイスティック・ジョイパッドの入力にDirectXを導入
- ジョイスティックの設定ダイアログを更新
- 調整設定に ガンマ/明るさ/コントラスト/彩度を追加
- スキャンラインの有無と微調整を可能にする設定とスライダーの追加
- スクリーンショットに新モードを追加： オリジナルモード、(544x240ピクセル）の大画面補正無しモード、（272ｘ240ピクセル）の小画面補正無しモード
- MSX-AUDIOエンジンを最近のソースと入れ替えと調整
- キークリックエミュレーションの更新
- ロムデータベース（romdb.dat）の更新と完全外部化、ユーザー自身のカスタム登録も可
- カセットイメージ用のデータベース(casdb.dat)とディスクイメージ用のデータベース(dskdb.dat)を搭載
- zip圧縮されたロムにおいて、ロムタイプの選択が可能
- スプライト表示の有無が切り替え可能
- rom/dskイメージをドラッグ＆ドロップした際にどちらのスロット/ドライブが標準なのか設定可能
- ロムデータベースに未登録の場合に標準マッパータイプの選択が可能
- FS-4500 と FS-4700において、文節のマッパーの誤動作を修正。　漢字変換が正常になりました。
- エミュレーション中にASCII8タイプのロム取り出しをした際に起こるバグを修正。
- オーディオバグ修正： PSGサンプルの再生を正常化
- オーディオバグ修正： パナソニック (FS-CA1)MSX-AUDIOを使用した際に、対応ソフトを認識させる際にpoke分が不要になりました。コンパイルのディスクステーションやロムソフトのラビリンスやゼビウスなどでMSX-AUDIOがお楽しみいただけます。
- 起動の際に作成されるはずのディレクトリーで生じたバグを修正
- 最小化した際にエミューションの停止させずに、ビデオのレンダリングのみを無効化
blueMSX v 1.5.0 6/12/04 - エミュレーション部分におけるタイミングスキーム並びにDirectDrawの全ての書き換えと最適化が図られました。　結果的に遅いPC(<1.4Ghz)にて、より優れたフレームレートの実現とサウンド面の割り込みが減少させることできました。

- MSX1のエミュレーションの改善：使用されるパレットの再現性、CMOSの無効化。

- MSX2/2+モードにおけるRTCの再現、テストとアラームレジスターも含まれます。

その他の変更点：
- カウンターの設置: fpsの表示とエミュレーターにおけるCPUリソースの使用率
- ツールバーへ新たにポーズと停止ボタンを追加
- フィンランド語に対応
- SCC/SCC+のマッパー各種に対応
- セーブステートのZIP化をサポート
- ROM種類の選択ををファイルメニューに追加
- 水平ストレッチの改善
- Screen8におけるスプライトパレットの修正
- dsk/romファイルをダブルクリックした際のバグ修正:エミュレーターはクリックしたファイルのみを起動します。（すでに挿入されているカートリッジは自動的にイジェクトされます。）;blueMSXが既に動作中である場合は、ダブルクリックは起動中のエミュレーターのみに反応します。
- 高クロック時におけるマウスの無反応の修正
- エミュ動作中（エミュの上）にてダイアログボックスの移動にて、エミュレーターが反応しなくなるのを修正
- フルスクリーン時のプロパティーのバグを修正
- ツールバーの停止/再生ボタンのアップデートの不都合を修正
- オプション/エミュレーションにリセットの無効化のチェックボックスを追加
- Namcotのゲームにおいて、発生するSCREEN1のVDP問題を修正
- ディスクパッチのバグ修正：VDPコマンドの初期化が正しく行われるようになりました。(Disk Station 17 BGV #13とルーンマスターIIIのグラフィックが正しく表示されるようになりました。)
- マシン構成編集のドロップダウンメニューの不都合を修正：ドロップダウンの外をクリックした際に設定値がリセットされない
- ミキサーにおけるバグ修正（モノラル時のボリュームバランススライダー）
- Screen6の水平スクロールのスプライトエミュレーションのバグ修正
- グラフィカルインターフェースのバグ修正
- MSX1使用時のセーブステートのバグ修正
blueMSX v 1.4.1 5/10/04 blueMSX v1.4.1における主な新機能と改良点はこちらです、今回は主にサウンド面の強化とユーザーリクエストへの対応がメインとなっております。

- blueTVに新しいく追加された機能
* 全画モニターエミュレーションに水平と垂直ストレッチモードを追加
* DirectDraw のハードウェアアクセラレーションドライバーを導入、ビデオをとシステムメモリを併用し、パフォーマンスを最適化。（恩恵を受けられるかどうかはご使用の環境に左右されます。）

- blueAUDIOにおける新機能と更新された機能
* サウンドミキサー部分の微調整
* Moonsoundの修正（ノイズに対応）
* MSX-AUDIOをカートリッジレベルで再現(パナソニックのカートリッジにおけるスイッチにも対応）
* SCCの改善

- 標準マシン構成にフランス語とドイツ語のMSX2を追加
- パフォーマンスの向上の更に小さなサウンドバッファ値を追加
- di1, di2, mx1, mx2などのファイルタイプをサポート
- ”ファイルの関連付け”設定を追加、ダブルクリックで一発起動
- ロムデータベース機能を追加、blueMSXのルートにromdb.datが無い場合は作成
- カートリッジスロットに漢字ロムをサポート
- Korean 90-in-1 ロムのサポート
- その他のサブメニューにPACとMegaram機能を追加
- マウスとジョイスティックの設定をセーブステートに保存
- マウスの互換性を向上
- マウスの左ボタンを押しながらの起動で、”マウスをジョイスティックとして使用”
- ”Joystick in Port #1” を ”Port #1”表記変更
- blueMSX使用中にWindowsキーの無効化のオプションを追加
- Screen 0における、スプリットスクリーンの修正（Anma's Relaxのスクロールが正しく表示）
- VDPコマンドの同期と待ちに対応するためのディスクパッチをアップデート(Xak3 -ガゼルの塔における画像の不都合を修正）
- スプライトのアドレッシングをアップデート
- zip圧縮されたcasファイルをテープ位置セットした際に起こる不都合を修正
- NT4とWIN95へのサポート
blueMSX v 1.4.0 4/24/04 - MOONSOUNDへの対応
- 新しく光栄のメガロムマッパーを追加。　おそらくMSXエミュレーターで初めて正確な(8kBと32kB)ロムの認識が可能になりました。 主に1991年以降に発表されたSRAMを搭載した作品において、ただしく内臓SRAMに保存ができるようになりました。
- ほかに不都合のあったSRAM搭載ソフトへの対応　（SUPER大戦略など）
- オーバースキャンへの対応　（Matra産のソフト、Unknown Realityなどが正しく動作。）
- セーブステートのバージョンコントロール　（過去のバージョンのセーブステートの互換性の保守とロードエラー防止）
- ロムデータベースの更新
- 日本語キーへの変更　（数字キー側のENTERを有効に、MSX側の実行キーを変換へ割り当て、取り消しを無変換に割り当て）
- マウスボタンのバグフィックス、（原宿アフターダーク、首切り館など）
- screen 0 width 80におけるバグフィックス。
- screen 1-3 のスプライトの当たり判定と描画の修正
- ”テープを読み込み専用にする”のオプションが逆転していたのを修正。
- セーブステートのオーディオチップの情報がセーブされないのを修正
- メニューの表記や翻訳ミスを修正
blueMSX v 1.3.0 4/11/04 - イタリア語をサポート
- MSX2にアラビア、ブラジル、そしてロシアの標準設定を追加
- パナソニック系機種のフロントサイドスイッチに対応、内蔵ソフトの立ち上げ有無の選択可能になりました。
- Holy Quran、松下、パナソニック、文節、ナショナル、などの専用マッパーを追加
- マウスサポートの強化 (一部の未対応ソフトもありますが、プリンセスメーカーなどの動作確認は取れております。）
- ショートカットによるマウスのキャプチャー
- ディスク切り替えを円滑に行うために開発された、バーチャルドライブ通称v-DRIVEを搭載。　ゲーマーを協力にサポート！
- 起動中にスクリーンセイバーを解除するオプション追加。
- ソフトの実行速度を早送り出来る、blueSPEED機能追加。
- ”最近使ったファイル”の記録と消去が可能。(記憶数も設定可能）
- ステートセーブの強化、v1.3.0からはすべてのメモリ状況を保存するように変更されました。　ネーミング方法も変更。
- 日本語のキーボードへの対応！
- MSX2+のscreen4と6において、水平スクロールへの対応。
- VDPのタイミングの修正 (一部ソフトのちらつきを排除）
- メニュー経由でのスクリーンキャプチャーのバグを修正
- PSGサンプル再生時のバグを修正
- フル画面モードの際にタイトルバーのダブルクリック時に生じるバグを修正
- screen10と12モードにおいて、水平スクロールで生じる色の壊れを修正。
blueMSX v 1.2.0 3/4/04 - インターフェースへの対応
- VDPからZ80への同期を向上をはかりました。
- MSX-AUDIO, MSX-MUSICの有無の切り替え
- エミュレーションの速度の制御をスライダーとショートカットにて可能
- スピードの変更した際も音楽が鳴るようにしました
- カートリッジとディスクの挿入にショートカットの割り当て
- FM-PACとSRAMのサポート
- 多言語サポート　オランダ語、英語、フランス語、日本語、ポルトガル語、スペイン語とスウェーデン語
- DSK/ROM/CASファイルのフォルダーの記録
- コマンドラインへの対応
- スプライトの当たり判定の向上
- 大きなスプライトへの対応
- スタート/ポーズとヘルプボタンの追加
- ディスクのハンドリングとフォーマットのバグフィックス
- Z80のタイミングのバグフィックス (TZRなど）
- スクリーン12の水平スクロールのバグフィックス
- VDPのアドレッシングにおけるバグでデモの動作が以上だったのを修正
- AY8910のバグフィックスにて、サンプル音の再生を修正
- ASCIIロムマッパーのバグを修正
blueMSX v 1.1.1 2/5/04 - MSX2+の水平スクロールへの対応
- Screen7と8の正しいVRAMアドレシングを修正
- 256/512ピクセルスクリーン分離の動作を修正
- PSGとSCC音源の向上
- メガロムのR-TYPE、は～りぃふぉっくす、クロスブライムへ対応
- 韓国のMSXとMSX2をサポート
- CASファイルのサポート
- キーボードの入力にDirectXを導入（win9xやAZERTY配列のキーボード問題を修正）
- MSX-MUSICとMSX-AUDIO使用時にもステートセーブ可能
- Capsロックとカナキーのインジケーターの表示
- 初期ディスク挿入の際に生じるバグを修正
- メガロムマッパーのバグを修正
- Z80オプコードの更新
- その他多数の不都合を修正
blueMSX v 1.1.0 1/15/04 - メガロムASCII8/ASCII16のSRAM搭載タイプをサポート
- ラム搭載のSCC+メガロムをサポート
- ソフトウェアリセットに対応(RAMの内容が消去されない）
- エミュレーション中にメガロムの挿入と取り外しに対応
- - MSX-AUDIOをサポート
- PSG音源の向上
- CPUのクロック選択が可能
- スクリーンキャプチャ機能を追加
- フリッカー減少の為に、ビデオレンダリングを修正
- マニュアルを作成
- インタフェースにツールバーを追加
- XPスタイルへの対応（XP使用時のみ）
- ステートロードの読み込み失敗の不都合を修正
- ロムマッパーのコマンド読み出しの失敗を修正
- ZIPファイル使用時に、コナミのロムの組み合わせで挙動不審だったのを修正
- CPUセーブステートのキャンセル時にクラッシュするのを修正
- 見た目と多数のマイナーバグを修正
blueMSX v 1.0.5 12/7/03 - 出力にステレオとモノラルを追加
- ミキサー機能を搭載、ボリューム、パンなど、音源チップ毎に調整可能
- ZIPに圧縮された（複数の）ROM/DSKファイルへの対応
- SCREEN6,SCREEN7とTEXT80において、512ピクセルをサポート
- SCREEN8の256色をサポート
- Scale 2xのモニターレンダラーを追加
- プログラムアイコンからドラッグ＆ドロップで一発起動が可能
- PSGを使用した際に一部サンプルが再生されないバグを修正
- BIOSパッチの不都合でＰＣがハングする問題を修正
blueMSX v 1.0.4 11/30/03 - 日本のMSXとMSX2を追加
- コナミのGame MasterとGame Master2に対応
- キークリック音を追加
- SCCとAY8910のエミュレーションを追加
- コンポジット出力のモニターエミュレーションを更新
- ヨーロッパ仕様のキーボードのマッピングを修正
- win95とwin98（他も）において、設定が保存されなかったのを修正
- カートリッジとディスク挿入のメニューのバグ修正
- ウィンドウモードにて、ディスク挿入が失敗する不都合を修正
- 20分経過した際にblueMSXがクラッシュする問題を修正
- 終了する際にblueMSXがクラッシュする問題を修正
blueMSX v 1.0.3 11/24/03 - エミュレーションのタイミングを修正
- PALとNTSCの選択メニューをビデオ設定オプションに追加。（Nemesis2などのゲームの正確なスピードに対応するため）
- ブラジルのMSXを追加
blueMSX v 1.0.2 11/22/03 - サウンドにDirectXを追加.
- DirectXにてビデオの動作を修正.
blueMSX v 1.0.1 11/20/03 最初のリリースの小さな不都合を修正したバージョン。 オーディオチャンネルの有無を選択した際にSCCの動作しなかったのを修正。AY8910エミュレーションの際のフェーズエラーを修正。


blueMSX Special Thanks & Salutation

■ Special Thanks & Salutation

machine configurations
blueMSXの開発に当たって、多くの方々にご協力いただきあました。 この場をお借りして、感謝をさせていただきたいと思います。
Shimanuki Koshi | エミュレーターのテストや、ニュースグループからの情報収集やバグレポートなどを手伝っていただきました。ミキサーの提案と日本語への翻訳にもご協力いただきました。
Roger Filipe | gcc/mingwのビルド環境の構築とバグフィックス、ロムマッパーの改善による互換性の向上などにご協力いただきました。ポルトガル語への翻訳も担当していただきました。
SLotman | zlibライブラリの統合とScale2xモニターエミュレーションの移植など、blueMSXのクローンredMSXで実装されています。
Nicolas Beyaert | ロムデータベースの構築と修正などでご協力をいただきました。
Laurent Halter | 新たな画像キャプチャー機能の作成、水平/垂直ストレッチのコード作成とDirectX問題におけるアドバイスと協力。
Kobayashi Michiko | ツールバーのグラフィックにおいて手伝っていただきました。
Marco Casali | Ram Corporation (T2)と伊 ICMグループのメンバーであり、イタリア語への翻訳ならびにMSX-AUDIOにおける不都合とテトリス2のドングル機能導入時にご協力いただきました
Jon Cortazar Abraido | asMSXのシンボルファイルとデバッグコマンドのサポートならびにトレースロッガーにてご協力をいただきました
Fabio Albergaria Dias | ポルトガル語のMSXシステムロムにおける貴重なフィードバックとテスト
Glafouk | オーディオエミュレーションのテストと音楽ディスクの提供。フランス語の翻訳を担当していただきました。
Martijn van Tienen | コマンドライン部分とオランダ語翻訳を手伝っていだきました。
Amer Dugmag | アラビア関連のロムの情報をいただきました
Ulver | 韓国語の翻訳を手伝っていただきました。
Victor Fernandez Sanchez | スペイン語の翻訳を手伝っていただきました。
Davide Platania, aka Kruznak | イタリア語の翻訳を手伝っていただきました。
Miikka Poikela | フィンランド語の翻訳を手伝っていただきました。
Tanni | ドイツ語の翻訳を手伝っていただきました。
Jacek Bogucki (Gucek) | ポーランド語の翻訳を手伝っていただきました。
William Ouwehand | エミュレーターのアーカイブとユーザーインタフェース部分における貴重なフィードバック
Wouter Vermaelen | スプライトとロムマッパーのエミュレーションにて協力をいただきました。
Tobias Keizer | Z80のタイミングテーブルの情報を提供していただきました。
Atarulum | 水平ストレッチ及び多数のエミュレーションに置けるアドバイスをいただきました。
Sandy Pleyte | Megaram機能搭載の祭にアドバイスをいただきました。
MkII | M1ウェイティングステートやタイミングについてアドバイスをいただきました。
Ricardo Bittencourt | 'dir as disk'機能のソースの公開とMicrosolのマッパー情報の提供をしていただきました。
Rudolf Lechleitner | ロムマッパーに関しての技術的アドバイスやプリンター機能の導入の際に多くのご協力いただきました。
Hondarer | FDDのLED部分で実機と同じタイミングで点灯するソースの提供ならびに多数の不都合に置ける貴重な情報を多数いただきました。
 | そしてサポートしていただいている、ユーザーの方々に深く感謝させていたげきたいと思います。

machine configurations
こちらの方々はblueMSXで使用している機能の元となるソースを開発された方々です。 これらの素晴らしいソフトウェアが無ければblueMSXは存在しなかったと言えます。 この場をお借りして感謝を述べたいと思います。
Marat Fayzullin | blueMSXが開発当初使わせていただいた、fMSX の作者です。
Alex Wulms | VDPコマンドエンジンの作者です。
R. Belmont and O. Galibert | YMF278 サウンドチップのエミュレーション。 (Moonsoundの一部で使用させていただきました。）
Jarek Burczynski | YM2413とYMF262サウンドチップのエミュレーション。 (Moonsoundの一部で使用させていただきました。）
Mitsutaka Okazaki | YM2413サウンドチップのエミュレーション。
Tatsuyuki Satoh | Y8950 サウンドチチップのエミュレーション。
Gilles Vollant | unzipの作者です。


blueMSX SblueMSXへのお問い合わせ

■ blueMSXへのお問い合わせ

blueMSXに関するご意見、ご感想、バグレポート、要望、ティップスなどがございましたら、是非公式blueMSXのフォーラムへお問い合わせください。　当フォーラムでは直接開発者との対話や要望のリクエストなどを受け付けております。　ユーザーの声を反映される事が開発の大きな目標ですので、積極的にフォーラムへの参加をお願いいたします。

日本のユーザー専用のウェブサイトもご用意させてたいだいております、最新のニュースやロムデータベース更新などのが入手できます。

-blueMSX公式日本語ウェブサイト
http://www.bluemsx.com/jindex.htm

-blueMSX公式フォーラム　（日本語フォーラム完備）
http://www.bluemsx.com/blueforum

-メールは作者のDaniel Vikまで　（日本語でもＯＫです。）


blueMSX スタートアップガイド概要

■ スタートアップガイド概要

こちらのではblueMSXをなるべく初心者の方でも理解できるように作成したスタートアップガイドです。
セクションは以下の項目で構成されています。

■　インストール編 - blueMSXのインストール方法の解説
■　起動方法 - blueMSXの起動方法の解説
■　ロムイメージの起動方法 - ロム（カートリッジソフト）の起動方法解説
■　ディスクイメージの起動方法 - ディスクイメージ（フロッピーソフト）の起動方法解説
■　テープイメージの起動方法 - テープイメージ（カセットソフト）の起動方法解説
■　その他の特殊機能 - その他、便利な機能や特徴的な機能のご紹介と使用方法


blueMSX インストール編

■ blueMSX インストール

ダウンロードした任意のblueMSXvxxx.exeという自己解凍型圧縮ファイルを実行します。
（ｘｘｘ = バージョンおよびビルド番号です。）

インスールプログラムは解凍先のディレクトリーを要求してきます。
標準は C:\Program Files\blueMSX に解凍されます。

それ以外の場所に解凍したい時は、”Browse...”ボタンをクリック、もしくは記入欄に任意の解凍場所を指定します。
指定の場所に解凍先のディレクトリが存在しない場合は自動的にフォルダが作成されます。
あとは”Start..."ボタンを押すことにより解凍作業が実行されます。

お好みによって、すべてのユーザーかユーザーのみの使用かを選択する事ができます。　（特にWINXPユーザーにとっては便利なオプションかもしれません。）

”次へ”を押す事によりインストール作業が実行されます。　指定したディレクトリが存在しない場合は自動的に作成されます。

その他のインストール作業は不要です。 ご指定のディレクトリーにはblueMSX本体とヘルプファイルが解凍されます。
同時に9つのサブディレクトリが作られ、いずれもblueMSXに必要なディレクトリです。

machine configurations
Audio Capture | 録音機能によりキャプチャーされた、*.wavファイルが収納されます。
Casinfo | blueDECK機能にて保存されたテープ位置の記録用*.posファイルが収納されます。
Keyboard Config | キーボード構成編集機能で作成されたスキームが保存されています。
Machines | blueMSXでエミュレート可能な機種の設定ファイルとBIOSの収納に使用されます。
ScreenShots | スクリーンキャプチャ機能により取り込まれた*.bmp画像ファイルが収納されます。
Shortcut Profiles | ショートカット構成編集機能にて作成された、ショートカットファイルが収納されています。
Sram | SRAM搭載カートリッジ、本体内蔵SRAM、FM-PACやPACカートリッジを使用した際の*.sramファイルが保存されます。 最後に使用されたMSX機種のclockchipの内容が.cmosファイルとして保存されます。
Themes | テーマように作成されたスキンが収納されているフォルダーになります。
Tools | blueMSXに対応したプラグインが収納されるフォルダーです。

クイックセーブ機能を使用した際には、QuickSaveというディレクトリーが新たに作成されます。

■ blueMSX アンインストール

blueMSXをアンインストールをするには、コントロールパネルから”プログラムの追加と消去”を選択し、一覧からblueMSXを選んで”消去”ボタンを押します。　後は指示に従って捜査してください。　”変更”を選択するとblueMSXの修復が行われます。


blueMSX blueMSXの起動編

blueMSXの起動

blueMSXのアイコンをダブルクリックで起動します。
よく使う場合はデスクトップにショートカットを作っておくと便利です。

起動の際には下のような画面が出ます。　この時点ではエミュレーションは停止した状態です。

日本のユーザーがまず最初にやって置きたい事はGUIを日本語化する事でしょう。"Options"というメニューをクリックしてドロップダウンメニューから"Language"という項目を選びます。　するともう一つウィンドウが開きますので、その中から日本語の"Japanese"を選択して"OK"を押しましょう。　これでGUIがすべて日本語に切り替わります。

MSXのエミュレーションをスタートさせるにはF9（=実行）もしくははＦ12（=リセット）ボタンを押します。
（ここから実際のＭＳＸワールドへの入り口になります。）

走らせるソフト（ゲームやアプリケーション）が無い場合は、基本的にMSX-BASICが起動します。　もし、お使いの機種が内蔵ソフトを搭載している場合は、内蔵ソフトが起動します。

ソフトウェアを起動させるには”イメージ”と呼ばれる専用ファイルをエミュレーターに読み込ませなくてはいけません。　これから各種イメージのロード方法をそれぞれの専用ページにて説明いたします。

blueMSXがサポートするイメージ形式はフロッピーディスクファイル、ロムカートリッジファイル、とカセットファイルになります。　これらは実際のメディアから、エミュレーターで読み込めるように変換された物で、全体の事を”イメージ”と呼びます。

ディスクイメージにはこれらの拡張子が含まれます：　*.dsk、*.di1、*.di2、*.360、*.720など。　ディレクトリをディスクとして使用する機能も利用できます。

ロムイメージにはこれらの拡張子が含まれます： *.rom、*.ri、*.mx1、*.mx2、*.colなど

テープ（カセット）イメージにはこれらの拡張子が含まれます: *.cas、*.tapなど

blueMSXがこれらのイメージファイルが収納されたZIP形式の圧縮ファイルを直接扱うことができます。


blueMSX ロムイメージの起動方法

■ ロムイメージの起動方法

ロムイメージにはカートリッジに記録されているデータが収納されています。基本的にはロムイメージは .rom拡張子が付けられていますが、blueMSXでは他にも.ri、.mx1、.mx2や.colといった拡張子も扱うことができます。

これらのロムイメージは5通りの方法で起動と実行が可能で、お使いの用途にあった方法を見つけください。

最初の3つの方法では、初めからエミュレーターが起動している状態で実行しますが残りの方法はエミュレーターと同時にロムイメージも起動する方法です。　また5番目の方法として、ロムイメージを直接ダブルクリックする事で起動させる方法です。　この場合は事前にblueMSX上で拡張子の関連付けをしておかなくてはなりません。　その方法はオプション＞その他＞blueMSXに関連付けるファイル種類....の項目を有効にします。

blueMSXは起動されたロムイメージを（標準で１０ファイル）記憶しています。　ロムのイメージ選択画面で確認する事が出来、ファイル選択メニューから再度選ぶ必要がなく、記憶された一覧から選択が可能です。

machine configurations
ロムイメージ選択方法 その１：メニューを使用 | - blueMSXをアイコン又はショートカットのダブルクリックで起動 - メニューからROMスロット1(2)＞挿入 - ファイル選択メニューから任意のロムイメージを選択 - 選択し終えたら、自動的にエミュレーターがリセットされ、エミュレーションがスタートします。 ”挿入/取り出し後リセット”オプションが解除されている場合は手動でリセット又は電源をいれてエミュレーションをスタートさせます。

machine configurations
ロムイメージ選択方法 その２：ツールバーを使用 | - blueMSXをアイコン又はショートカットのダブルクリックで起動 - ツールバーの3番目のアイコン（ROMスロット1に挿入ボタン）をクリックし、ファイル選択メニューを呼び出します。 - ファイル選択メニューから任意のロムイメージを選択 - 選択し終えたら、自動的にエミュレーターがリセットされ、エミュレーションがスタートさせます。 ”挿入/取り出し後リセット”オプションが解除されている場合は手動でリセット又は電源をいれてエミュレーションをスタートさせます。

machine configurations
ロムイメージ選択 方法その３： ショートカットから呼び出す | -blueMSXをアイコン又はショートカットのダブルクリックで起動 -ショートカットキーLCTRL+F7を押し、ファイル選択メニューを呼び出します。（左コントロールキーとファンクションキーの７です。） -ファイル選択メニューから任意のロムイメージを選択 -選択し終えたら、自動的にエミュレーターがリセットされ、エミュレーションがスタートさせます。 ”挿入/取り出し後リセット”オプションが解除されている場合は手動でリセット又は電源をいれてエミュレーションをスタートさせます。

machine configurations
ロムイメージ選択方法 その４：ドラッグ＆ドロップ | -ロムイメージを直接blueMSXのアイコンやblueMSXの画面の上にドラッグ＆ドロップします。 -ドラッグ＆ドロップし終えたら、自動的にエミュレーターがリセットされ、エミュレーションがスタートさせます。 ”挿入/取り出し後リセット”オプションが解除されている場合は手動でリセット又は電源をいれてエミュレーションをスタートさせます。 ＊アイコンやショートカットにロムイメージをドラッグ＆ドロップした場合のみ、”挿入/取り出し後リセット”の選択に関わらず、ロムは自動起動します。

machine configurations
ロムイメージ選択方法その５：ダブルクリック | この方法は冒頭で述べた、拡張子の関連付けをしておかなくてはなりません。 オプション＞その他＞blueMSXに関連付けるファイル種類.... -ロムイメージを直接ダブルクリックする事により、自動的にblueMSXが起動します。 ”挿入/取り出し後リセット”オプションが解除されている場合は手動でリセット又は電源をいれてエミュレーションをスタートさせます。 ＊この方法は”挿入/取り出し後リセット”の選択に関わらず、ロムは自動起動します。

■ Ｑ＆Ａ

ZIP圧縮されたイメージは扱えますか？
はい、可能ですが上で述べた５番目の方法（ダブルクリック）では使用できません。

- 圧縮ファイルに１一つのファイルしか収納されて無い場合は自動的にそのイメージを起動します。
- 複数のロムイメージが収納されている場合は、ファイル選択画面が表示されます。　その中から希望のロムイメージを選択します。

コナミ特有のロムの組み合わせについては？
専用開設ページを設けましたのでそちらを参照してください。

ロムイメージの自動起動させたくない場合は？
- ROMスロット１か２の”挿入/取り出し後リセット”オプションを解除します。

動きません、どうしたらいいでしょうか？
- 上の起動方法の1、２、もしくは３を使用した場合は、”挿入/取り出し後リセット”オプションが解除されている恐れがあります。　この場合は手動で起動されなくてはなりません。　ショートカットのF9(=起動)または、F12(=リセット）でロムを起動させましょう。

- ロムイメージにはMSX2専用の物も数多く存在します。　お使いのマシン構成がMSX1の場合はMSX2専用ソフトは上手く起動しません。オプション＞エミュレーション＞MSXの種類をMSX2以降に設定しなおしてください。ツール＞マシン構成編集からもMSXの機種選択が可能です。

- ロムイメージの中にはblueMSXの外部ロムデータベース(romdb.dat)に情報が未掲載の物があります。　それらの特殊なロムイメージは事前にロムデータベースに登録しておく必要があります。　起動させたいロムイメージのマッパーの種類がお分かりの場合は、romdb.datを編集して追加ください。　他の方法としてはロム選択メニューからファイルを選択し、マッパーを手動で指定する方法もあります。

- ロムイメージの中にはメモリ不足で上手く立ち上がらない場合があります。　その場合はリセット後に右CTRLキーか右SHIFTキーを起動画面中に押しっぱなしにし、ドライブが使用していたメモリーを切り離します。

- エミュレーターが何もしなくなった場合は、（エミュレーターの）再起動又はF12(=リセット）を押し、再起動させましょう。

- 一部のゲームやデモがまったく動作しない場合があり、それらの問題は：VDP又はZ80エミュレーションにおけるバグが原因。もしくは新しい未対応のマッパーのだったりするかもしれません。　それらのロムを発見した場合は是非blueMSXの専用フォーラムにご一報ください。　あなたのバグ報告がblueMSXの進化と互換性向上に大いに役に立つはずです！


blueMSX ロムイメージメニュー

■ ロムイメージメニュー

machine configurations
挿入 | - ロムイメージを任意のスロット（1か2）へ挿入します。 - 拡張子に*.rom/*.mx1/*mx2/*.zipのついたファイルをサポート - zipファイルに複数のイメージが含まれる場合は、任意のファイル選択ウインドウが表示されます。 - ロムの認識はromdb.datを参照し、正しいマッパータイプを自動的に認識します。 - romdb.datに含まれないロムは手動でマッパータイプが選択可能です。
取り出し | - ロムイメージを任意のスロット（1か2）から取り出します。
挿入/取り出し後リセット | - 有効の場合は新しくロムを挿入した際に自動的にエミュレーターがリセットされ再起動するようになります。
使用したファイル | - 差も最近使われた順番でロムイメージの一覧を表示されます。

■ その他のメニュー

machine configurations
SCC カートリッジ SCC+ カートリッジ | - SCCカートリッジとはコナミが独自で開発した音源チップを搭載したカートリッジの事です。（サラマンダやネメシス２など） - SCC+カートリッジはSCCに改良を施したヴァージョンでディスク系のソフトに使用されたました。（スナッチャーなど） - SCCとSCC+との大まかな違いは４つしか無かったウェーブメモリーが５つに拡張されたことです。 - これらのカートリッジはディスク用に開発されたソフトに対応する為の物です。（コナミ・ゲームコレクションや、スナッチャー、SDスナッチャーやデモ系ソフトのFony Demo Disk 1など）
FM-PAC PAC | - FM-PACはFM-パナソニックアミューズメントカートリッジの略です。 - MSX-MUSICと拡張ベーシックが搭載されています。 （_FMPAC文でアクセスする事ができます。） - S-RAMを搭載する事で対応ソフトでRAMにセーブする事ができます。 - PACはS-RAMのみを搭載した省略版といえる物です。 - blueMSXでは標準でMSX2以降に最初からFM-PACを搭載した形になっています。 またMSX2+からはMSX-MUSICが標準規格になり、最初から搭載しています。 - MSX1などFM音源やS-RAMを搭載しない機種で使用するといいでしょう。
Sony HBI-55 カートリッジ | - HB-75,HB-201で利用可能な特殊なカートリッジで、内容を保存したりする為の専用カートリッジ。
External RAM | - メモリーの内部拡張（増設）はマシン構成編集からも可能ですが、実機のように外部カートリッジとし扱う事ができます。 外部増設の場合は、MSX2、MSX2+、またはTurbo-R上でのみに限られます。
MegaRAM | - ロムイメージをRAMに書き戻す事を目的に開発された、ブラジル発祥のサードパーティーハードウェアです。 日本では似非ＲＡＭなどが同じ用途で使われています。 メモリマッパだけでは要領不足で走らせる事ができないメガロムなどを書き戻すために私用されたりします。


blueMSX 外部ロムデータベース

 ｓ

■ 外部ロムデータベース

blueMSXでは(CRC32コードまたはSHA1)を利用した外部ロムデータベースを使用しています。　ロムデータベースの役割はblueMSXにロムのマッパー情報などを伝える為の物です。　マッパー情報が無い場合は任意のロムがエミュレーター上でどういった物かが分からず、起動に失敗することがあります。　そのためロムデータべースで補助する事が目的とされています。　本来はエミュレーターのプログラム内部に存在する部分の物ですが、blueMSXではあえてユーザーにデータベースを開放し柔軟性を持たせています。

もし、お持ちのロムがデータベースに登録されていない場合はユーザーが自ら登録することが可能です。 blueMSXのインストールされているディレクトリにromdb.datというファイルがありそれをテキストエディターなどで編集する形で実施されます。　それでは、romdb.datにデータの追加方法をこれから解説いたします。

現在は2種類の同じ内容のデータベースが存在します。　旧形式のromdb.batファイルと新しい形式のsoftwaredb.xmlがあり、新形式にはXMLを利用しています。　将来的にはXML方式に統一し、旧形式は廃止される予定です。

データの構成はロム一つにたいして一行という決まり事があります。

フォーマットはこのようになっています。
[crc] [romtype] [詳細（任意）]

[crc] と [romtype]　は必ず小文字でなければなりません。

参考例：

cb935a50 basic 3d Golf
27405eed konami5 Space Manbow
68fe9580 ascii16 Pinball Blaster

■ CRC32の照合データの取得方法は？

- フリーウェアでCRC32を算出できるソフトが多数存在します、お好きなソフトを入手してお使いください。　この説明でWINZIPを参考に説明していきます。
- それではお持ちのロムイメージをWINZIPにて圧縮ファイルを作ってください。
- 次に作成されたZIPファイルをダブルクリックしてWINZIP上で開きます。
- 先ほど圧縮したロムファイルを左クリックし、メニューから"File Properties"項目を選びます。　すると、下のようなウィンドウが表示されます。
- ウィンドウの一番の項目CRCがロムファイルのCRC32情報になります。
- 通常は8桁ですが、7桁の場合は最初に数字の0を追加したものがCRCになります。

こちらがSELENIAK.ROMを参考としてWINZIPで参照した例になります。

CRC32情報が取得できたら、次はロムマッパー種類を指定して、外部ロムデータベースromdb.datに情報を追加するのみです。
参考例：　6E8BB5FA mirrored Seleniak (2004)(Guzuta Raster Leisure)[6E8BB5FA]

■ [詳細（任意）]部分の用途は？

詳細部分は任意でなくても構いませんが、DIGIblueのようなテーマを使用した際には追加情報として内容を表示させる事ができます。

推奨される詳細情報のフォーマット形式は以下のようになります。

ソフトの名称 (発売された年) (発売元名) [その他の追加情報 (任意)] [crc]

[その他の追加情報 (任意)] 部分には複数の情報を追加する事ができます。

例：
- コナミ系に付けられているRC番号
- TOSECやGOODなどに使用されている記号など
- 多言語のヴァージョン情報など

この部分は自由に情報を記載する事ができます、ロムの情報整理などに利用してみては？

■ softwaredb.xml を使用した場合のフォーマット：

基本的にはXMLの形式に従って記入してください。

machine configurations
<software>
              <title xml :lang="en"> .......</title> | 例 : Metal Gear 2 Solid Snake
              <system> ....... </system> | 例: MSX (または：SVI - Coleco)
              <company> .......</company> | 例: Konami
              <year> ......</year> | 例: 1990
              <country> ....... </country> | 例: Japan
              <dump>
                        <original value="...."> .... 例:
- GoodMSX dumpには : <original value="true">GoodMSX</original>
- それ以外の dumpいは : <original value="false"/>
                        <rom> 例 :
- megarom - sccpluscart - system rom
                        <type> ....... </type>

例:
- rom - megarom - system rom に限定されます
- Mirrored Rom または 0x0000から始まる通常ロムの場合は表記無しでよい。
(自動認識されますが；システムロム系には推奨できません。）
                        <start> ....... </start>

例:
- 0x0000 - 0x4000 - 0x8000 - 0xC000 の通常ロムのみ。
- Mirrored Rom または 0x0000から始まる通常ロムの場合は表記無しでよい。
(自動認識されますが；システムロム系には推奨できません。）
                        <boot> ...... </boot> 例:
- scc - scc+ のsccpluscarts に限定されます
                        <hash algo="...."> ....... </hash> 例:
- crc32 または sha1値 (sha1値が推奨されます。)
                        <remark>
                                      <text> ....... </text> | dumpのための”その他”の情報を記入できます。
                        </remark>
                        </rom>
            </dump>
            <dump>
上の繰り返しです。
            </dump>
</software>

■ SHA1の照合データの取得方法は？
- Googleなどの検索エンジンを利用して、SHA1値の取得ツールを探してください。　複数存在しますので、自分に合ったツールをさがしてみてください。

■ こちらがblueMSXでサポートされているマッパー種類になります。

旧romdb.batとsoftwaredb.xmlとではマッパーの呼び名が異なります。

machine configurations
romdb.dat | softwaredb.xml |
ロム |  |
mirrored | (auto-detection) | 通常のロムとミラードロム
0x4000 | Normal - start 0x4000 | 通常のロムでアドレスが&H4000から始まる物
basic | Normal - start 0x8000 | MSX-BASICのものでアドレスが&H8000から始まる物
konamisynth | Synthesizer | コナミの新生Sizer系専用
メガロム系 |  |
konami5 | KonamiSCC | SCCを搭載したコナミのメガロム （例：王家の谷 エルギーザの封印など）
konami4 | Konami | SCCを搭載しないコナミのメガロム （例：ウシャス）
ascii8 | ASCII8 | 8kbのアスキーメガロム （例：バブルボブルなど）
ascii16 | ASCII16 | 16kbのアスキーメガロム （例：ゼビウスなど）
ascii8sram | ASCII8SRAM8 Wizardy | SRAMを搭載した8kbのアスキーメガロム （例：ザナドゥなど）
ascii16sram | ASCII16SRAM2 | SRAMを搭載した16kbのアスキーメガロム （例：ハイドライド２など）
koei | KoeiSRAM8 KoeiSRAM32 | SRAMを搭載した光栄のメガロム （例：大航海時代など）
gamemaster2 | GameMaster2 | コナミの新10倍カートリッジ（SRAM搭載）専用
konami4nf | GenericKonami | konami4の異なるヴァージョン （例：コナミの改造メガロムなど）
ascii16nf | SuperPierrot | 16kbのアスキーメガロムの異なるヴァージョン （例：改造メガロムなど）
majutsushi | Majitsushi | 牌の魔術師系専用
rtype | R-Type | R-TYPE専用
loderunner | SuperLodeRunner | スーパーロードランナー専用
crossblaim | CrossBlaim | クロスブレイム専用
harryfox | HarryFox | はーりぃふぉっくす 雪の魔王専用
korean80 | Zemina80in1 | 韓国産：30-in-1, 64-in-1 と 80-in-1専用
korean90 | Zemina90in1 | 韓国産：90-in-1専用
korean126 | Zemina126in1 | 韓国産：126-in-1専用
holyquran | HolyQuran | (アラビア語MSX2系用）Holy Quran専用
scc | boot : scc | コナミSCCサウンドチップ
scc+ | boot : scc+ | コナミSCC+サウンドチップ
mirrored | (auto-detection) | 通常のロムとミラードロム
normal | Normal - start 0x0000 | 通常のロム
diskpatch | fMSXPatched | 通常のロム + ディスクパッチ
caspatch | CasPatch | 通常のロム + カセットパッチ
0x4000 | Normal - start 0x4000 | 標準ロム (0x4000からスタート)
basic | Normal - start 0x8000 | ベーシックロム (0x8000からスタート)
0xC000 | Normal - start 0xC000 | 標準ロム (0xC000からスタート)
msxdos2 | MSX-DOS2 | MSX-DOS2.2のカートリッジのみ
fmpac | FMPAC | パナソニックのFM-PAC（SRAMとMSX-MUSIC搭載）専用
fmpak | FMPAK | オランダまたは韓国製のMSX-MUSICロム
msxaudio | MSX-AUDIO | パナソニックのMSX-AUDIOカートリッジ専用
msx-music | MSX-MUSIC | 日本版MSX-MUSICロム
moonsound | MoonSound | MoonSound ロム
kanji | Kanji | 漢字カートリッジ
kanji12 | Kanji12 | 漢字12カートリッジ
bunsetsu | Bunsetsu | 文節カートリッジ専用
jisyo | Jishyo | 辞書専用 （文節カートリッジと併用）
halnote | Halnote | HALNOTE（SRAM搭載）専用
national | National | ナショナル用ロム（SRAM搭載）
panasonic16 | Panasonic 16 | 16kb SRAM搭載 パナソニックロム
panasonic32 | Panasonic 32 | 32kb SRAM搭載 パナソニックロム
tc8566af | TC8566AF | パナソニックのフロッピディスクコントローラー専用
mb8877a | MB8877A | ナショナル/Daewoo産のMSXに搭載されていた専用ディスクコントローラー
wd2793 | WD2793 | フィリップス/ソニー産のMSXで搭載されていた専用ディスクコントローラー
microsol | Microsol | マイクロソル専用ディスクコントローラー（主にブラジルのMSXに搭載されていた）
svi738fdc | SVI738FDC | Spectravideo産SVI-738専用ディスクコントローラー
cx5m | CX5M-MUSIC | ヤマハ CX5M/CX7M 音楽ロム （未対応）
fsa1fm1 | FSA1FM1 | パナソニック FS-A1FM モデムロム （未対応）
fsa1fm2 | FSA1FM2 | パナソニック FS-A1FM ファームウェア （未対応）
normal | Normal - start 0x0000 | SVIまたがColeco 用 BIOSロム
caspatch | CasPatch | SVIロム+ カセットパッチ
svi328cart | SVI328CART | Spectravideo SVI-318/328 ロム
svi80col | SVI80COL | Spectravideo 80 列カード
coleco | Coleco | ColecoVision / Adam ロム


blueMSX コナミ系ロムの組み合わせ詳細

■ コナミ系ロムの組み合わせ詳細

コナミの一部のソフトでは２本別々のカートリッジを同時使用することで特殊な機能やパワーアップなどが得られる事があります。

またコナミのゲームを１０倍楽しむカートリッジやコナミの新１０倍カートリッジ使用する事で同じように特殊機能を有効にする事が可能です。

コナミの組み合わせを使用する方法は？
- 通常通りにスロットにカートリッジを差込ます。（方法1-ファイルメニュー、方法2-アイコン、方法3-ショートカット）
- スロット１に最初のゲーム（走らせたいゲーム）
- スロット２に特殊機能を提供するゲームを挿入
＊ 方法1を選んだ場合は、ファイル / スロット２ / 挿入を選択します。
＊ 方法2を選んだ場合は、ツールバーのアイコンから スロット２-挿入をクリックします。
＊ 方法3を選んだ場合は、ショートカットのCTRLキー＋F8を押し任意のロムを挿入します。

ロムの組み合わせで受けれる恩恵はどういったのが存在しますか？
下のリストで組み合わせにおける効果を説明しています、参考にしてください。
他にコナミのゲームを１０倍楽しむカートリッジとコナミの新１０倍カートリッジ使用した際の効果を説明した専用ページが設けられています。

machine configurations
スロット１にロム | RC | スロット２にロム | RC | 組み合わせによる効果
Ｆ１スピリット / A1 Spirit | 752 | コナミのゲームを１０倍楽しむカートリッジ | 735 | 全クラスが使用可能
Ｆ１スピリット / A1 Spirit | 752 | キングコング２ | 745 | 全クラスが使用可能
Ｆ１スピリット / A1 Spirit | 752 | Ｑバート | 746 | 全クラスが使用可能
がんばれゴエモン！からくり道中 / Samurai | 748 | Ｑバート | 746 | ステージセレクトとプレイヤーの数の指定が可能 ポーズ機能とコマ送り機能が使用可能
グラディウス 1 / Nemesis 1 | 742 | ツインビー | 740 | プレイヤーの期待がツインビーに変わり、エネルギーポッドが鐘にかわります。
グラディウス 2 / Nemesis 2 | 751 | ガリウスの迷宮 | 749 | 機体を損失しても、得たオプションは継続されます。 （コンティニューでは使用できない）
グラディウス 2 / Nemesis 2 | 751 | Ｑバート | 746 | ポーズ機能から３つのパスワードが使用可能になります： LARS18TH - すべての武器が使用可能に METALION - 緑シールド (無敵になるが、地形の間を飛ぶ事はできない。） NEMESIS -次のステージに飛ぶ
グラディウス 2 / Nemesis 2 | 751 | 夢大陸アドベンチャー | 743 | 機体がペンギンに変わり、パワーアップが魚に、そして青いパワーアップが取りへ置き換わります。
火の鳥鳳凰編 / Firebird | 747 | キングコング２ | 745 | F4キーでテープへのセーブとF5キーでロードが可能に
火の鳥鳳凰編 / Firebird | 747 | Ｑバート | 746 | ステージセレクトとプレイヤーの数の指定が可能 ポーズ機能とコマ送り機能が使用可能
ガリウスの迷宮 | 749 | 魔城伝説 | 739 | 死の神殿でポポロンとアフロディーテを９９回復活させられます。
ガリウスの迷宮 | 749 | Ｑバート | 746 | ＶＩＴ満タン、矢筒、コイン、キー１００個が最初から得られます。
沙羅曼蛇 | 758 | グラディウス 2 / Nemesis 2 | 751 | エキストラステージがアクセス可能に、ヴェノム博士を倒して、真のエンディングが変見れます。
ウシャス | 753 | Ｆ１スピリット / A1 Spirit | 752 | 必殺技が常時使用可能
ウシャス | 753 | グラディウス 2 / Nemesis 2 | 751 | Ｆ5でコンティニューが可能
ウシャス | 753 | ガリウスの迷宮 | 749 | コインが100の状態でスタートできる
ウシャス | 753 | メタルギア | 750 | 受けるダメージが半減する
イーガー皇帝の逆襲 | 737 | イーアルカンフー | 725 | プレイヤーと敵の体力が両方赤くなると、李の亡霊が出てきて烏龍茶を落として行ってくれる、とる事が出来れば体力を回復できる。


blueMSX コナミのゲームを１０倍楽しむカートリッジ

■ コナミのゲームを１０倍楽しむカートリッジ　（RC-735）

このカートリッジはコナミのMSX1用のゲームソフトと一部のMSX2用のゲームと同時に利用する事により特殊機能を使用可能にするカートリッジです。
MSX1のゲームの場合はカートリッジをスロット1に入れて利用します。（ゲームのカートリッジはスロット２に入れます）；一部のゲームではコナミのゲームを１０倍楽しむカートリッジの一部の機能しか有効になりません。
MSX2のゲームの場合はカートリッジをスロット2に入れて利用します。（ゲームのカートリッジはスロット1に入れます）；この場合はコナミのゲームを１０倍楽しむカートリッジの一部の機能が有効になります。

基本メニュー

メニュー１ : GAME

machine configurations
日本語版 | 海外版

通常のゲームを遊びたい場合は、このオプションを選択します。
起動の際にエミュレーター上でESCキーを押しながら立ち上げる事で、直接ゲームを起動できます。
コナミのゲームを１０倍楽しむカートリッジを無効化する場合は、ブート時にSHIFTキーを押しながら立ち上げます。

メニュー２ : MODIFY

machine configurations

コナミのゲームを１０倍楽しむカートリッジは上に改造対象のカートリッジの番号を表示しています。(RC-7xxなど）

MODIFY STAGE NUMBER: 開始するステージの入力
MODIFY PLAYER NUMBER: プレイヤーの数を決定します
RANKING MODE: 下を参照
COLOR TEST PATTERN: 下を参照
START GAME: 改造を適応した状態でゲームを起動します。

RANKING MODE:

このモードはゲームのセーブとロードを制御します。

新しいゲームでこのオプションを有効にする場合は事前にCLEAR RANKING DATAをゲーム開始前にしておく必要があります。

事前にセーブされている場合はLOADのオプションの使用が可能です。

COLOR TEST PATTERN:

このオプションはあまりエミュレーター上では利用価値がありませんが、TV出力などの際に色合いをあわせるためのカラーパターンになります。
PRINT SCREENは白黒でのスクリーンダンプを出力します。

メニュー３ : SELF (スロット２にソフトが挿入されてなくても利用可能）

machine configurations

COLOR TEST PATTERN:
このオプションはあまりエミュレーター上では利用価値がありません。COLOR TEST PATTERNを参照してください。

LOAD SCREEN DATA:
ゲームのスクリーンキャプチャをロードします。
キャプチャーした画像をMSX上で読み込む方法として、以下の手法が使えます。(ディスクに保存した場合。）
- カーソルをENDにあわせますが実行せずに、
- 左CTRLキー＋SHIFTキー＋Spacebarを押します。
- *.VRM拡張子のファイルが作成されます。
- *.VRMファイルはMSX-BASICで読み込めるファイル形式で以下のプログラムを利用してロード表示ができます。
COLOR 15,0,0: SCREEN 2,2: BLOAD "ファイル名.VRM",S: A$=INPUT$(1)

各種機能説明

machine configurations
ポーズ機能 | - ゲームの実行中にストップ(=PageUp)を押してポーズをかけます。 デモ中でもパーズをかける事ができ、パーズ中はCAPSロックのLEDが点灯します。 ポーズモードを解除するには再度ストップ(=PageUp)をおします。 （同時にCAPSロックのLEDも消えます。）
コマ送り機能 | - ポーズ中に、”；”キーを押して一コマづつ前進させます。
スローモーション機能 | - ポーズ中にESCキーを押して、スローモーションモードを有効にします。 再生速度はDELキーとINSキーで調節できます。 スローモーションを解除するには再度ストップ(=PageUp)をおします。
セーブ/ ロード機能 | - ポーズ中に、左CTRLキーを押して、セーブ/ ロード機能機能を有効化します。 - セーブ機能には幾つかの項目が選択できます：ハイスコアのセーブ/ゲームのセーブ/スクリーンのセーブ/ランキングのセーブ（ランキングモードが有効化されている場合のみ） - セーブ対象にディスクかテープへの選択が可能。 - 保存されたファイルには拡張子として、*.Hxx（ハイスコア）、*.Gxx(ゲームデータ）、*.Sxx（スクリーンデータ）、*.Rxx(ランキングのデータ）が存在し、xxの部分にコナミのRC型番が追加されます。 - スクリーンのデータファイルはベーシックから読み出し可能なフォーマットにコンバードが可能です。（SELFのセクションを参照）
ランキング機能 | - ポーズ中に、左CTRLキーを押して、中からランキングモードへアクセスします。 - 事前にランキングモードを有効化した場合にのみ利用可能です。（上を参照） - 過去に登録されたランキングを参照する事が出来ます。 - 登録されたプレイヤー名の変更も可能。
スクリーンダンプ機能 | - ポーズ中に、F3を押してスクリーンダンプを作成します。（白黒にで） - 出力にはプリンターが必要ですが、エミュレーター上での対応の都合であまり、利用価値はありません。
リスタート機能 | - ポーズ中に、左CTRLキーを押して、セーブ/ ロード機能機能を有効化し、カーソルをENDに合わせます。 - 左CTRLキー＋SHIFTキー＋Spacebarを押します。 - コナミのゲームを１０倍楽しむカートリッジとゲームの両方が完全いリセットされます。

MSX1用ソフトの追記（カートリッジはスロット２に挿入されていなければならない。）

machine configurations
ゲーム名 | RC | 追記 | SRAM
けっきょく南極大冒険 | 701 | プレイヤーの数の変更は不可 |
わんぱくアスレチック | 700 |  |
キャベッジパッチキッズ | 716 |  |
サーカスチャーリー | 712 |  |
ぽんぽこぱん | 714 |  |
F1 Spirit / A1 Spirit | 752 | ステージ選択、プレイヤー数、ランキングモード不可 |
フロッガー | 704 | ステージ選択不可 |
ゴーファーの野望ＥＰＩＳＯＤＥII / Nemesis 3 | 764 | ランキングモード不可 | GOFE1 GOFE2
グラディウス 1 / Nemesis 1 | 742 |  |
グラディウス 2 / Nemesis 2 | 751 | ランキングモード不可 |
ハイパーオリンピックI / Track & Field 1 | 710 | プレイヤーの数の変更は不可 |
ハイパーオリンピックII / Track & Field 2 | 711 | プレイヤーの数の変更は不可 |
ハイパーラリー | 718 | プレイヤーの数の変更は不可 |
ハイパースポーツ１ | 715 | プレイヤーの数の変更は不可 |
ハイパースポーツ２ | 717 | プレイヤーの数の変更は不可 |
ハイパースポーツ３ | 733 | プレイヤーの数の変更は不可 |
王家の谷 | 727 |  |
エルギーザの封印 （MSX1版） | 760 |  |
魔城伝説 | 739 |  |
ガリウスの迷宮 | 749 | ステージ選択、プレイヤー数、ランキングモード不可 |
コナミのベースボール | 724 | ステージ選択、プレイヤー数、ランキングモード不可 |
ビデオハスラー | 706 | ステージ選択不可 |
コナミのボクシング | 736 | プレイヤー数、ランキングモード不可 |
コナミの麻雀道場 | 707 | ステージ選択、プレイヤー数、ランキングモード不可 |
コナミのピンポン | 731 | ステージ選択、プレイヤー数、ランキングモード不可 |
コナミのサッカー | 732 | プレイヤー数、ランキングモード不可 |
コナミのテニス | 720 | ステージ選択、プレイヤー数、ランキングモード不可 |
マジカルツリー | 713 |  |
モン太君のいち・に・さんすう | 702 | ステージ選択不可 |
モピレンジャー | 728 |  |
パロディウス | 759 | ランキングモード不可 |
ピポルズ | 729 |  |
Qバート | 746 |  |
ロードファイター | 730 | プレイヤーの数の変更は不可 |
沙羅曼蛇 | 758 |  |
スカイジャガー | 721 |  |
スーパーコブラ | 705 | ステージ選択不可 |
グーニーズ | 734 | プレイヤーの数の変更は不可 |
タイムパイロット | 703 | ステージ選択不可 |
ツインビー | 740 |  |
イーアルカンフー | 725 |  |
イーガー皇帝の逆襲 | 737 |  |
夢大陸アドベンチャー | 743 |  |

MSX2用ソフトの追記（カートリッジはスロット１に挿入されていなければならない。）

machine configurations
ゲーム名 | RC | 追記
魔城ドラキュラ | 744 | 一部の機能が有効：ステージ選択、プレーヤー数が可能。 ポーズ機能とコマ送り機能が可能。
がんばれゴエモン！からくり道中 | 748 | 一部の機能が有効：ステージ選択、プレーヤー数が可能。 ポーズ機能とコマ送り機能が可能。
火の鳥鳳凰編 | 747 | 一部の機能が有効：ステージ選択、プレーヤー数が可能。 ポーズ機能とコマ送り機能が可能。


blueMSX コナミの新１０倍カートリッジ

■ コナミの新１０倍カートリッジ　（RC-755）

このカートリッジはコナミのMSX1用とMSX2用のゲームと同時に利用する事により特殊機能を使用可能にするカートリッジです。
通常はスロット１へ挿入して使用します。（対象ゲームカートリッジはスロット２へ挿入します。）
SRAM機能のみを使用したい場合はスロット２へ挿入し、ゲームカートリッジはスロット１へ挿入します。
魂斗羅と牌の魔術師はコナミの新１０倍カートリッジからの起動はできません。したがってスロット２へコナミの新１０倍カートリッジを挿入する事が推奨されます。
一部のゲームではコナミの新１０倍カートリッジのオプションの使用が限られます。

基本メニュー

メニュー１ : GAME

machine configurations
日本語版（MSX1では多少違います。） | ヨーロッパ版

通常のゲームを遊びたい場合は、このオプションを選択します。
起動の際にエミュレーター上でESCキー、GRAPHまたはスペースキーをを押しながら立ち上げる事で、直接ゲームを起動できます。
コナミの新１０倍カートリッジを無効化する場合は、ブート時にSHIFTキーを押しながら立ち上げます。
スロット２にソフトが無い場合でもGRAPHまたはスペースキーの起動が可能ですが、その場合はMSX-BASICまたはMSX-DOSが起動します。

メニュー２ : MODIFY

machine configurations

コナミの新１０倍カートリッジは上に改造対象のカートリッジの番号を表示しています。(RC-7xxなど）

MODIFY STAGE NUMBER: 開始するステージの入力
MODIFY PLAYER NUMBER: プレイヤーの数を決定します
START GAME: 改造を適応した状態でゲームを起動します。

メニュー３ : SELF (スロット２にソフトが挿入されてなくても利用可能）

machine configurations

SELF MODE MENU:

LOAD SCREEN DATA:
ゲームのスクリーンキャプチャをロードします。
キャプチャーした画像をMSX上で読み込む方法として、以下の手法が使えます。(ディスクに保存した場合。）
- カーソルをENDにあわせます
- 左CTRLキー＋SHIFTキー＋Spacebarを押します。
- *.VRM拡張子のファイルが作成されます。
- *.VRMファイルはMSX-BASICで読み込めるファイル形式で以下のプログラムを利用してロード表示ができます。
- MSX1の場合は
COLOR 15,0,0: SCREEN 2,2: BLOAD "ファイル名.VRM",S: A$=INPUT$(1)
- MSX2の場合は
COLOR 15,0,0: SCREEN 5,2: BLOAD "filename.VRM",S: COLOR=RESTORE: A$=INPUT$(1)

SRAM SCREEN DATA:下を参照
TENNIS AND HOCKEY:　ミニゲームが遊べます。
BIORYTHM: バイオリズムが起動します。

SRAM DISK UTILITY:

- 約10種類ほどのゲームにおいて、コナミの新１０倍カートリッジのSRAM機能を利用してデータをセーブする事ができます。
- SRAMを利用するに当たって、事前にフォーマットをする必要があります。　その場合は３つ目のオプションのFORMATを利用します。
- SRAMの内容消す場合はFILE DELETEを利用します。
- 要領は8KBの制限があるので、それほど沢山セーブする事はできないのでご注意ください。
- こちらのリンクから、SRAMの内容をディスクへ転送ができるツールを入手していただけます。 http://www.msxnet.org/utils/

各種機能説明

machine configurations
SRAM機能 | - 一部のゲームにおいて利用できますが事前にSRAMの初期が必要になります。（上を参照） ゲームによってSRAMへの利用法がことなります。 - 魂斗羅 / ゴーファーの野望ＥＰＩＳＯＤＥII / パロディウス F1でゲームをポーズ、SキーでセーブでLキーでSRAMからロードします。 - 激突ペナントレース / 激突ペナントレース２ SRAMはリーグデータとチームデータの保存に使用されます。 - 牌の魔術師 SRAMへのセーブは局の終了時に利用できます。 - エルギーザの封印 (MSX1 と MSX2 両バージョン) カスタムステージの保存とロードにしようされます。 - シャロム 特定の場所にてセーブが可能になります。 - ソリッドスネークメタルギア２ F5キーから保存とロードを行います。
ポーズ機能 | - ゲームの実行中にストップ(=PageUp)を押してポーズをかけます。 デモ中でもパーズをかける事ができ、パーズ中はCAPSロックのLEDが点灯します。 ポーズモードを解除するには再度ストップ(=PageUp)をおします。 （同時にCAPSロックのLEDも消えます。）
コマ送り機能 | - ポーズ中に、”；”キーを押して一コマづつ前進させます。
スローモーション機能 | - ポーズ中にESCキーを押して、スローモーションモードを有効にします。 再生速度はDELキーとINSキーで調節できます。 スローモーションを解除するには再度ストップ(=PageUp)をおします。
セーブ/ ロード機能 | - ポーズ中に、左CTRLキーを押して、セーブ/ ロード機能機能を有効化します。 - セーブ機能には２つの項目から選択できます：ゲームのセーブ/スクリーンのセーブ - セーブ対象はディスクへのみとなります。 - セーブされたデータはコナミのゲームを１０倍楽しむカートリッジとは互換性はありません。 - 保存されたファイルには拡張子として、*.Hxx（ハイスコア）、*.Gxx(ゲームデータ）、*.Sxx（スクリーンデータ）が存在し、xxの部分にコナミのRC型番が追加されます。 - スクリーンのデータファイルはベーシックから読み出し可能なフォーマットにコンバードが可能です。（SELFのセクションを参照）
リスタート機能 | - ポーズ中に、左CTRLキーを押して、セーブ/ ロード機能機能を有効化し、カーソルをENDに合わせます。 - 左CTRLキー＋SHIFTキー＋Spacebarを押します。 - コナミの新１０倍カートリッジとゲームの両方が完全にリセットされます。

MSX1用ソフトの追記（カートリッジはなるべくスロット２に挿入されていなければならない。）

machine configurations
ゲーム名 | RC | 追記 | SRAM
けっきょく南極大冒険 | 701 | プレイヤーの数の変更は不可 |
わんぱくアスレチック | 700 |  |
キャベッジパッチキッズ | 716 |  |
サーカスチャーリー | 712 |  |
ぽんぽこぱん | 714 |  |
F1 Spirit / A1 Spirit | 752 | ステージ選択、プレイヤー数、ランキングモード不可 |
フロッガー | 704 | ステージ選択不可 |
ゴーファーの野望ＥＰＩＳＯＤＥII / Nemesis 3 | 764 |  | GOFE1 GOFE2
グラディウス 1 / Nemesis 1 | 742 |  |
グラディウス 2 / Nemesis 2 | 751 |  |
ハイパーオリンピックI / Track & Field 1 | 710 | プレイヤーの数の変更は不可 |
ハイパーオリンピックII / Track & Field 2 | 711 | プレイヤーの数の変更は不可 |
ハイパーラリー | 718 | プレイヤーの数の変更は不可 |
ハイパースポーツ１ | 715 | プレイヤーの数の変更は不可 |
ハイパースポーツ２ | 717 | プレイヤーの数の変更は不可 |
ハイパースポーツ３ | 733 | プレイヤーの数の変更は不可 |
王家の谷 | 727 |  |
エルギーザの封印 （MSX1版） | 760 |  | FILE1 FILE2 FILE3
魔城伝説 | 739 |  |
ガリウスの迷宮 | 749 | ステージ選択、プレイヤー数、ランキングモード不可 |
シャロム | 754 | ステージ選択、プレイヤー数不可 | SHALM
コナミのベースボール | 724 | ステージ選択、プレイヤー数、ランキングモード不可 |
ビデオハスラー | 706 | ステージ選択不可 |
コナミのボクシング | 736 | プレイヤー数、ランキングモード不可 |
コナミの麻雀道場 | 707 | ステージ選択、プレイヤー数、ランキングモード不可 |
コナミのピンポン | 731 | ステージ選択、プレイヤー数、ランキングモード不可 |
コナミのサッカー | 732 | プレイヤー数、ランキングモード不可 |
コナミのテニス | 720 | ステージ選択、プレイヤー数、ランキングモード不可 |
マジカルツリー | 713 |  |
モン太君のいち・に・さんすう | 702 | ステージ選択不可 |
モピレンジャー | 728 |  |
パロディウス | 759 |  | PARO
ピポルズ | 729 |  |
Qバート | 746 |  |
ロードファイター | 730 | プレイヤーの数の変更は不可 |
沙羅曼蛇 | 758 |  |
スカイジャガー | 721 |  |
スーパーコブラ | 705 | ステージ選択不可 |
グーニーズ | 734 | プレイヤーの数の変更は不可 |
タイムパイロット | 703 | ステージ選択不可 |
ツインビー | 740 |  |
イーアルカンフー | 725 |  |
イーガー皇帝の逆襲 | 737 |  |
夢大陸アドベンチャー | 743 |  |

MSX2用ソフトの追記（カートリッジはなるべくスロット１に挿入されていなければならない。）

machine configurations
ゲーム名 | RC | 追記 | SRAM
魔城ドラキュラ | 744 |  |
魂斗羅 / Gryzor | 762 | SRAMオプションのみ ゲームのカートリッジをスロット1へ、コナミの新１０倍カートリッジをスロット２へセットする事が推奨されます。 | CONTR
がんばれゴエモン！からくり道中 | 748 |  |
激突ペナントレース | 757 | ステージ選択不可、プレーヤー数が設定不可 | PENAN
激突ペナントレース２ | 766 | SRAMオプションのみ | PENA2
牌の魔術師 | 765 | SRAMオプションのみ ゲームのカートリッジをスロット1へ、コナミの新１０倍カートリッジをスロット２へセットする事が推奨されます。 | MAJAH
火の鳥鳳凰編 | 747 |  |
キングコング２ | 745 | ステージ選択不可、プレーヤー数が設定不可 |
エルギーザの封印 （MSX2版） | 761 |  | FILE1 FILE2 FILE3
メタルギア | 750 | ステージ選択不可、プレーヤー数が設定不可 |
メタルギア２ ソリッドスネーク | 767 | SRAMオプションのみ | SNAK1 SNAK2 SNAK3
スペースマンボウ | 768 | 一部の機能が有効：ステージ選択、プレーヤー数が可能。 |


blueMSX ディスクイメージの起動方法

■ ディスクイメージの起動方法

ディスクイメージはフロッピーディスクの内容をデータ化した物です。ディスクイメージには*.dskという拡張子がつかられていますが、blueMSXでは他に*.di1と*.di2などの拡張子も認識します。

これらのディスクイメージの起動には5通りの方法があり、これかれそれらの方法を解説したいと思います。

最初の３つの方法では、初めからエミュレーターが起動している状態で実行しますが残りの方法はエミュレーターと同時にディスクイメージも起動する方法です。　また5番目の方法として、ディスクイメージを直接ダブルクリックする事で起動させる方法ですが、事前にblueMSX上で拡張子の関連付けをしておかなくてはなりません。　その方法はオプション＞その他＞blueMSXに関連付けるファイル種類....の項目を有効にします。

blueMSXは起動されたディスクイメージを（標準で１０ファイル）記憶しています。　ディスクのイメージ選択画面で確認する事が出来、ファイル選択メニューから再度選ぶ必要がなく、記憶された一覧から選択が可能です。

machine configurations
ディスクイメージ選択方法その１：メニューを使用 | -blueMSXをアイコン又はショートカットのダブルクリックで起動 -メニューからディスクドライブA(B)＞挿入 -ファイル選択メニューから任意のディスクイメージを選択 -選択し終えたら、ショートカットのF9(=起動)または、F12(=リセット）でMSXを起動させましょう。 ”挿入/取り出し後リセット”オプションを使うことで、自動的にMSXをリセットし起動する事ができます。

machine configurations
ディスクイメージ選択方法 その２：ツールバーを使用 | -blueMSXをアイコン又はショートカットのダブルクリックで起動 -ツールバーの5番目のアイコン（ディスクドライブAに挿入ボタン）をクリックし、ファイル選択メニューを呼び出します。 -ファイル選択メニューから任意のディスクイメージを選択 -選択し終えたら、ショートカットのF9(=起動)または、F12(=リセット）でMSXを起動させましょう。 ”挿入/取り出し後リセット”オプションを使うことで、自動的にMSXをリセットし起動する事ができます。

machine configurations
ディスクイメージ選択 方法その３： ショートカットから呼び出す | -blueMSXをアイコン又はショートカットのダブルクリックで起動 -ショートカットキーLCTRL+F9を押し、ファイル選択メニューを呼び出します。（左コントロールキーとファンクションキーの9です。） -ファイル選択メニューから任意のディスクイメージを選択 -選択し終えたら、ショートカットのF9(=起動)または、F12(=リセット）でMSXを起動させましょう。 ”挿入/取り出し後リセット”オプションを使うことで、自動的にMSXをリセットし起動する事ができます。

machine configurations
ディスクイメージ 選択方法その４： ドラッグ＆ドロップ | -ディスクイメージを直接blueMSXのアイコンやblueMSXの画面の上にドラッグ＆ドロップします。 -アイコンにドラッグ＆ドロップし場合は、自動的にエミュレーターがリセットされ、エミュレーションがスタートさせます。 ”挿入/取り出し後リセット”オプションが解除されている場合は手動でリセット又は電源をいれてエミュレーションをスタートさせます。 -画面にドラッグ＆ドロップし場合は、F9(=起動)または、F12(=リセット）を押してMSXを起動させます。 ”挿入/取り出し後リセット”オプションが設定されている場合は自動的にリセットされエミュレーションがスタートします。

machine configurations
ディスクイメージ選択 方法その５：ダブルクリック | この方法は冒頭で述べた、拡張子の関連付けをしておかなくてはなりません。 オプション＞その他＞blueMSXに関連付けるファイル種類.... -ディスクイメージを直接ダブルクリックする事により、自動的にblueMSXが起動します。 ”挿入/取り出し後リセット”オプションが解除されていても、リセットされエミュレーションがスタートします。 ＊この方法は”挿入/取り出し後リセット”の選択に関わらず、ディスクイメージは自動起動します。

■ Ｑ＆Ａ

複数枚のディスクを扱う場合は？
- ディスクイメージを入れ替えた際の自動リセットを阻止する為に、予め”挿入/取り出し後リセット”オプションを解除してください。
- ドライブAにディスクイメージを挿入し、blueMSXを起動させます。
- ディスクイメージを入れ替えるには上で述べた方法の1、２、か３を使用します。　便利な方法としてはblueMSX独自のディスクイメージ切り替え機能"v-DRIVE"を使用すといいでしょう。（ショートカットキー左ALT+F9　"v-DRIVE"の細かな詳細は専用のページにて解説されています。
- 切り替え後はソフトウェアの指示に従って進めてください。

ZIP圧縮されたイメージは扱えますか？
はい、可能ですが上で述べた５番目の方法（ダブルクリック）では使用できません。

- 圧縮ファイルに単一のディスクイメージしか収納されて無い場合は自動的にそのイメージを起動します。
- 複数のディスクイメージが収納されている場合は、ファイル選択画面が表示されます。　その中から希望のディスクイメージを選択します。

*.BAS / *.BIN / *.LDR　などイメージではないMSXのファイルを使いたい場合の方法は？
- ウィンドウズのドライブに適当なフォルダーを作成し、そこに必要なMSXファイルすべて解凍もしくは移します。(2DDのフロッピーディスクの要領を超えないように気を付けてください。)
- blueMSX上で”ディレクトリ挿入”を選択し、先ほど作成したフォルダーを指定します。
- 作成したフォルダーの中に”AUTOEXEC.BAS"などの起動用のファイルがない場合は、MSX-BASICがそのまま立ち上がります。　ファイルの中から専用の起動ファイルを探して実行させてください。（例：RUN"GAME.LDR")

ディスクドライブのＡとＢを同時に使用するには？
- 上で述べた方法の1、２、か３のいずれかの方法を選択します。
- ドライブAに一枚目のディスクイメージを挿入します。
- 続いてドライブBに次のディスクイメージを挿入します。
* 方法1を選択した場合は、ファイルメニューからディスクドライブB＞挿入
* 方法2を選択した場合は、ツールバーの6番目のアイコン（ディスクドライブBに挿入ボタン）をクリックします。
* 方法3を選択した場合は、ショートカットキーLCTRL+F10を押します。

ディスクイメージの自動起動させたくない場合は？
- ディスクドライブAかBの”挿入/取り出し後リセット”オプションを解除します。

動きません、どうしたらいいでしょうか？
- 上の起動方法の1、２、もしくは３を使用した場合は、”挿入/取り出し後リセット”オプションが解除されている恐れがあります。　この場合は手動で起動されなくてはなりません。　ショートカットのF9(=起動)または、F12(=リセット）でMSXを起動させましょう。

- ディスクイメージにはMSX2専用の物も数多く存在します。　お使いのマシン構成がMSX1の場合はMSX2専用ソフトは上手く起動しません。オプション＞エミュレーション＞MSXの種類をMSX2以降に設定しなおしてください。ツール＞マシン構成編集からもMSXの機種選択が可能です。

- ソフトウェアの中にはMSX2+以降やTurbo-R専用の物が存在します。

- MSX1,MSX2,もしくはMSX2+で正常に走るのに、Turbo-Rではうまく起動できないソフトがある場合は、リセット押した直ぐ後に"1”キーをビープ音が聞こえるまで押します、これによりMSX-DOS2が解除され読み込みができなかったソフト起動出来るようになる場合があります。

- MSX1では正常に起動できるのに、MSX2,MSX2+,もしくはTurbo-Rではうまくいかないソフトの場合はソフトウェアのローダーなどを調べ、リストの頭に次の命令分を追加してみてください。
   POKE -1,(15-PEEK(-1)\16)*17
  この汎用POKE文は他に存在する poke -1,0 や poke -1, 85 や poke -1,170 や poke -1,255 を置き換えた形で使用しなくてはなりません。

- 元々ディスクコントローラーを搭載しない機種ではフロッピーディスクは使用できません。方法としてはディスクロムをスロット1もしくはスロット2へ挿入するか、マシン構成編集で特殊な形で設定しなくてはなりません。

- ディスクイメージの中にはメモリ不足で上手く立ち上がらない場合があります。　その場合はリセット後に右CTRLキーを起動画面中押しっぱなしにし、二つ目のドライブが使用しているメモリーを切り離します。

- エミュレーターが何もしなくなった場合は、（エミュレーターの）再起動又はF12(=リセット）を押し、再起動させましょう。

- 一部のゲームやデモがまったく動作しない場合があり、それらの問題は：VDP又はZ80エミュレーションにおけるバグが原因が考えられます。blueMSXはまだ、一部のFDDエミュレーションしか導入されていません、そのため正確に動かないソフトも多数確認されています。　ディスクソフトで動かない物がありましたら、是非blueMSXの専用フォーラムにご一報ください。　あなたのバグ報告がblueMSXの進化と互換性向上に大いに役に立つはずです！


blueMSX ディスクドライブメニュー

■ ディスクドライブメニュー

machine configurations
挿入 | - ディスクイメージを任意のドライブ（AまたはB）へ挿入します。 - 拡張子に*.dsk/*.di1/*di2/*.zipのついたファイルをサポート - zipファイルに複数のイメージが含まれる場合は、任意のファイル選択ウインドウが表示されます。
ディレクトリ挿入 | - ウィンドウズのディレクトリをディスクAまたはBドライブとして仮想的に認識させる機能です。 - ディレクトリにはMSX対応ソフトの中身が存在しないと役割をはたしません。 中身に含まれるプログラムなどを元にブートセクターなどを構築し仮想イメージをとして起動する仕組みです。 - マウントしたディレクトリが起動してもMSX-BASICが立ち上がる場合は、自動実行される”AUTOEXEC.BAS"が用意されていない場合が原因と思われます。 その場合は手動で実行ファイルを探してRUN文で実行してください。 - この機能は使用上の安全を図るために読み込み専用としてのみ機能します。 変更する事は可能ですが、変更はウィンドウズ上のディレクトリには反映されません。 - この機能にはいくつかの制限があり、まずファイル数は１１２個以上を含む事はできません。 全要領も720Kb以内でなくてはいけません。 （立ち上げの際に必要なブートセクター要領も含みます。 MSXのサブディレクトリには対応しない他、特殊なブートセクターもサポートしません。
取り出し | - ディスクイメージまたはディレクトリを取り出します。
挿入/取り出し後リセット | - 有効の場合は新しくディスクを挿入した際に自動的にエミュレーターがリセットされ再起動するようになります。
使用したファイル | - 差も最近使われた順番でディスクイメージの一覧を表示されます。


blueMSX v-DRIVE

■ Virtual Drive (通称：v-DRIVE)

- v-DRIVEってなんですか？
v-DRIVEはblueMSXｖ1.3.0で初めて導入された補助機能です。　さて一体何を補助してくれるのでしょうか？　実際はいたって単純な仕組みで、ショートカットを介して同じソフトのフロッピーディスクを切り替える際に補助してくれる機能です。　ディスク切り替えの際にわざわざファイルメニューへ行かずに済むと言う訳です。　特に枚数の多いソフトやディスク入れ替えが頻繁な場合などには非常に便利です。　是非使い方をマスターしてください。

- 仕組みについて
仮にユーザーが（同じソフトの）複数枚ディスクイメージを持っていたとします、それぞれイメージ名には[DISK-1.dsk, DISK-2.dsk, DISK-3.dsk]と順番が付けられている事を仮定します。　blueMSXはそれらのイメージ名と割り振られた数字を頼りに順番を把握し、全体で３枚のディスクが同じソフトに存在すると（判断）認識します。　そのほかに数字でなくとも、アルファベット順に名前が振られたディスクイメージも認識する事が可能です。

- 使い方は？
複数のディスクに対応したゲームをエミュレーションしているとします、ディスク交換を促す趣旨のメッセージが出たらショートカットのLALT+F9（左ＡＬＴキーファンクションキーの９)を押します。画面上には（切り替えられる）ディスクイメージ名が書かれた小さな窓が表示されます。（上の画を参照）　さらにもう一度ショートカットを押すと次のディスクイメージに切り替わります。　もし最後のディスクイメージまでショートカットを押し続けた場合は一番最初のディスクイメージに戻る仕組みになっています。　要するに、ディスクイメージを順番にサイクルさせている訳です。　その動作を図で表した物が下の図になります。

- 注意する点は？
v-DRIVEが正確に動作するには、少しだけ注意する点があります。　現在のヴァージョンではZIP圧縮された、複数枚の単一のディスクイメージをサポートしません。（例：-- -- DISK-1.zip, DISK-2.zip, DISK-3.zip...など）　ただし、複数のディスクイメージを一つの書庫として圧縮したZIPファイルはサポートしております。　ユーザーは使いたいディスクイメージを任意のディレクトリーに解凍して使用する事をお勧めいたします。


blueMSX テープイメージの起動方法

■ CASイメージの起動方法

CASイメージはカセットに対応したデータが保存された専用イメージです。　拡張子には*.casが付いている事が多いです。

これらのテープイメージは5通りの方法で起動と実行する事ができます、お使いの用途にあった方法を見つけてみてください。

最初の３つの方法では、初めからエミュレーターが起動している状態で実行します。　また5番目の方法として、テープイメージを直接ダブルクリックする事でテープイメージを挿入する方法ですが、事前にblueMSX上で拡張子の関連付けをしておかなくてはなりません。　その方法はオプション＞その他＞blueMSXに関連付けるファイル種類....の項目を有効にします。

blueMSXは起動されたテープイメージを（標準で１０ファイル）記憶しています。　テープのイメージ選択画面で確認する事が出来、ファイル選択メニューから再度選ぶ必要がなく、記憶された一覧から選択が可能です。

テープイメージはロムやディスクと違い、自動実行には対応していません。　MSX-BASICからユーザーが手動でテープイメージのロードと実行命令を入力しなくてはなりません。　主なテープイメージのロード方法は下記のコマンドにて可能です、ソフトに対応したロード方法を選択してください。

- RUN"CAS:"
- LOAD"CAS:",R
- BLOAD"CAS:",R
- CLOAD + F5 (ベーシックで組まれたプログラムの読み込みなど）

machine configurations
テープイメージ選択方法 その１：メニューを使用 | -blueMSXをアイコン又はショートカットのダブルクリックで起動 -メニューからカセットテープ＞挿入 -ファイル選択メニューから任意のテープイメージを選択 -選択し終えたら、ショートカットのF9(=起動)または、F12(=リセット）でMSXを起動し、MSX-BASICを立ち上げます。

machine configurations
テープイメージ選択方法 その２：ツールバーを使用 | -blueMSXをアイコン又はショートカットのダブルクリックで起動 -ツールバーの7番目のアイコン（カセットテープを挿入ボタン）をクリックし、ファイル選択メニューを呼び出します。 -ファイル選択メニューから任意のテープイメージを選択 -選択し終えたら、ショートカットのF9(=起動)または、F12(=リセット）でMSXを起動し、MSX-BASICを立ち上げます。

machine configurations
テープイメージ選択 方法その３： ショートカットから呼び出す | -blueMSXをアイコン又はショートカットのダブルクリックで起動 -ショートカットキーLCTRL+F11を押し、ファイル選択メニューを呼び出します。（左コントロールキーとファンクションキーの11です。） -ファイル選択メニューから任意のデテープイメージを選択 -選択し終えたら、ショートカットのF9(=起動)または、F12(=リセット）でMSXを起動し、MSX-BASICを立ち上げます。

machine configurations
テープイメージ選択方法 その４：ドラッグ＆ドロップ | -テープイメージを直接blueMSXのアイコンやblueMSXの画面の上にドラッグ＆ドロップします。 -アイコンにドラッグ＆ドロップし場合は、自動的にエミュレーターがリセットされ、MSX-BASICが起動します。 （テープイメージは”挿入後巻き戻し”のオプションの有無にかかわらず、自動的に巻き戻した状態でスタートさます。） ＊blueMSXを最初に起動させた状態でテープイメージをウィンドウにドラッグ＆ドロップし、”挿入後巻き戻し”が無効になっている場合はテープイメージは自動的に巻き戻されません。

machine configurations
テープイメージ選択方法その５：ダブルクリック | この方法は冒頭で述べた、拡張子の関連付けをしておかなくてはなりません。 オプション＞その他＞blueMSXに関連付けるファイル種類.... -テープイメージを直接ダブルクリックします。 -自動的にblueMSXが起動し、MSX-BASICが起動します。 ”挿入後巻き戻し”オプションが解除されていても、自動的に巻き戻した状態でスタートさます。

■ Ｑ＆Ａ

ZIP圧縮されたイメージは扱えますか？
はい、可能ですが上で述べた５番目の方法（ダブルクリック）では使用できません。

- 圧縮ファイルに単一のテープイメージしか収納されて無い場合は自動的にMSX-BASICが立ち上がります。
- 複数のテープイメージが収納されている場合は、ファイル選択画面が表示されます。　その中から希望のテープイメージを選択します。

テープイメージを書き込みモードで使用する場合は？
- ”テープを読み込み専用にする”オプションを解除する事により、テープイメージが書き込みモードに変更されます。

テープイメージの自動巻き戻しを阻止する場合は？
- ”挿入後巻き戻し”オプションを解除する事で、手動による巻き戻しが可能になります。

動きません、どうしたらいいでしょうか？
- テープイメージはロムやディスクイメージと違い、自動立ち上げには対応していません。　ユーザーが手動でMSX-BASICを立ち上げてから、任意のロード方法を実行しなくてはなりません。

- RUN"CAS:"
- LOAD"CAS:",R
- BLOAD"CAS:",R
- CLOAD + F5 (ベーシックで組まれたプログラムの読み込みなど）

- ”挿入後巻き戻し”オプションが解除されている場合は、途中からテープが始まっている場合があります。　その場合はカセットテープ＞巻き戻しを実行するか、ショートカットのLCTRL+LSHIFT+F11を押してテープを巻き戻します。（左コントロールと左シフトキーとファンクションキーの11です。)

- 多くのカセットソフトはMSX1用でしたので、出来るだけMSX1をマシンとして選択し起動してください。　マシンの変更はオプション＞エミュレーションから可能です。

- Turbo-R上ではテープ端子を搭載していない為、テープ専用ソフトを扱う事はできません。

- エミュレーターが何もしなくなった場合は、（エミュレーターの）再起動又はF12(=リセット）を押し、再起動させましょう。

- 多数のカセットソフトはより多くのメモリーを必要とします。　メモリを多く得るにはディスクシステムに使用されている部分を切り離す事で可能です。　MSXを立ち上げと同時に、CTRLキーまたはSHIFTキーを押しながらMSX-BASICを起動させましょう。

- 一部のソフトにて”テープ位置セット”を使用しないと立ち上げれない場合があります。　（”テープ位置セット”を使って、任意のファイル名を指定しそこからテープを再生させると言う事になります。）

- 一部のゲームやデモがまったく動作しない場合があり、それらの問題は：VDP又はZ80エミュレーションにおけるバグが原因が考えられます。　テープソフトで動かない物がありましたら、是非blueMSXの専用フォーラムにご一報ください。　あなたのバグ報告がblueMSXの進化と互換性向上に大いに役に立つはずです！


blueMSX カセットメニュー 詳細

■ カセットメニュー 詳細

こちらがblueDECKの基本メニューオプションとその説明になります。になります。

machine configurations
挿入 | - テープイメージを読み込みます。 - 対応フォーマットは*.casとZIP書庫になります。 *.casのフォーマットはfMSX-DOS形式とfMSX98/ATを自動認識いたします。 - 複数のテープイメージが収納されたzip書庫を読み込んだ場合は専用のイメージ選択ウィンドウが開きます。 - 新しいテープイメージの作成は、ファイル選択メニューに新しいファイル名を入力する事で自動的に空の*.casファイルが作成されます。
取り出し | - テープイメージを取り出します。 注意：blueDECKは最後に再生されたテープの位置を記憶しています。（実際のデータレコーダーと同じ扱いになります。
挿入後巻き戻す | - テープイメージを挿入時に自動的に巻き戻します。 - 最後に取り出したテープ位置を記憶しているので、このオプションを使う事で自動的にテープイメージを最初の位置に戻す事が可能です。
テープを読み込み専用にする | - 大切なテープイメージなどに誤って書き込みを防止する為のオプションです。 このオプション時にセーブをしても、メモリにストックされるだけで、- 実際にはテープイメージに書き込みはされません。 - 実際にセーブしたい場合は必ずこのオプションを解除してください。
テープを別名でセーブする | - セーブされたデータを*.casファイルとして保存します。 - fMSX-DOSとfMSX98/ATのフォーマット書き出しが可能です。
テープ位置セット | - テープイメージの内容が表示され、その中のファイル名を選択することでテープの頭出しができます。
巻き戻し | - テープイメージを巻き戻します。
最近使ったファイル | - 最近使われた*.casファイルの一覧を表示されます。 すばやくイメージにアクセスしたい場合にご使用いただけます。


blueMSX blueDECK (テープ/カセットエミュレーション）

■ blueDECK (テープ/カセットエミュレーション）

- blueDECKってなんですか？
blueMSXv1.3.0から搭載された、独自のカセットエミュレーション機能です。

- blueDECKの独自性ってどんな部分ですか？
blueDECKは使いにくいカセットエミュレーションの操作性を、色々な思考をこらした機能で補っています。　中でも、テープイメージの途中からの再生やロードポイントへの頭出しなどを目で確認できる”テープ位置セット”オプションはblueMSXならではの独自機能です。　（おそらく、このような機能は他のエミュレーターでは搭載されていないでしょう。。。）

- テープイメージの扱いに関してはこちらの専用ページで詳しく解説されています。

- テープ位置セットってなんですか？
blueDECKはテープイメージの分析をし、保存されている内容を表示することが可能です。　この機能を使うことにより”早送り”が不要になり、スタートしたいデータが保存されている位置へ、フェイル名を選び簡単に頭だしをする事ができます。（なので、基本的には巻き戻ししか必要ありません。）

- 対応フォーマットは？
blueDECKでは支流のfMSX-DOSフォーマットの他に旧式のfMSX98/ATにも対応しています。

- テープ位置を記憶しているって具体的にどういう事ですか？
実際のデータレコーダーでは、最後にテープを取り出したところが、次回始まるポイントにあたります。　blueDECKではこれと同じ事を再現するために、テープイメージを取り出したポイントを記憶する仕様になっています。　そのため、エミュレーターを終了しても、次回同じテープイメージを挿入すれと、前回取り出した部分から再開できるようになっています。

- 挿入後巻き戻す
上で触れた、テープ位置を記憶している事から、挿入時のイメージは巻き戻った状態ではない場合があります。　その場合はこのオプションを入れておくと、必ず挿入時には巻き戻った初期状態にしてマウントされます。　途中再開したくない場合に利用すると便利だと思います。


blueMSX 外部カセットデータベース

■ 外部カセットデータベース

blueMSXでは(CRC32コード)を利用した外部カセットデータベースが利用でき、themeとの併用でテープイメージの詳細を表示したり、ロード方法などの上を収納する事ができます。

もし、お持ちのテープイメージがデータベースに登録されていない場合はユーザーが自ら登録することが可能です。 blueMSXのインストールされているディレクトリにcasdb.datというファイルがありそれをテキストエディターなどで編集する形で実施されます。　それでは、casdb.datにデータの追加方法をこれから解説いたします。

データの構成はテープイメージ一つにたいして一行という決まり事があります。

フォーマットはこのようになっています。
[crc] [詳細（任意）]

[crc] は必ず小文字でなければなりません。

参考例：

8c204dfb Oh Shit !

■ CRC32の照合データの取得方法は？

詳しい方法はこちらで解説されている部分が応用できます、参考にしてください。

■ [詳細（任意）]部分の用途は？

詳細部分は任意でなくても構いませんが、DIGIblueのようなテーマを使用した際には追加情報として内容を表示させる事ができます。

推奨される詳細情報のフォーマット形式は以下のようになります。

ソフトの名称 (発売された年) (発売元名) [その他の追加情報 (任意)] [crc]

[その他の追加情報 (任意)] 部分には複数の情報を追加する事ができます。

例：
- ソフトを起動されるための命令文
- TOSECなどに使用されている記号など
- 多言語のヴァージョン情報など

この部分は自由に情報を記載する事ができます、カセットの情報整理などに利用してみては？


blueMSX その他の特殊機能

■ その他の特殊機能

blueMSXには他にも様々な特殊機能が盛り込まれています。　エミュレーターでしか実現できない発想の物や、より楽しくユーザーに使っていただくため、導入した物もあります。

machine configurations
オーディオ録音機能 | - MSXの音源は非常に表現力で優れており、当時のパソコンの中でも個性的なサウンド機能を搭載していました。 その為多くのMSXユーザーが懐かしいサウンドを楽しむ為にエミュレーターを使う事も珍しいくありません。 blueMSXのオーディオ録音機能はそんなユーザーのためにエミュレーション中の音をWAV録音する為の物です。 - ショートカットの左シフトキー＋F7で録音の開始と停止を行う事ができます。（又はファイルメニューからも可） - 作成される*.wavファイルは自動的に"Audio Capture"の専用ディレクトリに保存されます。 - ファイル名は自動生成され、イメージ名と二桁の数字が割り振られます。

machine configurations
スプライト表示の有無 | - blueMSXの隠し機能の一つで、スプライト表示の有無を切り替える事が出来ます。 ゲームのマップ作成の際にスプライトが邪魔になり、綺麗な画像キャプチャーが出来ない場合に力を発揮します。 -この機能はショートカットからの利用のみです。 標準は左コントールキー＋左シフトキー＋Sキーです。

machine configurations
実行速度調整 | - エミュレーションの実行速度の調整が可能で、元々処理速度の遅いソフトやビジュアルシーンを飛ばしたりする時に便利な機能といえます。 * LShift+F9 = 押している間だけ加速する、いわば早送り的な機能です。 * LShift+F10 = 実行速度を標準値の3.579Mhzに戻します。 * LShift+F11 = 実行速度を5%下げます。 * LShift+F12 = 実行速度を5%上げます。 エミュレーションのポーズと実行はF9を押して切り替えます。

machine configurations
ステートセーブ | - セーブ出来ないゲームや、長いパスワードを書き写さなくてはならない、など余計な手間を一気に解消するのが、ステートセーブ機能です。 使っている状況（ステート）を全てファイルとして保存する仕組みです。 現在ステートセーブには２種類の手法が用意されています。
クイックセーブ | - ファイル名指定をする事なく高速にステートセーブする目的にで作成された機能です。 （シューティングゲームなどで使うと便利） - ショートカットのF8キーで実行する事ができ専用の"QuickSave"フォルダーに*.staというファイルで保存されます。 - ファイル名は自動生成され、イメージ名と二桁の数字が割り当てられます。
ステート保存 | - 仕組みは同じですが、こちらはファイル名をユーザーが指定する方法で行います。（その分時間がかかります。） - ショートカットの左ALTキー＋F8キーで実行する事ができ、ファイルダイアロクが表示されるのでファイル名を指定して保存します。セーブされるファイルには拡張子の*.staが付きます。
注意点と約束事 | - いずれの場合もblueMSXはステートセーブの保存内容として、使われているマシン構成や実行しているファイルの読み込み先など”すべて”を記録します。 従って、一つでも条件が変更されると互換性が損なわれ、ステートの復帰が出来なくなります。 必ずこれらの条件を念頭にご利用ください。 エミュレーターのヴァージョンが変わるとステートセーブの仕様も当然変更されるので互換性はなくなりますの十分ご注意ください。 -セーブされたステート*.staファイルはロムと似た扱いが出来るため、直接起動させる事ができます。 * ファイルメニューの"クイックロード”または”CPUステート読み込み”から復帰できます。 * 保存された、*.staファイルをエミュレーターに直接ドラッグ＆ドロップ * 保存された、*.staファイルを直接ダブルクリック。 （事前にファイルの関連付けが必要になります。 ”オプション>その他>blueMSXに関連付けするファイル”を有効化する。）

machine configurations
スクリーンショット | - 動作中のエミュレーター画面も簡単に取り込む事が出来ます。 好きなゲームの画面をキャプチャーしたり、マップ作成などに便利です。 現在blueMSXでは3種類のキャプチャーモードをサポートしています。 * PrtScrn =通常のスクリーンショットを実行します、同様の機能はファイルメニューからも可能。 （画像モードが通常の場合は320 x 240ピクセルで出力され、２倍モードとフルスクリーンでは640 x 680ピクセルになります。） * RAlt+F11 = 縮小画質でスクリーンショットを実行します。（272 x 240ピクセル） * RAlt+F12 = 大きい画質でスクリーンショットを実行します。(544 x 480ピクセル） - キャプチャーされた画像はすべて、"Screenshots"フォルダに*.bmpとして保存されます。 - ファイル名は自動生成され、イメージ名と二桁の数字が割り当てられます。


blueMSX コマンドライン詳細

■ コマンドライン詳細

blueMSXで使用できるコマンドライン一覧になります。

machine configurations
/rom1 <filename> | - 任意のロムイメージをカートリッジスロット1に設置します。 ファイルネームにはロムイメージ名を指定します。
/rom2 <filename> | - 任意のロムイメージをカートリッジスロット2に設置します。 ファイルネームにはロムイメージ名を指定します。
/romtype1 <rom type> | - 任意のロムイメージのマッパーを指定してスロット1に配置します。 ロムタイプの指定が無い場合は外部データベースから適したマッパーを自動的に割り当てられます。 ロムタイプ名には下記のマッパーリストから選択して記載します。
/romtype2 <rom type> | - 任意のロムイメージのマッパーを指定してスロット2に配置します。 指定方法は上と同じ。
/diskA <filename> | - ディスクドライブAに任意のディスクイメージを配置します。 ファイルネームにはディスクイメージ名を指定します。
/diskB <filename> | - ディスクドライブBに任意のディスクイメージを配置します。 ファイルネームにはディスクイメージ名を指定します。
/cas <filename> | - カセットポートに任意のテープイメージを配置します。 ファイルネームにはテープイメージ名を指定します。
/rom1zip <filename> | - スロット1に挿入する、zip書庫に収納された特定のイメージファイルを指定します。デフォルトは最初のファイルを読み込む事になっています。
/rom2zip <filename> | - スロット2に挿入する、zip書庫に収納された特定のイメージファイルを指定します。デフォルトは最初のファイルを読み込む事になっています。
/diskAzip <filename> | - ドライブAに挿入する、zip書庫に収納された特定のイメージファイルを指定します。デフォルトは最初のファイルを読み込む事になっています。
/diskBzip <filename> | - ドライブBに挿入する、zip書庫に収納された特定のイメージファイルを指定します。デフォルトは最初のファイルを読み込む事になっています。
/caszip <filename> | - カセットポートに挿入する、zip書庫に収納された特定のイメージファイルを指定します。デフォルトは最初のファイルを読み込む事になっています。
/fullscreen | - フルスクリーンモードで立ち上げます。 指定が無い場合は２倍サイズで立ち上がります。- フルスクリーンモードで立ち上げます。 指定が無い場合は２倍サイズで立ち上がります。
/machine <name> | - 起動したい機種を指定します。 例：MSX / MSX2J / MSXBR / MSX2+ / "MSX+ Panasonic FS-A1FX"
/language <name> | - エミュレーターの使用言語を指定します。 使用したい言語は必ず小文字で入力します。 例： english / french / japanese
/theme <name> | - 立ち上げの際に使用するテーマを指定します。 名前はthemeフォルダーに収められているディレクトリ名と同一でなければなりません。
/reset | - エミュレータの設定を全て標準に戻します。 注意：マシンのリセットボタンではありません。
/inifile | - blueMSXの設定をレジストリーでは無く、*.iniファイルとして保存する命令です。

ロムマッパーとして指定できる種類一覧になります。

machine configurations
mirrored | 通常のロムとミラードロム
0x4000 | 通常のロムでアドレスが&H4000から始まる物
basic | MSX-BASICのものでアドレスが&H8000から始まる物
msxdos2 | MSX-DOS2.2のカートリッジのみ
konami5 | SCCを搭載したコナミのメガロム （例：王家の谷 エルギーザの封印など）
konami4 | SCCを搭載しないコナミのメガロム （例：ウシャス）
konami4nf | konami4の異なるヴァージョン （例：コナミの改造メガロムなど）
scc | コナミSCCサウンドチップ
sccmirrored | コナミSCCサウンドチップのミラード版
sccexpanded | コナミSCCサウンドチップの拡張版
scc+ | コナミSCC+サウンドチップ
snatcher | スナッチャー用のコナミSCC+サウンドチップ
sdsnatcher | SDスナッチャー用のコナミSCC+サウンドチップ
ascii8 | 8kbのアスキーメガロム （例：バブルボブルなど）
ascii16 | 16kbのアスキーメガロム （例：ゼビウスなど）
ascii16nf | 16kbのアスキーメガロムの異なるヴァージョン （例：改造メガロムなど）
ascii8sram | SRAMを搭載した8kbのアスキーメガロム （例：ザナドゥなど）
ascii16sram | SRAMを搭載した16kbのアスキーメガロム （例：ハイドライド２など）
koei | SRAMを搭載した光栄のメガロム （例：大航海時代など）
halnote | HALNOTE（SRAM搭載）専用
gamemaster2 | コナミの新10倍カートリッジ（SRAM搭載）専用
fmpac | パナソニックのFM-PAC（SRAMとMSX-MUSIC搭載）専用
pac | パナソニックのアミューズメントパック（SRAM搭載）専用
msxaudio | パナソニックのMSX-AUDIOカートリッジ専用
konamisynth | コナミの新生Sizer系専用
majutsushi | 牌の魔術師系専用
rtype | R-TYPE専用
crossblaim | クロスブレイム専用
harryfox | はーりぃふぉっくす 雪の魔王専用
loderunner | スーパーロードランナー専用
korean80 | 韓国産：30-in-1, 64-in-1 と 80-in-1専用
korean90 | 韓国産：90-in-1専用
korean126 | 韓国産：126-in-1専用
holyquran | (アラビア語MSX系用）Holy Quran専用
jisyo | 辞書専用 （文節カートリッジと併用）
bunsetsu | 文節カートリッジ専用
kanji | 漢字カートリッジ
tc8566af | パナソニックのフロッピディスクコントローラー専用
mb8877a | ナショナル/Daewoo産のMSXに搭載されていた専用ディスクコントローラー
wd2793 | フィリップス/ソニー産のMSXで搭載されていた専用ディスクコントローラー
microsol | マイクロソル専用ディスクコントローラー（主にブラジルのMSXに搭載されていた）
svi738fdc | Spectravideo産SVI-738専用ディスクコントローラー


blueMSX メニュー総合詳細

■ メニュー詳細

こちらのセクションではドロップダウンメニュー一覧の紹介と解説が掲載されています。

■ ファイル関連メニュー

machine configurations
ROMスロット1 | - このメニューはカートリッジスロット1の制御を行う為の物です。 - サブメニューにはロムの挿入と取り出しがあり、拡張子に*.ROM、*.MX１、*.MX2と*.ZIPのファイルを受け付ける事ができます。 ZIP書庫に複数のロムイメージが収納されている場合のみ、専用選択ウインドウが新たに表示されます。 - ”挿入/取り出し後リセット”の項目はロムの抜き差し後に自動リセットを行う為の物です。 メニュー下には最近使われたファイル一覧が表示され、再度利用したい場合にそこから選ぶ事ができます。 - ”その他”のサブメニューには特殊なロムを取り扱う為のオプションが用意されており、コナミ製のSCC(+)対応ソフトへのサポートを可能にしています。
ROMスロット2 | -このメニューはカートリッジスロット2の制御を行う為の物です。基本動作はROMスロット1とまったく同じです。
ディスクドライブ A | -このメニューはディスクドライブ Aの制御を行う為の物です。 サブメニューにはディスクの挿入と取り出しがあり、拡張子に*.DSK、*.DI1、*.DI2と*.ZIPのファイルを受け付ける事ができます。 ZIP書庫に複数のディスクイメージが収納されている場合のみ、専用選択ウインドウが新たに表示されます。 -”挿入/取り出し後リセット”の項目はディスクの抜き差し後に自動リセットを行う為の物です。 -メニュー下には最近使われたファイル一覧が表示され、再度利用したい場合にそこから選ぶ事ができます。
ディスクドライブ B | -このメニューはディスクドライブ B の制御を行う為の物です。基本動作はディスクドライブ Aとまったく同じです。
カセットテープ | -このメニューはカセットテープ(blueDECK)の制御を行う為の物です。 -サブメニューにはロムの挿入と取り出しがあり、テープ位置の制御には”巻き戻し”や”テープ位置セット”などが用意されています。 -拡張子に*.CASと*.ZIPのファイルを受け付ける事ができ、複数のテープイメージが収納されている場合のみ、専用選択ウインドウが新たに表示されます。 -メニュー下には最近使われたファイル一覧が表示され、再度利用したい場合にそこから選ぶ事ができます。
プリンター | - プリンターを次のページのトップまでフォームフィードします。
CPUステート 読み込み | CPUや設定情報などの読み込みメニューを呼び出します。
CPUステート 保存 | CPUや設定情報などの全ての情報を保存します。 実行した際にはファイルダイアログが表示されるので、名前を指定して保存します。
クイックロード | クイックセーブで穂保存された、簡易CPUステートの読み込みができます。
クイックセーブ | CPUステート保存の簡易版です。 保存名などの指定が不要で、手軽に扱う事が出来ます。
録音 | エミュレーション中の音を保存します。 録音と中断の両方を兼ねたオプションになっており、保存されたファイルは*.WAVとして、"Audio Capture"フォルダに保存されます。
スクリーンショット | エミュレーション中の画像をキャプチャーします。 保存されたファイルは*.BMPとして、"Screenshots"フォルダに保存されます。
終了 | blueMSXを終了します。 設定情報などは終了時に自動的に保存されます。

■ 実行関連メニュー

machine configurations
実行 / ポーズ | - エミュレータの実行とポーズの役割を担います。
停止 | - エミュレーションを停止させます。
ハードリセット | - エミュレータにハードウェアリセットをかけます。
ソフトリセット | - エミュレータにソフトウェアリセットを行います。 ソフトリセットされた場合がラムの内容は初期化されません。
クリーンリセット | - 挿入されているロムやディスクを抜いた状態でリセットが実行されます。

■ ウィンドウメニュー

machine configurations
標準サイズ | - エミュレーション画面を320x240ピクセルに設定します。
2倍サイズ | - エミュレーション画面を640x480ピクセルに設定します。
フルスクリーン | - エミュレーション画面を全画面表示に切り替えます。

■ オプション関連メニュー

machine configurations
ビデオソース | - ビデオソースの選択を行います。（可能な場合のみ） - 通常は最適なソースが自動的に選択されます。
エミュレーション | - エミュレーションの設定画面を呼び出します。
ビデオ | - ビデオ設定画面を呼び出します。
サウンド | - サウンド設定画面を呼び出します。
コントロール | - 操作系の設定画面を表示します。
パフォーマンス | - パフォーマンスに関する設定画面を呼び出します。
ファイル | - ファイル関連の設定画面の表示します。
その他 | - その他の設定画面を呼び出します。
ポート | - ポート設定画面の表示します。
言語 | - 表示言語選択の画面を表示します。

■ ツールメニュー

machine configurations
マシン構成編集 | - マシン構成編集画面を呼び出します。
ショートカット構成編集 | - ショートカット構成編集画面を呼び出します。
キーボード構成編集 | - キーボード構成編集画面を呼び出します。
Trainer | - Trainer (トレイナー）ツールを呼び出します。
Debugger | - Debugger (デバッガ）ツールを呼び出します。
Trace Logger | - Trace Logger (トレースロッガー)ツールを呼び出します。

■ ヘルプメニュー

machine configurations
ヘルプ目次 | - このヘルプを呼び出します。
blueMSXについて | - blueMSXについての詳細ウィンドウを表示します。


blueMSX ツールバー詳細

■ ツールバー詳細

こちらのセクションではツールバー一覧の紹介と解説が掲載されています。
ツールバーの大半がドロップダウンメニューと同じ役割を果し、ボタンなどで表現されています。
ボタンによってはサブメニューとしてドロップダウンが利用できます。

こちらが標準の”クラシック”スタイルのツールバーの外観です。

追加テーマオプションの”DIGIblue"を利用した場合のツールバーの外観です。

追加テーマオプションの”DIGIblue 2.0 "を利用した場合のツールバーの外観です。

このテーマからはドライブ類といったメニューが全て右側に移動しています。

最新の公式テーマの"DIGIblue SUITE-X"は基本は上のテーマと同じですが、新しくカセットの巻き戻しボタンが追加されました。（画面右）

■ ボタンの役割
左から順番に解説します。　（ボタンの隣の小さな下向き矢印マークや十字マークがサビューメニューになります。）

machine configurations
リセット | - エミュレーターをハードリセットします。 サブメニューにはソフトウェア、ハードウェアと、クリーンリセットが用意されています。
実行 | - エミュレーターを実行します。
ポーズ | - エミュレーターにポーズをかけます。
停止 | - 実行中のエミュレーターを停止させます。
ROMスロット1 | - カートリッジ1への挿入ボタンで、ファイル選択メニューを呼び出します。 サブメニューには通常メニューと同じ項目が用意されています。
ROMスロット2 | - カートリッジ2への挿入ボタンで、ファイル選択メニューを呼び出します。 サブメニューには通常メニューと同じ項目が用意されています。
ディスクドライブ A | - ディスクドライブ Aへの挿入ボタンで、ファイル選択メニューを呼び出します。 サブメニューには通常メニューと同じ項目が用意されています。
ディスクドライブ B | - ディスクドライブ Bの挿入ボタンで、ファイル選択メニューを呼び出します。 サブメニューには通常メニューと同じ項目が用意されています。
カセットテープ | - カセットテープの挿入ボタンで、ファイル選択メニューを呼び出します。 サブメニューには通常メニューと同じ項目が用意されています。
巻き戻し | - カセットテープの巻き戻しをします。（アイコンとしては”DIGIblue SUITE-X”のみで表示されています。）
ウィンドウ | - 画面モードを選択するためのボタンですが、サブメニューを利用し画面モードを選択します。
オプション | - オプションの詳細設定画面を呼び出します。 サブメニューには通常メニューと同じ項目が用意されています。
ヘルプ | - ヘルプマニュアルを起動します。


blueMSX 左パネル部分詳細

■ 左パネル部分詳細

公式テーマの"DIGIblue SUITE-X"の左パネルに表示されているLEDについての詳細になります。

machine configurations
上から順に：
- Caps Lockの有無を表すLED
- カナの無を表すLED
- R800プロセッサが機能しているかを表すLED
MSXに搭載されているスイッチの有無を表すLEDで、上から順に：
- F-S = パナソニックの前面スイッチ
- A-S = MSX-AUDIOのカートリッジ用スイッチ
- P-S = ポーズスイッチ

* これらの機能をON / OFF制御するボタンは右パネルに配置されて見ます。


blueMSX 右パネル部分詳細

■ 右パネル部分詳細

公式テーマの"DIGIblue SUITE-X"の右パネルに表示されているLEDとボタンについての詳細になります。

machine configurations
上から順に：
- FDDドライブ1がアクセス中に点灯します。
- FDDドライブ2がアクセス中に点灯します。
- カセットが動作中にに点灯します。
上の3つのボタンは下記の役割を担います。　なお、ON / OFFの状態は左パネルに表示されます。　上から：
- F-S = パナソニックの前面スイッチ
- A-S = MSX-AUDIOのカートリッジ用スイッチ
- P-S = ポーズスイッチ

空間を空けて下の５つのボタンはテーマの機能画面を切り替える為の物です、上から順に：
- STATUS = 基本テーマ画面
- MIXER = ミキサーコントロールテーマ画面
- VIDEO = ビデオテーマ画面
- CONTROL = コントロールテーマ画面
- K-CONF = キーボード構成編集ツール表示ボタン


blueMSX ステータスバー詳細

■ ステータスバー詳細

ステータスバーはblueMSXの動作中にあらゆる情報などを表示する機能を備えています。　"クラシック”テーマでは基本的な情報が得られますが、テーマオプションの"DIGIblue SUITE-X "を利用した際にはもっと細かな詳細を表示させる事ができます。

■ 標準ステータスバー詳細

machine configurations
パネル-1 | - 描画書き換えの数値を表示しています。
パネル-2 | - CPUの使用割合をパーセンテージで表示します。
パネル-3 | - エミュレーターが動作している周波数を表します。
パネル-4 | - 動作中のMSXが使用しているスクリーンモードを表示します。
パネル-5 | - ディスクドライブやカセットテープイメージなどにアクセスされた場合に、点滅して動作中である事を表しています。
パネル-6 (CAPS) | - エミュレーター使用時にCAPSキーが押されているときに点灯します。
パネル-7 (KANA) | - エミュレーター使用時にカタカナキーが押されているときに点灯します。
パネル-8 (FS) | - フロントスイッチの略で、MSX2+系の内蔵ソフトを使用したさいに点灯します。
パネル-9 (AS) | - オーディオスイッチ略で、パナソニックのFS-CA1(MSX-AUDIO)搭載の内蔵ソフトを利用している場合に点灯します。

■ DIGIblue SUITE-X 拡張ステータスバー詳細

上部の細長い窓枠には動作中ソフトの詳細（名前 / メーカー / 販売年などなど）を表示できる情報欄が用意されています。　外部のデータベースと連携しているので、ロムカートリッジ、ディスクイメージやテープイメージなどの情報を表示させる事ができます。

右パネル部分のBASEボタンを押す事でいつでもステータスパネルを表示する事ができます。

machine configurations
USAGE | - 描画書き換えの数値を表示しています。- CPUの使用割合をパーセンテージで表示します。
FPS | - 描画書き換えの数値を表示しています。
SCREEN | - 動作中のMSXが使用しているスクリーンモードを表示します。
VIDEO | - 動作中のMSX機種が搭載しているVRAMメモリーを表示されます。
MAIN | - 動作中のMSX機種が搭載しているメインメモリーを表示されます。
SCREEN | - エミュレーターが動作している周波数を表します。
MAPPER | - 動作中のロムのマッパー種類を表示。
% | - エミュレータが動作している速度をパーセントで表示。
画面右の大きなダイアル | - エミュレータの動作速度調整ダイアル。
画面右少ボタン | - エミュレータの動作速度をワンタッチで標準に戻します。

■ DIGIblue SUITE-X から切り替え可能なパネル3種：

MIXERボタンからはミキサーパネルを表示する事ができます。　基本的にはプロパティのオプション＞ミキサーの内容と操作は同じで、こちらはビジュアルを通して音量を確認する事ができます。

VIDEOボタンからはビデオパネルを表示する事ができます。　基本的にはプロパティのオプション＞ビデオの操作と同じですが、ビデオソースの選択オプションも搭載しています。　ビデオソースの利用は現在のところSVI-328MkI使用時に限定されています。　（40-コラムTMS9929Aビデオチップと80-コラムCTRC6845ビデオチップとの切り替え） MSXでは将来的にV9938/58ビデオチップやV9990(GFX9000)ビデオチップの切り替えの際に使用される予定です。　”OUTPUT CONNECTOR"と書かれた文字の横にあるボタンを押す事で、ビデオ端子を挿したり、抜いたりした状況も再現されます。（砂嵐がTVに表示される時の現象ですね。）

プロパティーウィンドウとは違い、画像を確認しながらリアルタイムに変更できるのが特徴です。

CONTROLボタンからはバーチャルキーボードへアクセス出来るようになります。　このパネルには他にコントロール類の選択も兼ねており、ジョイスティックポート１と２の選択や連射機能の調節が行えます。　バーチャルキーボードはテーマのみ使用時拡張機能になります。　配列はターボRが基盤です。

■ DIGIblue 2.0 ステータスバー詳細

テーマに以前同封されていた、DIGIblue 2.0を使用した場合はステータスバーは下のパネルが画像で表示されます。

DIGIblue 2.0のステータスバーは基本的にはDIGIblue SUITE-XのBASEパネルとMIXERパネル部分を統合した形の物です。 こちらにはLED3種（ダイヤル上部）が追加されており、左からP-S（ポーズスイッチ）、A-S（パナソニックMSX-AUDIOスイッチ）、F-S（パナソニック前面スイッチ）に配列されており、有効時には点灯します。

■ (旧式）DIGIblue ステータスバー詳細

上部の細長い窓枠には動作中ソフトの詳細（名前 / メーカー / 販売年などなど）を表示できる情報欄が用意されています。　外部のデータベースと連携しているので、ロムカートリッジ、ディスクイメージやテープイメージなどの情報を表示させる事ができます。

左の小さな窓には下記の情報が表示されています。

machine configurations
FPS | - 描画書き換えの数値を表示しています。
CPU | - CPUの使用割合をパーセンテージで表示します。
MHz | - エミュレーターが動作している周波数を表します。
MAIN | - 動作中のMSX機種が搭載しているメインメモリーを表示されます。
VIDEO | - 動作中のMSX機種が搭載しているVRAMメモリーを表示されます。
SCREEN | - 動作中のMSXが使用しているスクリーンモードを表示します。
MEGARAM | - MEGARAMが使用されている場合に点灯します。
AS | - オーディオスイッチ略で、パナソニックのFS-CA1(MSX-AUDIO)搭載の内蔵ソフトを利用している場合に点灯します。
FS | - フロントスイッチの略で、MSX2+系の内蔵ソフトを使用したさいに点灯します。
REC | - 録音中に点灯します。
F-RI | - ディスクドライブの”挿入/取り出し後リセット”オプションが選択されている場合に点灯します。
R-RI | - ROMスロット1&2のいずれかの”挿入/取り出し後リセット”オプションが選択されている場合に点灯します。
C-RO | - カセットテープの”テープ読み込み専用にする"オプションが選択されている場合に点灯します。

中央の窓は主に音関係や入力関連の情報を表示しています。　ミキサー部分はPSG, SCC, MSX-Music , MSX-AUDIO, MoonSound, キーボード音と全体を現したマスター音量が用意されています。

- 挿入されているロムカートリッジの種類によって、それに属するカートリッジタイプが点灯します。　（通常ロム、メガロム）
- FM-PACを使用している場合や機種に搭載されている時などには、FM-PACが点灯します。
-使われている音源種類によって、各種アイコンが点灯します。　(MSX-Music, SCC, MoonsoundやMSX-AUDIO)

入力関連の表記説明になります。

machine configurations
P1 | - MSXのポート1に割り当てられているデバイスをあらわします。 * M = マウス使用時に点灯 * N = テンキー使用時に点灯 * K = キーセット使用時に点灯 * DX = DirectX対応デバイス使用時に点灯
P2 | - MSXのポート2に割り当てられているデバイスをあらわします。 * M = マウス使用時に点灯 * N = テンキー使用時に点灯 * K = キーセット使用時に点灯 * DX = DirectX対応デバイス使用時に点灯
HS | - Horizontal Stretchの略で水平ストレッチが選択されている場合に点灯します。
VS | - Vertical Stretchの略で垂直ストレッチが選択されている場合に点灯します。
SL | - 使用中のスキャンラインのパーセンテージを表示します。
MACHINE TYPE | - MSX機種の種類を表示します。
MAPPER TYPE | - 挿入されているカートリッジのマッパー種類を表示します。

右側に配置された５つのLEDに見立てたインジケーターはそれぞれ左から右へ順番に：
- ディスクドライブAのアクセス時に点灯するLED
- ディスクドライブBのアクセス時に点灯するLED
- カセットテープへのアクセス時に点灯するLED
- KANAキーが押されている状態に点灯するLED
- CAPSキーが押されている状態に点灯するLED


blueMSX エミュレーション設定

■ エミュレーション設定

このパネルはエミュレーションの核となる設定が行えます。　もっとも頻繁に利用するのがMSXの機種選択ではないでしょうか？

machine configurations
MSXの種類 | - お使いになるMSXの機種選択ができます。 - ドロップダウンメニューからはシステムロムが用意、認識されている機種しか選択できません。 - blueMSXのフルバージョンをお使いの場合は汎用機種、C-BIOS機種とMSX以外の機種がご利用いただけます。 - ターボRをご利用になられる場合は、なるべく早いCPUを搭載した機種が必要になります。 - ご利用のマシンのカスタマイズにはマシン構成編集機能をご利用ください。
スピード | - エミュレーションの速度の変更可能になります。 標準周波数は3.579Mhzになります。
ビデオ周波数 | - ビデオ周波数の変更ができます。 デフォルトでは自動的に使用したいMSX機種応じた周波数を選択します。基本的には日本/韓国/ブラジルの機種の場合は60Hz(NTSC)が主流でヨーロッパの機種では50Hz(PAL)となっております。 - 非ヨーロッパ機種で50Hzにした場合には、ソフトは若干遅く動作します。 - ヨーロッパ規格のマシンで60Hzにした場合は、ソフトは若干早く動作します。 - このオプションの変更は場合によってはソフトの正しい動作の妨げになる場合があります。
FDDドライブの タイミングを無効化 | - FDDの再現する為のウェイト処理を省略し読み込みを高速化するオプションです。 ただし、タイミングを無視する為、一部で不都合の出るソフトもあり、使用には注意が必要になります。
パナソニックスイッチ | - 2つの項目が用意されています。 - パナソニック前面スイッチ。 内蔵ソフトの起動の有無の設定に利用します。(内蔵ソフトがある機種にもに対応しています。） - ポーズスイッチ。 パナソニックやソニーの機種などで見かけるPAUSEキーの役割をはたします。（エミュレーターのポーズは違います。） - パナソニックMSX-AUDIOカートリッジスイッチ。


Emulation 汎用マシン

■ 汎用マシン

blueMSXのフルバージョンには標準で１８種類の汎用マシン構成がお使いいただけます。

■ MSX1汎用マシン構成

machine configurations
MSX1汎用マシン構成
共通仕様詳細 | - 汎用マシンの中に含まれる6機種はMSX1の地域別の機種に属す物です。 - 4つの非拡張型スロット - 2カートリッジスロット - カセット端子 - 64Kb RAM - 16Kb VRAM - 通常は2ドライブ搭載 (ブラジル製マシンには1ドライブ）
MSX （ヨーロッパ仕様） | - キー配列は QWERTY - キャラクターは アクセント符号 - FDCに Philips-Sony製ドライブ - ビデオ周波数は 50Hz
ブラジル仕様 | - キー配列は QWERTY - キャラクターは アクセント符号 - FDCに Microsol製ドライブ - ビデオ周波数は 60Hz
ドイツ仕様 | - キー配列は QWERTY - キャラクターは アクセント符号 - FDCに Philips-Sony製ドライブ - ビデオ周波数は 50Hz
日本仕様 | - キー配列は QWERTY - キャラクターは カナ - FDCに パナソニック製ドライブ - ビデオ周波数は 60Hz
韓国仕様 | - キー配列は QWERTY - キャラクターは ハングル - FDCに National-Daewoo製ドライブ - ビデオ周波数は 60Hz
スウェーデン仕様 | - キー配列は QWERTY - キャラクターは アクセント符号 - FDCに Philips-Sony製ドライブ - ビデオ周波数は 50Hz
- これらの機種でMSX-MUSICをご利用になりたい場合はFM-PACをスロット1または2のいずれかに挿入してください。 - MSX-AUDIOを利用になる場合はマシン構成編集からお使いの構成にMSX-AUDIOチップを追加してください。 - 別途MSX-AUDIOカートリッジロムを必要とするのはMSX-AUDIO BASICを利用しているソフトのみになります。

■ MSX2汎用マシン構成

machine configurations
MSX1汎用マシン構成
共通仕様詳細 | - 汎用マシンの中に含まれる10機種中8機種はMSX2の地域別の機種に属す物です。 - 2つの非拡張型スロット - 2つの拡張スロット - 2カートリッジスロット - カセット端子 - 通常は2ドライブ搭載 (ブラジル製マシンには1ドライブ） 以下拡張済み（特別仕様になっています ）： - 512Kb Mapped RAM - 128Kb VRAM - MSX-MUSIC - MSX-AUDIO - MoonSound - Turbo-Basic - PAC カートリッジ 特別例 - MSX2 アラビア仕様、MSX2+とターボR機種： - 1つの非拡張型スロット - 3つの拡張スロット - アラビア仕様は特殊なBIOSを使用 - ターボRはカセット端子を非搭載
ヨーロッパ仕様 | - キー配列は QWERTY - キャラクターは アクセント符号 - FDCに Philips-Sony製ドライブ - ビデオ周波数は 50Hz
アラビア仕様 | - キー配列は QWERTY - キャラクターは アラビア式 - FDCに パナソニック製ドライブ - ビデオ周波数は 50Hz
ブラジル仕様 | - キー配列は QWERTY - キャラクターは アクセント符号 - FDCに Microsol製ドライブ - ビデオ周波数は 60Hz
フランス仕様 | - キー配列は AZERTY - キャラクターは アクセント符号 - FDCに Philips-Sony製ドライブ - ビデオ周波数は 50Hz
ドイツ仕様 | - キー配列は QWERTY - キャラクターは アクセント符号 - FDCに Philips-Sony製ドライブ - ビデオ周波数は 50Hz
日本仕様 | - キー配列は QWERTY - キャラクターは カナ + 漢字 - FDCに パナソニック製ドライブ - ビデオ周波数は 60Hz
韓国仕様 | - キー配列は QWERTY - キャラクターは ハングル + Screen 9 - FDCに National-Daewoo製ドライブ - ビデオ周波数は 60Hz
PSG音源のみ | - キー配列は QWERTY - キャラクターは アクセント符号 - FDCに Philips-Sony製ドライブ - ビデオ周波数は 50Hz
ロシア仕様 | - キー配列は JCUKEN - キャラクターは キリル - FDCに National-Daewoo製ドライブ - ビデオ周波数は 60Hz
スペイン仕様 | - キー配列は QWERTY - キャラクターは アクセント符号 - FDCに Philips-Sony製ドライブ - ビデオ周波数は 50Hz
MSX2+仕様 | - キー配列は QWERTY - キャラクターは カナ + 漢字 - FDCに パナソニック製ドライブ - ビデオ周波数は 60Hz
MSX2+仕様 | - キー配列は QWERTY - キャラクターは カナ + 漢字 - FDCに パナソニック製ドライブ - ビデオ周波数は 60Hz
- 別途MSX-AUDIOカートリッジロムを必要とするのはMSX-AUDIO BASICを利用しているソフト、もしくはコンパイルなどのMSX-MUSICも同時にサポートしているソフトの場合です。 - 上記のケースのような場合は”PSG音源のみ”の機種を基準に、マシン構成編集からお使いの構成にMSX-AUDIOチップを追加してください。 - PSG音源のみの機種は（強制的にMSX-MUSICを認識してしまうソフトで）FM音源を聴きたくない場合に使ってください。


blueMSX C-BIOS

■ C-BIOS

現在blueMSXはC-BIOSと一緒に配布されています。　C-BIOSはMSX互換のフリーウェアBIOSで現在3機種をサポートしています。
C-BIOSをお使いいただくには必要なシステムロムがそれぞれのディレクトリに収納されている必要があります。（標準では再設定する必要はありません。）

machine configurations
この場をお借りして、C-BIOSというオープスソースのプレジェクトへ感謝を述べさせていただきたいと思います。
Albert Beevendorp | 開発者
Manuel Bilderbeek | サポートマネージャー
Eric Boon | 開発者
BouKiChi | 開発者
Herman Oudejans | テスター
Jussi Pitkanen | プログラマー
Reikan | 元C-BIOSの開発者
Maarten ter Huurne | 開発者
Patrick van Arkel | テスター
Joost Yervante Damad | パッケージング

C-BIOSは現在でも開発が進められているプロジェクトで、まだディスクやテープ、ベーシックなどには未対応です。　しかし、頻繁に開発がすすめれているので、ヴァージョンアップの度に互換性が向上されています。　C-BIOSについてもっと詳しくお知りになりたい場合は、プロジェクトのホームページを参照ください。

C-BIOSマシンをカートリッジを挿さずに起動させると以下の画面が表示されます。

machine configurations
C-BIOS 起動画面 | スロットにカートリッジが未挿入の場合。。。

machine configurations
MSX1 / C-BIOSマシン構成
基本仕様詳細

- 4つの非拡張型スロット
- 64Kb RAM
- 16Kb VRAM

MSX2 と MSX2+ / C-BIOSマシン構成
基本仕様詳細

- 3つの非拡張型スロット
- 1つの拡張スロット
- 512Kb Mapped RAM
- 128Kb VRAM

- MSX2+ にはMSX-MUSICが搭載されています。
その他

- C-BIOSはまだ発展途上のため、多くのソフトで不都合が出る可能性があります。　こういった場合にエミュレータのバグと勘違いされるケースもありますので、かならず動作確認の際はC-BIOS以外の機種での検証を行った後にバグ報告をお願いいたします。
- MSX-AUDIOはまでC-BIOS上では未対応です。

MSX-MUSIC / MSX-AUDIOの追加方法

(*)現時点ではMSX-AUDIOはC-BIOSで未対応ですが、将来的なサポートの為に方法を記して置きます。

MSX1 C-BIOSの場合：
- blueMSXのディレクリ内のMachinesフォルダを開きます
- MSX C-BIOSディレクトリのコピーを作成します。　（名前は MSX C-BIOS 2 など）
- MSX2+ C-BIOS ディレクトリへ移動します。
- 中に保存されている cbios_music.rom というファイルを先ほどコピー作成したディレクトリにコピーします。
- エミュレーターを起動して、マシン構成編集を開き先ほど作成したMSX C-BIOS 2の構成を編集します。
- メモリタブから追加でタイプに MSX Audio chip を選択します。
- 次にスロット2 にcbios_music.romを追加し、タイプには必ず MSX Music を選択してくだいさい。　アドレスには 4000-7FFF を指定します。
- 編集したマシンをセーブして、MSX-MUSIC対応のゲームでFM音源で再生されれば成功です。

MSX2 C-BIOSの場合：
- blueMSXのディレクリ内のMachinesフォルダを開きます
- MSX2 C-BIOSディレクトリのコピーを作成します。　（名前は MSX2 C-BIOS 2 など）
- MSX2+ C-BIOS ディレクトリへ移動します。
- 中に保存されている cbios_music.rom というファイルを先ほどコピー作成したディレクトリにコピーします。
- エミュレーターを起動して、マシン構成編集を開き先ほど作成したMSX2 C-BIOS 2の構成を編集します。
- メモリタブから追加でタイプに MSX Audio chip を選択します。
- 次にスロット3-1 にcbios_music.romを追加し、タイプには必ず MSX Music を選択してくだいさい。　アドレスには 4000-7FFF を指定します。
- 編集したマシンをセーブして、MSX-MUSIC対応のゲームでFM音源で再生されれば成功です。

MSX2+ C-BIOSの場合 (MSX-AUDIOを追加すると仮定して）：
- エミュレーターを起動して、マシン構成編集を開き MSX2+ C-BIOS の構成を編集します。
- メモリタブから追加でタイプに MSX Audio chip を選択します。
- 新しい構成として保存します。 （名前は MSX2+ C-BIOS 2 など）


Emulation MSX以外のマシン

■ MSX以外のマシン

blueMSXのフルバージョンには4つのMSX以外のマシン構成が含まれています。
お使いいただくには必要なシステムロムがそれぞれのディレクトリに収納されている必要があります。

■ ColecoVision

machine configurations
Coleco機種構成
仕様詳細 | - 現在はColecoVisionのみをサポートしています。 - 4つの非拡張型スロット - 1カートリッジスロット - 16Kb RAM - 16Kb VRAM - 標準のビデオ周波数は60Hzですが、オプション＞エミュレーションから50Hzに切り替え可能 - 現在ColecoAdamのサポートも検討中

■ SVIマシン構成

machine configurations
MKII
SVI機種構成
共通仕様詳細 | - 現在 SVI系は3機種サポートされています。 - 4つの非拡張型スロット - 1カートリッジスロット - カセット端子 - 16Kb VRAM - キー配列に QWERTY を採用 - 標準のビデオ周波数は60Hzですが、オプション＞エミュレーションから50Hzに切り替え可能 多機種との違いは基本的にはRAMの要領とドライブ数と2枚目に追加可能なビデオカードです。
SVI-318 | - 16Kb RAM - ドライブ無し - 2機目のグラフィックカード 無し
SVI-328 | - 64Kb RAM - ドライブ有り - 2機目のグラフィックカード 無し
SVI-328 MK2 | - 160Kb RAM - ドライブ有り - 2機目のグラフィックカード 有り （80列 表示）


blueMSX ビデオ設定

■ エミュレーション設定

このパネルはビデオ関連全般の細かな指定が行えます。　画像のカラー補正や比率の変更などをサポートし、実際のTV出力に近づける事が可能になります。

machine configurations
モニター種類 | - 出力をカラー/モノクロ/グリーンモニターとアンバーの４種類から選択できます。
モニターエミュレーション | - 出力に対してTV出力のようなエフェクトを追加します。 * なし = 出力に何も適応されません、ピクセルは1x1の比率で表示されます。 * Monitor = 精度の高いS-VIDEO出力を再現。 (ST&GTのS端子を想定しています。） * Y/Cケーブル (鮮明) = S-VIDEO相当に等しいエミュレーションをします。 * Y/Cケーブル＋ノイズ (鮮明) = S-VIDEO相当にぶれなどを追加し、エミュレーションを再現します。 * コンポジット (不鮮明) = コンポジット相当にに等しいエミュレーションをします。 * コンポジット＋ノイズ (不鮮明) = コンポジット相当にぶれなどを追加し、エミュレーションを再現します。 * Scale 2x = ピクセル間を擬似的に埋める、エミュレーターならではの再現方法です。 * Hq2x = ピクセル間を擬似的に埋め、よりスムーズに表示するモードです。 またフル画面モード時の解像度に1024x768以上に設定する事で、Hq2xがHq3xモードに自動的に切り替わります。
ガンマ 明るさ コントラスト 彩度 | - 出力に好みのカラー補正を適応する事を可能します。
水平 ストレッチ | - 実際MSXをTVで見た物に近い比率（4:3）で再現します。 モニターエミュレーションとの併用が可能。
デインターレース | - 実際のインターレースを再現し、オプションが有効な場合はv1.6.1以前のモードと同じ仕様になります。 (標準は有効) インターレスモードは常に全てフレームが描画される必要があるので、早いマシンでの利用が推奨されます。 モニターエミュレーションとの併用が可能。
垂直 ストレッチ | - 画面の余った部分を埋めるために垂直に伸ばします。 モニターエミュレーションとの併用が可能。
スキャンライン | - TV出力などで見られる隙間を再現するオプション、スライダーで隙間の大きさを調節する事できます。 モニターエミュレーションとの併用が可能。
RFモジュレータ | - TV出力などで見られる色ムラやにじみを再現するモードです。 網状のドット配列などで見られる虹色現象などいままで再現しずらかったエフェクトが体感できます。 * それらしい効果を得るにはモニターエミュレーションの "コンポジット＋ノイズ (不鮮明)" と "スキャンライン" の両方を有効にして、調節するのを推奨します。


blueMSX サウンド設定

■ サウンド設定

このパネルはサウンド関連全般の細かな指定が行えます。

machine configurations
サウンドのエミュレーション - 音源チップセット単位で使用の有無が選択できます。
- blueMSXに標準で搭載されているマシン構成（MSX2、MSX2+とターボR）上は最初からMSX-MUSIC / MSX-AUDIO / MOONSOUNDを装備した特別な仕様にセットアップされています。
- お使いのマシンのスペックに合わせて、常時使うサウンドチップを限定する事をお勧めいたします。　Moonsoundは他と比べてCPUをより多く消費するので、1.2ghz以下のマシンでは使うとき以外は無効するなどの方法があります。
オーバーサンプリング - MSX-AUDIO, MSX-MUSICとMoonsoundチップにおいてより質の高い音を得る場合に設定できるオプションです。　このオプションはCPUのリソースを多少消費するので、早い機種での利用が推奨されます。　標準ではx1に設定されていますが、ご使用の環境とお好みに合わせて変更してみてください。　こちらのテスト環境では以下の設定で好ましい音質が得られました。（ただしお使いの環境に大きく左右される機能なので必ずしも期待通りの音が得られるわけではありません。）

MSX-MUSIC | - | 4x | - | 8x
MSX-AUDIO | - | 2x | - | 4x
Moonsound | - | 1x | - | 2x
ミキサー - ミキサーを使用して、ボリューム、パンやミュート設定などを音源単位で可能です。　ステレオからモノラルへの切り替えとマスターボリュームによる総合音量調整ができます。

- 拡張テーマ"DIGIblue"を利用すると、ミキサーの設定をリアルタイムに監視する事ができます。

- 複数の音源チップをサポートするソフトの場合はその中からひとつの音源を優先し、メインの再生チップとして出力する場合があります。　たとえばコンパイルのアレステなどはPSGとMSX-MUSIC（FM音源）の両方をサポートしていますが、MSX2+など最初からMSX-MUSICを搭載している機種ではPSG音源より先にMSX-MUSICが優先され、PSG音源を聞く事はできません。　その場合ミキサーでいくらMSX-MUSICをミュートまたは無効化してもPSG音源だけを聞く事はできません。　こういった場合の策としてはMSX-MUSICチップを非搭載のマシン構成を使用するほか方法はなく、つまりハード的に無効化する必要があると言う事です。
- そのような場合に備えてblueMSXではPSG音源のみを搭載したMSX2マシンの構成やC-BIOS機種が搭載されています。
ミキサー種類

- PSG はPSG音源
- SCC はSCCまたはSCC+音源
- MSX-M　はMSX-MUSIC (FM音源）
- MSX-A　はMSX-AUDIO
- MOON はMoonSound
- PCM　はターボRのPCM、もしくはMSX-AUDIOのPCM
- KBD はキーボードのクリック音や一部のソフト上では音源としても使われています。
- I/O はFDC(フロッピードライブ音）


サウンド設定 PSG

■ PSG音源

PSG音源は (Programmable Sound Generator)の略で、全MSX機種（とその系統の）に搭載されているサウンドチップの一つです。

- MSXとSVIにはGeneral Instruments AY-3-8910のチップが使用しています。
- ColecoVisionではTexas Intrument SN76489のチップを使用しています。

PSG音源の特徴としては矩形波3音とノイズ(white noise generator)が出力されている所です。
MSX-BASICにはPSG音源を鳴らす為の命令分が搭載されています。

■ PSG音源 利用時のTIPS

machine configurations
ステレオ | - ごく稀にSCC音源とPSG音源を同時に使ったデモやゲーム（コナミ系）が存在します。 これはオプションのサウンドメニューからミキサーを調節してステレオにし、出力を左右に分けて聴く事で互いの特徴部分をより一層味わい深い物になります。 お好みに合わせて左右に振り分けるパンの度合いを調整してみて下さい。
PSG音源のみ | - PSG音源だけを聞きたい場合はミキサー部分から他のサウンドチップを無効にする事で可能になります。 - もし何も出力されない場合は下記の方法を参照してください。
PSG音源に限定したい | - MSX-MUSICエミュレーションやMSX-AUDIOエミュレーションをオプションのサウンドメニューから無効化する。 - PSG音源のみを搭載したMSX2機種を利用する。 コンパイル製のソフトなどでFM音源ではなくPSG音源で楽しみたい場合にはこうしてください。


サウンド設定 SCC

■ SCC

SCC (Sound Custom Chip または　Sound Creative Chip)とはサウンドチップの名称で、コナミとヤマハによって開発されK051649というチップとしても知られています。
8オクターブ5重和音で、波形を自由に作成できるのが特徴です。多少矩形波に見られる、段階を踏んだような波形で出力されるため、実に独特で音色を楽しむ事ができます。
独自にメモリマッパを搭載しています。　on/offビット,音量、波数と32バイトウェーブファームがチャンネル毎に制御できます。

SCC+とはSDスナッチャーやスナッチャーなどに（カートリッジ形式で）同封されていた、改良版に当たる物です。
SCCとSCC+の違いは独立した5っ目のチャンネルと64Kbの要領のRAMを搭載しているところです。（RAMの要領は128Kbまで増設可能）

SCCまたはSCC+の音源を試聴するにはスロットにSCCのチップがささっている必要があります。（カートリッジとして）

コナミのソフトで最初からSCCを搭載しているゲームはそのカートリッジを使用する事により自動的にSCCを楽しむ事ができますが、ディスクなどの対応ソフトの場合は後からSCCまたはSCC+のカートリッジをスロットに挿す必要があります。

基本的にSCC音源を制御するBASIC命令は存在しません。

■ SCC音源 利用時のTIPS

machine configurations
ステレオ | - ごく稀にSCC音源とPSG音源を同時に使ったデモやゲーム（コナミ系）が存在します。 これはオプションのサウンドメニューからミキサーを調節してステレオにし、出力を左右に分けて聴く事で互いの特徴部分をより一層味わい深い物になります。 お好みに合わせて左右に振り分けるパンの度合いを調整してみて下さい。
SCC音源のみ | - SCC音源だけを聞きたい場合はミキサー部分から他のサウンドチップを無効にする事で可能になります。

■ SCC搭載ソフト

下記のソフトの通常版は全てSCCチップを最初から搭載しており、マッパー種類にKonami5を使用しています。
もし下のソフトでマッパーの種類がASCII8の場合は、空きスロットにSCCカートリッジを別途挿しておく必要があります。

MSX1対応ソフト
Ｆ１スピリット / A1 Spirit
グラディウス 2 / Nemesis 2
ゴーファーの野望ＥＰＩＳＯＤＥII / Nemesis 3
エルギーザの封印　（MSX1版）
パロディウス
沙羅曼蛇

MSX2対応ソフト
魂斗羅 / Gryzor
激突ペナントレース
激突ペナントレース２
エルギーザの封印　（MSX2版）
メタルギア２　ソリッドスネーク
クウォース
スペースマンボウ

■ SCCまたはSCC＋に対応したdskソフト

下記のソフトでSCC音源を楽しみたい場合は、SCCまたはSCC+のカートリッジをスロットに挿しいる必要があります。

MSX1対応ソフト
コナミゲームコレクションＶｏｌ．１
コナミゲームコレクションＶｏｌ．２
コナミゲームコレクションＶｏｌ．３
コナミゲームコレクションＶｏｌ．４

MSX2対応ソフト
コナミゲームコレクション番外編
ＳＤスナッチャー
スナッチャー

■ SCCまたはSCC＋に対応した改造ロムゲーム

下記のゲームは元々コナミゲームコレクションシリーズに収録されていた物をロムに変換した改造版(Hack)にあたる物です。

MSX1対応ソフト
けっきょく南極大冒険
グラディウス 1 / Nemesis 1
ハイパーラリー
ハイパースポーツ２
魔城伝説
コナミのボクシング
ピポルズ
ロードファイター
スカイジャガー
スーパーコブラ
ツインビー
ビデオハスラー
イーアルカンフー
イーガー皇帝の逆襲

MSX2対応ソフト
Go Othello
Rice
Rice 2
Title Memory


サウンド設定 MSX-MUSIC

■ MSX-MUSIC

MSX-MUSICはMSX-AUDIOからサンプリング機能を排除の省略版という位置づけといえる規格です。ヤマハYM-2413 OPLL FM音源シンセサイザーを搭載し、（リズム音を除く）FM9声または FM6音+リズム5音中3音という構成になります。

エミュレーター上でMSX-MUSICを試聴するにはMSX-MUSICチップを搭載した機種を使用します。　基本的に(blueMSXで)はMSX2、MSX2+とターボRにてMSX-MUSICは使用可能になっています。（例外としてPSGのみのMSX2マシン構成も存在します。）

 MSX-MUSIC（カートリッジまたは対応機種）を利用する事により、FM-BASICが拡張され、BASICからMSX-MUSICの制御や命令文が使用可能になります。

■ MSX-MUSIC 利用時のTIPS

機種としてMSX1またはC-BIOS搭載MSX1/MSX2を利用している場合はMSX-MUSICを（カートリッジまたはチップとして）追加しなくてはなりません。
簡単な方法としてはFM-PACなどをスロットに挿してご利用いただく方法と、マシン構成編集を利用してチップとしてマシンの基本構成に追加する形があります。
C-BIOS搭載機種の場合はMSX2+用のC-BIOSに含まれる、cbios_music.romというファイルを利用する事が推奨されています。

machine configurations
ステレオ | - 海外のデモなどではよくMSX-MUSICとMSX-AUDIOを同時に使用物が存在し、ステレオを通して聞く事でよりMSXサウンドの魅力を引き出す事ができます。 オプションのサウンドメニューからミキサーを調節して自分にあったお好みのステレオサウンドを見つけてみましょう。
MSX-MUSICのみ | - MSX-MUSICだけを聞きたい場合はミキサー部分から他のサウンドチップを無効にする事で可能になります。 - もし何も出力されない場合は下記の方法を参照してください。
MSX-MUSICに限定したい | - MSX-AUDIOエミュレーションやMOONSOUNDエミュレーションをオプションのサウンドメニューから無効化する。

■ MSX-MUSIC に存在するカートリッジの種類

machine configurations
パナソニック FM-PAC | - 日本で普及した、MSX-MUSICカートリッジでゲームデータなどのセーブに利用できるS-RAMを搭載していました。 - MSX-BASICからCALL FMPACで内臓のソフトにアクセスできます。
CHECKMARK FM-PAK | - オランダで利用されていたMSX-MUSICカートリッジ。（S-RAM非搭載） - MSX-BASICからCALL FMPAKで内臓のソフトにアクセスできます。
ZENIMA MUSICBOX | - 韓国で使われていたMSX-MUSICカートリッジでS-RAMと内臓ソフトは非搭載。
ACVS FM-AVCS | - ブラジルで使われていたMSX-MUSICカートリッジでS-RAMと内臓ソフトは非搭載。


サウンド設定 MSX-AUDIO

■ MSX-AUDIO

MSX-AUDIOは音源規格の一種で特徴的な二つの要素で構成されています：
- 音源チップとしてヤマハYM-8950を搭載していました。（FM9音またはFM6音+リズム5音）
- 8ビットADPCM(Advanced Differential Pulse Code Modulation) 1音で、最高16KHzのサンプリングレートが可能で、32kbのサンプルデータ保存RAMを搭載。（最高256kbまで増設可能）

エミュレーター上でMSX-AUDIOを試聴するにはMSX-AUDIOチップを搭載した機種を使用します。　基本的に(blueMSXで)はMSX2、MSX2+とターボRにてMSX-AUDIOは使用可能になっています。（例外としてPSGのみのMSX2マシン構成も存在します。）

また事前に搭載RAMも基本的に(blueMSXで)256kbまで拡張した状態で最初から構成されています。

 MSX-AUDIO（カートリッジまたは対応機種）を利用する事により、MSX-AUDIO BASICが拡張され、BASICからMSX-AUDIOの制御や命令文が使用可能になります。

■ MSX-AUDIO 利用時のTIPS

機種としてC-BIOS搭載MSX1を利用している場合はMSX-AUDIOチップをマシン構成編集を利用してチップとしてマシンの基本構成に追加する必要があります。
MSX-AUDIO BASICを利用したい場合は別途パナソニックMSX-AUDIOカートリッジをスロットに追加する必要があります。

machine configurations
ステレオ | - 海外ではよくMSX-AUDIOとMSX-MUSICを同時に使用するデモなどが存在し、ステレオを通して聴く事でよりMSXサウンドの魅力を引き出す事ができます。 オプションのサウンドメニューからミキサーを調節して自分にあったお好みのステレオサウンドを見つけてみましょう。 ターボR用のデモではMSX-AUDIOとPCM機能を同時に鳴らす物も存在し、同じステレオ調整が可能です。
MSX-AUDIOのみ | - MSX-AUDIOだけを聞きたい場合はミキサー部分から他のサウンドチップを無効にする事で可能になります。 - もし何も出力されない場合は下記の方法を参照してください。
MSX-AUDIOに限定したい | - MSX-MUSICエミュレーションやMOONSOUNDエミュレーションをオプションのサウンドメニューから無効化する。 - PSG音源のみを搭載したMSX2マシンを利用し、マシン構成編集からMSX-AUDIOチップを追加します。 - MSX-AUDIOに対応したソフト（コンパイルの物）やMSX-AUDIO BASICを利用したい場合はパナソニックMSX-AUDIOカートリッジをスロットに追加する

■ MSX-AUDIO に存在するカートリッジの種類

machine configurations
パナソニック FS-CA1 | - 日本で発売されたカートリッジで、非常に大きなカートリッジをしておりモノラルにもかかわらず、端子はなぜかステレオのピンが出ていた。 - 実物には内臓ソフトの起動を制御するON/OFFスイッチが付いており、blueMSXでもスイッチの部分はオプションのエミュレーションメニューから切り替え可能です。 - スイッチは東芝のカートリッジにも搭載されており、エミュレーター上でもスイッチは共通です。 - スイッチが無効になっている場合は、内臓ソフトは起動しない代わりにMSX-AUDIO BASICが利用可能になります。 拡張BASICを呼び出すにCALL AUDIO命令文を利用します。 拡張BASICにはADPCMの制御や増設用キーボードの制御も可能になります。（エミュレーター上では一部未対応） - 内臓ソフトを呼び出すにはCALL SYNTHE文を利用します。（ただしCALL AUDIO後は不可） - 特殊なPOKE文を使わずにコンパイルのソフトでMSX-AUDIOを聴くには別途パナソニックMSX-AUDIOカートリッジが必要になります。 - MSX-AUDIO対応のROMを利用する場合はスロット1にパナソニックMSX-AUDIOカートリッジを挿し、スロット2に対応カートリッジを挿す事が推奨されます。（MSX-AUDIOを正しく認識させる為に）
PHILIPS NMS-1205 | - オランダで使われていたMSX-AUDIO互換カートリッジ - 標準で内蔵ソフトが立ち上がる仕組みになっていますが、立ち上げの際にESCキーを押すことで起動解除できます。 - BASICからCALL MUSICBOXで内臓ソフトの立ち上げが可能です。 - MSX-AUDIO対応のソフトを利用したい場合には以下の方法でPSGまたはFM音源の認識を阻止する必要があります。（コンパイルのソフトやディスクステーションなど） - MSX-AUDIOのカートリッジを差し、ESCを押しながらMSXを立ち上げます。 - コンパイル製ソフトのディスクをドライブにセットします。 - MSX-BASICから、 POKE -54,35:POKE&HF346,1:_SYSTEM と入力します。
東芝 HX-MU900 | - 日本で使われていたMSX-AUDIO互換カートリッジ - 標準で内蔵ソフトが立ち上がる仕組みになっていますが、立ち上げの際にESCキーを押すことで起動解除できます。 - BASICからCALL SYNで内臓ソフトの立ち上げが可能です。 - MSX-AUDIO対応のソフトを利用したい場合には以下の方法でPSGまたはFM音源の認識を阻止する必要があります。（コンパイルのソフトやディスクステーションなど） - MSX-AUDIOのカートリッジを差し、ESCを押しながらMSXを立ち上げます。 - コンパイル製ソフトのディスクをドライブにセットします。 - MSX-BASICから、 POKE -54,35:POKE&HF346,1:_SYSTEM と入力します。


サウンド設定 MoonSound

■ Moonsound

Moonsoundは海外のアマチュアシーンから誕生した音源規格の一種で特徴的な二つの要素で構成されています：
- 音源チップとしてヤマハYMF-262 OPL3 FM音源シンセサイザーを搭載していました。（2オペFM18音 / 2オペFM15音+リズム5音 / 4オペFM6音+2オペFM6音 / 4オペFM6音+2オペFM3音+リズム5音）
- 8ビットADPCM(Advanced Differential Pulse Code Modulation) 1音で、最高16KHzのサンプリングレートが可能で、32kbのサンプルデータ保存RAMを搭載。（最高256kbまで増設可能）

- ヤマハYMF-278B-F OPL4 PCMシンセサイザー（PC業界ではウェーブテーブルシンセサイザーとして馴染みがあるかもしれません。)　こちらはOPL3互換FM音源16ビットウェーブテーブルシンセ24音 （ステレオで各チャンネル１６段階で調節可能。　8/12/16ビットウェーブデータと44.1KHzまでのサンプリング波数をサポート）

- サウンドチップとしてはMSX-AUDIO互換（ADPCM部分を除く）で128kbのサンプル用RAMを搭載し、2MBまで増設可能。
- Moonsoundには300個以上のサンプルデータを搭載します。

 エミュレーター上でMoonsoundを試聴するにはMoonsoundチップを搭載した機種を使用します。　基本的に(blueMSXで)はMSX2、MSX2+とターボRにてMoonsoundは使用可能になっています。（例外としてPSGのみのMSX2マシン構成も存在します。）

また事前に搭載RAMも基本的に(blueMSXで)640kbまで拡張した状態で最初から構成されています。

Moonsoundには特別な拡張ベーシックの類は搭載していません。

■ Moonsound 利用時のTIPS

machine configurations
ステレオ | - MoonsoundはMSX音源チップとしては唯一ステレオを標準でサポートするカートリッジです。 - オプションのサウンドメニューからミキサーを調節して自分にあったお好みのステレオサウンドをお楽しみください。


サウンド設定 PCM

■ PCM

PCM (Pulse Code Modulation) はMSXではターボRにしか搭載されていない規格です。　性能としては8ビットサンプリングユニットと最高16KHzのサンプリング周波数をサポートします。　またMSX-AUDIOとは違いアナログ>デジタル変換機能は搭載していません。

 エミュレーター上でMoonsoundを試聴するにはMoonsoundチップを搭載した機種を使用します。　基本的に(blueMSXで)はMSX2、MSX2+とターボRにてMoonsoundは使用可能になっています。（例外としてPSGのみのMSX2マシン構成も存在します。）

PCM音源を聴くにはターボR機種とTurbo-R PCMチップを搭載している必要があります。

ターボR機種のMSX-BASIC上ではPCMを制御する命令文が含まれています。

■ PCM 利用時のTIPS

machine configurations
ステレオ | - ごく稀にPCM音源とMSX-AUDIOを同時に発音させステレオ効果を演出するターボR用のデモが存在します。お好みに合わせて左右に振り分けるパンの度合いを調整してみて下さい。
PCM音源のみ | - PCM音源だけを聞きたい場合はミキサー部分から他のサウンドチップを無効にする事で可能になります。


blueMSX コントロール設定

■ コントロール設定

このパネルはエミュレーション中に利用可能な入力装置の細かな設定が行えます。

MSXには２つの入力ポートがあり、それぞれジョイスティックポート１＆２と呼ばれています。

blueMSXは自動的にDirectXに対応した、PC用(USBなどの）の入力装置を認識しエミュエーターで利用できるようにドロップダウンメニューに割り当てます。　使われていないボタンにはショートカットエディターから任意のキーを割り当てられます。

machine configurations
コントロール | - 最初のドロップダウンメニューからはマウスやジョイスティックなどの使用を切り替えて使用します。 * マウス = エミュレーター上でマウスが利用できるように設定します。 * テンキー = キーボードの数字キーの8/6/4/2/0をジョイスティックとして利用可能にします。 * キーセット = MSX専用のジョイパッド配列に好みのキーを割り当てる事ができます。 * テトリス2ドングル = テトリス２特別版を起動させたい場合のオプションでプロクテト正常に認識いたします。 * DirectX = このオプションはDirectXに対応した入力デバイスをジョイスティックとして利用可能にします。 お使いのPCに対応デバイスが接続されている場合にのみ表示されるオプションで、デバイス表記はお使いの装置によって異なります。
連射 | - 連射機能は３段階のスピード設定をサポートします。
ボタン A | - MSX互換のジョイスティックボタンAにPC用の入力デバイスのボタンを任意に割り当てます。 DirectX対応デバイスを利用時にのみ設定可能なります。
ボタン B | - MSX互換のジョイスティックボタンBにPC用の入力デバイスのボタンを任意に割り当てます。 DirectX対応デバイスを利用時にのみ設定可能なります。
コンフィグ キーセット | - コントロール設定で”キーセット”を選択した際に変更可能になる設定です。 選択した際は下のウィンドウが呼び出されます。 - 設定方法は、ジョイスティックとして割り当てたい項目の空欄にマウスでクリックします、その後に任意キーを押します。 ６っこ分のキーアサインが終了したら、OKを押して選択を確定します。

- マウスをジョイスティック代わりに使用したい場合は、実際のMSXで行う方法と同様の形で立ち上げ時に約５秒間ほど左マウスボタンを押し続けます。


blueMSX キーボードの仕様

■ キーボードの仕様

MSXのキーボードは比較的PC用のキーボードの配列と近く、アルファベットの配列や数字キーなどはほぼ同じです。　違いと言えば、ファンクションキーがMSXでは5つしかなく、シフトキーと併用する事によりF1からF5をF6からF10として利用するところでしょう。　当エミュレーターもファンクションキーの扱いはMSXと同じ仕様になります。

標準のキー配列はエミュレートされているMSXのBIOSを基準とした設定になっています。

PC用のキーボードには存在しないいくつかのMSX独自のキーが存在します。　それらはPCのキーボードにしかないキーに割り当てる形で再現されています。 下がキー割り当てのテーブルになります、左側の太文字がMSXのキーで右が割り当てられているPCキーになります。

machine configurations
SELECT | - End
STOP | - Page Up
Ctr Home | - Home
Graph | - 左Alt
Code / かな / ハングル | - 右Alt
数字キーのコンマ | - Page Down
アクセント / アンダースコア | - 右Ctrl

パナソニック系のMSX2+には別途２つの専用キーが用意されており、それらもPC用のキーボードに割り当てられています。

machine configurations
実行 | - 左ウィンドウキー 又は Back (Explorer)
取り消し | - 右ウィンドウキー 又は Forward (Explorer)

*お使いのMSXが海外仕様(BIOS)の場合はその国のキー配列がそのまま適応されますので、英語圏のMSXの場合はキー配列も英語キーになります。
*一般的なPC用のキーボードは複数のキーへの同時押しを、組み合わせによってはサポートしない物があり、blueMSXのバグではありません。

キーボード構成編集またはバーチャルキーボード（ DIGIblue SUITE-X 2.2テーマのみ）を利用する事で、より詳しくキー配列の把握が可能になります。　またキーボード構成編集からユーザーの希望するキー配列を構築していただく事が可能です。


blueMSX ジョイスティックとマウスの仕様

■ ジョイスティックとマウスの仕様

MSX用のジョイスティックは８方向と２ボタンという仕様が一般的です。　blueMSXではそれらを実際のPC用のジョイパッド/ジョイスティックやキーボードによって代用する事ができます。
エミュレーターのコントロールプロパティから設定を行ってください。　またDIGIblue SUITE-X 2.2 テーマからも設定が可能です。

マウスの使用も当然サポートしており、この場合はPC用のマウスがそのままご利用できます。　マウスの利用はエミュレーターのコントロールプロパティから行ってください、またDIGIblue SUITE-X 2.2 テーマからも設定が可能です。
マウスをジョイティックの代わりに代用する事も出来、その場合はMSXを立ち上げる際にマウスの左ボタンを５秒以上押し続けください。

* マウスをサポートしているソフトでも、利用するに当たって特殊な方法を要いている物が存在します。　（例:ソフトが立ち上がってからSELECTキーで切り替えるなど。）


blueMSX ショートカット構成編集 詳細

■ ショートカット構成編集 詳細

こちらがblueMSXの標準ショートカットの一覧になります。　割り当てはショートカット構成編集から自由に行う事ができます。

machine configurations
F7 | - クイックロード CPUステート簡易保存を復帰します。
F8 | - クイックセーブ CPUステートを簡易保存します。
F9 | - エミュレーターの実行とポーズ
F10 | - MSXのエミュレーションを停止します。
F12 | - ハードリセットをかけ、MSXを再起動します。
Pause | - ポーズスイッチの実行と解除。 （エミュレーター側のポーズではない。）
PrtScrn | - スクリーンショットを実行します。 （画像モードが通常の場合は320 x 240ピクセルで出力され、２倍モードとフルスクリーンでは640 x 680ピクセルになります。）
Scroll Lock | - パナソニック系のMSX2+の前面スイッチのオン/オフ切り替え。 （内蔵ソフトの入り/切にあたります。）
LAlt+Enter | - フルスクリーンに切り替え
LAlt+Scrl Lock | - パナソニックMSX-AUDIOの内蔵ソフトのオン/オフ切り替え
LAlt+F7 | - CPUステート保存されたファイルのロード。
LAlt+F8 | - CPUステートをファイルに保存します。
LAlt+F9 | - v-DRIVE / 連番ディスクの切り替えを行います。
LAlt+F10 | - 画面を通常モードへ切り替えます。 （320ｘ240）
LAlt+F11 | - 画面を２倍モードへ切り替えます。 (640x480)
LAlt+F12 | - フルスクリーンに切り替えます。
LShift+F6 | - テーマの切り替え
LShift+F7 | - 録音の実行と停止
LShift+F8 | - マウスのキャプチャーのオン/オフ
LShift+F9 | - 押されている間はMSXの動作を高速化します。
LShift+F10 | - 標準クロックの3.579Mhzに戻します。
LShift+F11 | - エミュレーションのクロックを5%減速させます。
LShift+F12 | - エミュレーションのクロックを5%加速させます。
LCtrl+F6 | - ヘルプダイアログを表示します。
LCtrl+F7 | - ROMスロット1挿入ダイアログを呼び出します。
LCtrl+F8 | - ROMスロット2挿入ダイアログを呼び出します。
LCtrl+F9 | - ディスクドライブA挿入ダイアログを呼び出します。
LCtrl+F10 | - ディスクドライブB挿入ダイアログを呼び出します。
LCtrl+F11 | - カセットテープ挿入ダイアログを呼び出します。
LCtrl+F12 | - ソフトリセットを掛け、MSXを再起動します。（ラムの内容は初期化されません）
LCtrl+Pause | - blueMSXを終了します。
LCtrl+LAlt+F7 | - ROMスロット1の"その他"メニューを呼び出します。
LCtrl+LAlt+F8 | - ROMスロット2の"その他"メニューを呼び出します。
LCtrl+LAlt+F9 | - ディスクドライブAの”挿入/取り出し後にリセット”オプションの有無を切り替えます。
LCtrl+LAlt+F10 | - カセットテープの”挿入後巻き戻す”オプションの有無を切り替えます。
LCtrl+LAlt+F11 | - カセットテープの”テープ位置セット”ウィンドウを表示します。
LCtrl+LAlt+F12 | - ロム、ディスク、テープイメージを全て、取り出した上体でリセットを掛け、MSXを再起動させます。
LCtrl+LSft+F8 | - ROMスロット1と2の”挿入/取り出し後にリセット”オプションの有無を切り替えます。
LCtrl+LSft+F10 | - カセットテープの”テープを読み込み専用にする”オプションの有無を切り替えます。
LCtrl+LSft+F11 | - テープイメージを巻き戻します。
LCtrl+LSft+F | - FDDドライブのタイミングの 無効化オプションの切り替えます。
LCtrl+LSft+M | - エミュレーションの最速化を有効にします。
LCtrl+LSft+P | - プリンターを次のページのトップまでフォームフィードします。
LCtrl+LSft+S | - スプライトの表示 / 無表示を切り替えます。
LCtrl+LSft+W | - エミュレーターウィンドウを最小化します。
RAlt+F6 | - モノラル / ステレオの切り替えを行います。
RAlt+F7 | - ボリュームを下げます。
RAlt+F8 | - ボリュームを上げます。
RAlt+F9 | - ディレクトリをディスクドライブAとして挿入のメニューを表示します。
RAlt+F10 | - ディレクトリをディスクドライブBとして挿入のメニューを表示します。
RAlt+F11 | - 縮小画質でスクリーンショットを実行します。（272 x 240ピクセル）
RAlt+F12 | - 大きい画質でスクリーンショットを実行します。(544 x 480ピクセル）
RAlt+Scrl Lck | - ボリュームをミュートさせます。
RShift+F6 | - エミュレーション設定ウィンドウを開きます。
RShift+F7 | - ビデオ設定ウィンドウを開きます。
RShift+F8 | - オーディオ設定ウィンドウを開きます。
RShift+F9 | - コントロール設定ウィンドウを開きます。
RShift+F10 | - パフォーマンス設定ウィンドウを開きます。
RShift+F11 | - ファイル設定ウィンドウを開きます。
RShift+F12 | - その他の設定ウィンドウを開きます。
RCtrl+F6 | - ”blueMSXについて” のダイアログを開きます。
RCtrl+F7 | - ROMスロット1からカートリッジを取り出します。
RCtrl+F8 | - ROMスロット2からカートリッジを取り出します。
RCtrl+F9 | - ディスクドライブAからカートリッジを取り出します。
RCtrl+F10 | - ディスクドライブBからカートリッジを取り出します。
RCtrl+F11 | - テープイメージを取り出します。
RCtrl+RShft+D | - デバッガウィンドウを開きます。
RCtrl+RShft+K | - キーボード構成編集を表示します。
RCtrl+RShft+L | - 言語選択画面を開きます。
RCtrl+RShft+M | - マシン構成編集ウィンドウを開きます。
RCtrl+RShft+P | - ポートのプロパティを開きます。
RCtrl+RShft+S | - ショートカット構成編集ウィンドウを開きます。
RCtrl+RShft+T | - トレイナーウィンドウを開きます。


blueMSX パフォーマンス設定

■ パフォーマンス設定

このパネルはエミュレーション中のパフォーマンス関連の設定が可能です、マシンスペックにあった設定を見つけて最適化を行う事ができます。
ご使用の環境で互換性問題などが生じたさいにも、こちらの設定を変更する事で改善される場合があります。

machine configurations
ディスプレイドライバ | - 描画エンジンにDirectDrawかGDIを利用するか選択するオプションです。 お使いのスペックやドライバーにもよりますが、通常はDirectDrawを利用した方がパフォーマンスを得る事ができます。HW accl (ハードウェアアクセラレーション）はビデオメモリとシステムメモリの両方を利用して描画を円滑に行う仕様で、条件を満たしていれば非常に高いパフォーマンスが期待できます。
フレームスキップ | - 描画の書き換え時に処理が追いつかない場合に、描画を飛ばしてCPUの負担を減らす事ができます。 通常の”なし”を利用した場合でも書き換えが間に合わない場合は自動的にフレームスキップされる設計になっています。
フルスクリーン解像度 | - フル画面での解像度を指定する事ができます。 - 解像度に1024x768以上に設定する事で、Hq2xがHq3xモードに自動的に切り替わります。
サウンドドライバ | - 音源出力にDirectXかWMMを使うかを設定します。 一般的にはDirectXの方がパフォーマンスを得られます。
サウンドバッファ | - 内蔵のサウンドバッファの容量を指定します。 低い値ほど、高速かつ正確な反応をしますが、逆に出力が乱れたりする事があります。 お使いのサウンドカードによって、設定が大きく異なるので音の乱れが無くなる設定値を見つけてください。
SYNCモード | - MSXのクロックとPCのクロックとの同期方法を選択するオプションです。 * 自動 （推奨） = エミュレーターに同期を自動制御するためのオプションで、旧スペックのPCをお使いの場合はこちらの利用をおすすめします。 * 1ms = 同期をなるべく実際のMSXと同じになるように制御します。 描画の書き換えなど極めて正確に処理を行うため、高速なスペックがないと恩恵を受ける事は出来ない場合があります。 （P4 1.4Ghz 以上推奨）


blueMSX ファイル設定

■ ファイル設定

このパネルではイメージをどう取り扱うかなどの細かな設定ができます。

machine configurations
ファイルヒストリ | - 過去に利用したファイルの履歴数を変更したり、消去したりする事が可能です。 設定できる数値は0から30個となっています、デフォルトは10個になります。
ドラッグ＆ドロップ | - ロムやディスクイメージをドラッグ＆ドロップして起動した場合に、どちらのスロット/ドライブに挿入されるかを設定する項目です。
ロムダイアログを開く | - 外部ロムデータベースに登録されてないロムを使用した際に、どのマッパーで読み込むかを設定する事ができます。 * ロム種類を推測 = エミュレーターがロムを解析して、適したマッパーを選択します。 （必ず成功するとは限りません。）


blueMSX ポート設定

■ ポート設定

このパネルはパラレルポート（プリンター）やシリアルポート（モデムなど）全般の細かな指定が行えます。
なおblueMSXは自動的にDirectXに対応したポートとデバイスを認識します。

■ パラレルポート設定

machine configurations
ポート | - お使いのパソコンにプリンターが接続されている場合には自動的に認識しLPTポートに表示されます。 - SiMPL / Covox DAC デバイスを接続して、一部のアプリケーションから利用できるように設定します。 - プリントした内容をファイルとして保存します。
ファイル名 | - プリント機能を利用した際に、使用されるファイル名とセーブ箇所を指定します。 - 標準ではprinter.datというファイル名でblueMSXと同じフォルダーに保存されます。
エミュレーション | - 使用するプリンタエミュレーションにFX-80もしくはMSXプリンターを選択できます。

■ シリアルポート設定

machine configurations
ポート | - モデムが接続されている場合は自動的に認識しCOMポートに表示されます。 - コミュニケーションの内容をファイルとして保存します。
ファイル名 | - シリアルポートに接続したデバイスを利用した際に、使用されるファイル名とセーブ箇所を指定します。 - 標準ではuart.datというファイル名でblueMSXと同じフォルダーに保存されます。


blueMSX その他設定

■ その他設定

このパネルではblueMSXをアプリケーションとしてどう利用するか設定ができます。

machine configurations
テーマ | - blueMSXの外観や追加情報を得られるテーマの選択を行います。 - ｖ1.7.0からはテーマその物をユーザーが自由に作成カスタマイズする事ができるようになりました。 テーマの作成方法などは専用ページを参照してください。
ウィンドウズ環境 | - エミュレーターが起動中に動作を妨げる仕様の無効化や、ファイルの関連付けを設定するオプションです。 動作中にスクリーンセイバーを無効化したり、Windowsキーを押してもスタートウィンドウを強制的に開かなくする事ができます。 - また、*.rom、*.dsk、*.cas、*.staファイルをクリックした際に自動的にblueMSXが立ち上がるように関連付けも行えます。 (ただしレジストリに変更がなされます。） - blueMSXのプライオリティーのブーストは通常より優先的に、エミュレーションに処理を割り当てます。


blueMSX 言語選択

■ 言語設定

このパネルではblueMSXの使用される表示言語を設定ができます。

machine configurations
言語 | - 12種類の言語から選択できます：オランダ語、英語（標準）、フィンランド語、フランス語、ドイツ語、イタリア語、日本語、韓国語、ポーランド語、ポルトガル語、スペイン語、スウェーデン語 一部で完全に翻訳しきれていない部分やミスがあるかもしれません、その際はどうぞ開発チームにお知らせください。


blueMSX マシン構成編集 詳細

■ マシン構成編集 詳細

blueMSXは強力なマシン構成編集機能を提供し、自由にメモリレイアウトからI/Oの仕様の制御を使い安いインターフェースを介して行えます。
- なお初心者の方のために、マシン構成を自ら行う必要が無い様に標準で設定された汎用マシン構成が付属しています。（なお汎用マシン構成は独自の形でMSX規格を再現した特別仕様なので、必ずしもベストな構成ではありませんし、ソフトによっては不都合が出る可能性もあります。　なるべく自分の所有する機種を再現する方法をお勧めいたします。）
- メーカー機種(パナソニック、ソニー、サンヨーなど）を再現するための設定も幾つか標準で搭載しています。
- Machinesフォルダーには、現在blueMSXで再現できる機種の仮設定フォルダーを参照していただけます。（一部の機種で動作がしますが、一部の機能が不完全な物もあります）

マシン構成編集を使って、既存のMSXのカスタマイズや仕様変更が可能になります。

マシン構成編集は大きく分けて３つのセクションに分かれており、上位のドロップダウンメニューから現在登録されているMSX機種の一覧と切り替えが行えます。　マシンの構成情報は設定ファイルとして、"Machines"のサブディレクトリーに任意のマシン名のついたフォルダー内に設定ファイルとして保存されます。

中央の部分が核となるエミュレーターのハードウェア構成を決めるウィンドウで、4つのタブに分かれています。　タブごとの解説は専用のセクションで説明をしていますので、下記のリンクを参照してください。

- スロット構成
- メモリ
- チップ
- エキストラ

一番下の分部のボタン説明：

machine configurations
保存 | - 現在のマシン構成を設定を保存します。
別名保存 | - 現在のマシン構成を別名で保存します。 ボタンを押すと別ウィンドウが開くので、任意のファイル名を入力してください。
起動 | - 選択されているマシン構成でMSXを起動します 変更内容が保存されていない場合は警告が表示されます。
閉じる | - マシン構成編集を閉じます。 変更内容が保存されていない場合は警告が表示されます。


blueMSX スロット構成編集 詳細

■ スロット構成編集 詳細

こちらのメニューではスロットの基本構成を編集する事できます。　スロットのレイアウトはロムのイメージをメモリにどのようにマッピングされるか左右します。

machine configurations
基盤 | - 基盤タイプではエミュレートしたい機種のコアの設定を行います。 - MSX規格、SVI規格とColecoVision規格のいずれかを選ぶ事ができます。 - SVIはMSXと非常に似たハードウェア構成をしており、機種としてはSpectravideoのSVI-318/SVI-328の2機種が存在します。 - ColecoVisionはMSX1のハードウェアに非常に近い構成を持ったコンソール機です。
スロット構成 | - 4つのスロットの内で、基本として設定するか、拡張スロットして選択します。
拡張スロット | - カートリッジの用のスロットを外部スロットかサブスロットとして使うか選択できます、サブスロットとして仕様する場合はメモリ設定などを指定する必要があります。 外部スロットは通常ゲームカートリッジなどに使用されます。


blueMSX メモリ構成編集 詳細

■ メモリ構成編集 詳細

こちらのメニューではメモリの基本構成の編集や、ロムイメージを任意のスロットやアドレスにアサインする事ができます。

中央のウィンドウには現在使用されている機種のメモリ構成が表示され、一行ごとにロム/ラムやIOマッパーの設定が表示されます。

machine configurations
警告欄 | - 同じスロットで競合を起こした場合に警告アイコンが表示されます。
スロットアドレス | - ロムなどがマッピングされるスロットの指定します。 何も設定しない場合は空欄になります。
アドレス | - ロム / ラムをマッピングするアドレスを指定します。 何も設定しない場合は空欄になります。
タイプ | - マッピングしたい、メモリタイプを指定をします。
ロム | - ロムマッパーの場合はマッパーの種類をしています。

一番したのボタンの説明です。

machine configurations
追加 | - メモリ構成に新しく設定を追加します。
編集 | - 選択されている構成の編集を行います。
消去 | - 選択されている構成の消去を行います。

追加または編集を行った場合はマッパー設定ウィンドウが表示されます。

マッパー編集のオプションの説明になります。

machine configurations
ファイル | - こちらの欄にはマッパーに割り当てるロムファイルを指定します。 ファイルダイアログが表示されるので、任意のイメージを選択してください。 イメージの設定が必要ないマッパーの場合は空欄にあります。
タイプ | - マッパータイプのドロップダウンメニューになります。
スロット | - 割り当てるスロットの指定をしますが、種類がIOマッパーの場合は空欄になります。
アドレス | - 割り当てるアドレスの指定をしますが、種類がIOマッパーの場合は空欄になります。
サイズ | - 指定のマッパーがロムの場合は、メモリサイズ設定が表示されます。 ラムマッパーの場合はドロップダウンメニューが有効になり、ラムの容量が指定可能にあります。


blueMSX チップ設定 詳細

■ チップ設定 詳細

こちらのメニューではエミュレーションに使われる映像とサウンドチップセットやCMOSの設定が可能です。

上位のドロップダウンメニューはMSXで使われる、ビデオチップの種類とそのラムの容量をを選択します。

machine configurations
TMS9929A | - PAL仕様の50ｈｚのMSX1やSVI-318 / SVI-328で使用されるチップセットです。
TMS99x8A | - NTSC仕様の60ｈｚのMSX1やColecoVisionに使用されるチップセットです。
V9938 | - MSX2に使われたPALとNTSCの両方をサポートしたチップセットです。 利用されているBIOSから信号の規格を判断し出力します。日本仕様のMSXはNTSCを利用するBIOSを搭載し、ヨーロッパ仕様はPALになります。
V9958 | - MSX2+に使われたPALとNTSCの両方をサポートしたチップセットです。 PAL/NTSC信号の識別V9938と同じ方法です。


blueMSX エキストラ設定 詳細

■ エキストラ設定 詳細

こちらのメニューではCPUの周波数、搭載ドライブ数とCMOS関連の設定が行えます。

上位のドロップダウンメニューはCPUが動作する周波数を設定を行います。　下は搭載ドライブ数を設定します。

machine configurations
CPU周波数 | - Z80とR800が動作する周波数の設定ができます。 オーバークロックもできますが、アンダークロックも可能です。 - オーバークロックし場合は相応のCPUリソースを消費します。
フロッピーディスクコントローラー | - フロッピードライブを搭載したマシンのドライブ数を決定します。 - 汎用機種には標準として2ドライブの構成に設定されています。 - ブラジルのMSX1とMSX2には標準で1ドライブしか搭載していません。 これは起動時にCTRLキーの働きを正常に保つための規格です。 - ドライブを一基しか搭載していなくても、MSXのシステムはロジカルドライブとして2ドライブ分使用できます。（フロッピードライブのコピー時の切り替え要求時など）

machine configurations
CMOSを有効 | - MSX2/MSX2+/ターボRで使用される規格で、MSX1では無効になります。
内蔵バッテリーを有効化 | - CMOSの内容を保つためのバッテリーの使用を選択します。


blueMSX ショートカット構成編集 詳細

■ ショートカット構成編集 詳細

blueMSXの新しい機能として、ショートカットエディダーが搭載されました。　この機能はユーザー自身がエミュレーターのあやゆる操作を好みのキーや複数のキーへの割り当てを援助したします。　中でもインターフェースには存在しない”隠れ”機能などがあり、それらはショートカットからでないと利用する事ができません。

PC用のジョイパッド/ジョイスティックなどで、複数のエミュレーション中に使われないボタンがあります。　ショートカットエディターは余ったボタンをショートカットとしてアサインする事がます。

標準では3つのショートカット集が用意されており、１つはblueMSXの基本ショートカット設定で、残りの二つはNLMSXとparaMSXのショートカット設定（一部）をblueMSXにアレンジした物です。　他のエミュレーターから、乗り換えた場合などに便利かと思います。

エディターからは既存のショートカットファイルの変更又は新しくユーザー専用のショートカット設定を作成する事ができます。

ショートカットエディターは大きく分けて３つのセクションに分かれており、上位のドロップダウンメニューが現在登録されているショートカット週の一覧と切り替えが行えます。　ショートカット集はすべて、"Shortcut Profiles"のサブディレクトリーに*..shortcutsという専用ファイルに保存されます。

中央の部分が核となるエミュレーターの命令文とそれを実行に移すショートカットの全一覧です。　基本はショートカットはすべてキーボードに割り当てられていますが、ジョイパッドのボタンなどにもアサインするが可能です。

ショートカットを変更するにはまず、中央の一覧から変更したい項目をマウスで選びます。　次に、”ショートカットキー入力欄”横のフォームに割り当たいキー又は複数のキーを（同時）に入力します。　入力し終えたら、”割り当て”ボタンを押して設定を確定してください。

一番下の分部のボタン説明：

machine configurations
保存 | - 現在のショートカット設定を保存します。
別名保存 | - 現在のショートカット設定を別名で保存します。 ボタンを押すと別ウィンドウが開くので、任意のファイル名を入力してください。
OK | - ショートカット構成編集を閉じます。 保存されていない場合は警告が表示されます。


blueMSX テーマの基礎

■ テーマの基礎

blueMSXでは標準に"classic"タイプと、拡張テーマとして"DIGIblue SUITE-X"が付属します。（DIGIblue SUITE-Xは２倍画面モードのみでサポート）
DIGIblueはテーマ機能のポテンシャルを最大限に活かした物で、同じような物をユーザーからも手軽に作成する事ができます。　実際のテーマに使われている素材は"Themes"のディレクトリーに保存されているので、参照にしてみてください。

テーマは４つの要素から成り立っており、まずgraphics(画像）、controls(制御）、triggers（トリガー）、とactions(アクション）があります。

テーマ作成の第一歩として、エミュレーターで必要な要素をまとめ、画像を作成する事から始まります。　具体的にはエミュレーション中のポーズや停止用のボタンなどが必要とされます。　DIGIblueでは”Main-Off-State.bmp ”画像ファイルが参考になると思います。　じっくり研究してみてください。

中央部分はMSXの動作中画面が割り当てられる空間になり、この画面を囲むような配置でテーマを設計するのが妥当かと思います。

大まかにテーマで使用される画像の種類としては、テキスト用のフォント、アイコン類、LED類、ボタン類などがあります。

作成した画像の配置や動作を定義するには、theme.XMLと呼ばれるテーマ定義ファイルを利用します。　テキストエディターなどで編集が行え、一見複雑に見えますが構成はいたってシンプルなので、少し勉強すればすぐに設定できるようになります。

テーマ定義ファイルは”bluemsxtheme"というブロックで構成されています。　このブロックには"name"という属性があり、テーマ名を設定するために用意されています。
”bluemsxtheme"には別に１～４つのサブブロックが用意されています。　　必ずテーマの頭で定義する必要があります。

- テーマモードはテーマが使用される画面モードと実際のサイズを定義します。
例：　<theme mode="normal" width="680" height="652">　もしくは　<theme mode="fullscreen">

- エミュレーターのウィンドウの位置をx/y座標で指定します。
例：
emuwindow x="10" y="65"/>　もしくは　<emuwindow x="0" y="0"/>

- エミュレーターのテキストメニューの位置と背景色の設定。
例：　<menu x="20" y="3" bgcolor="bdbdbd" focuscolor="6995ba"/>

- テーマが表示されるクリップリージョンの指定も可能です。　クリップリージョンとはメディアプレイヤーなどで使用されているスキンだけを表示する機能で、マウスカーソルが乗っている間だけウィンドウの枠を表示し、そうでない時は隠れるといった働きをします。　クリップリージョンはいくつでも指定可能で、x,y座標で指定したい角を定義しなくてはなりません。
例：　<clipregion>
<point x="17" y="27"/>
<point x="786" y="27"/>
<point x="786" y="655"/>
<point x="799" y="655"/>
<point x="799" y="725"/>
<point x="0" y="725"/>
<point x="0" y="655"/>
<point x="17" y="655"/>
</clipregion>

- ウィンドウズのネイティブフォントもご利用いただく事ができます。
- ただし、フォントが表示される部分には必ず背景用のビットマップが必要になり、src文で指定します。 このビットマップのサイズはフォント表示部分の範囲の設定と同時にフォントの書き換えの目的にも使用されます。（フォントは透明色を利用し、背景の書き換えを行わずにフォントを表示すると、前に表示された部分が残像として残ってしまいます。）

- type に "native”を指定する事でシステムフォントが指定されます。
- fgcolorの指定でテキストの色が設定されます。
- widthの値はネイティブフォント使用時には無視されます。
例：　<text x="118" y="533" src="ICONS/ROMNAMEBG.bmp" type="native" fgcolor="99bb99" trigger="text-runningname"/>

これらの定義し終えたら、メインとなるボタンやLED類などの画像の定義が続き、controls(制御）文を利用して構成していきます。　triggers（トリガー）、とactions(アクション）はcontrols(制御）命令内で使われる属性種類にあたります。


blueMSX controls(制御）

■ controls(制御）

テーマには制御するための命令文がいくつか存在します。　命令文は共通して必ず：
- x座標とy座標を指定
- src属性に*.bmp画像ファイルの名前と場所の指定
その他の属性は任意指定の要素になります。　例：テキストディールドの幅と位置設定、アクション、ボタン用のトリガーなど。

machine configurations button 文
命令説明 | - ボタンを制御すための命令文
src | - srcに指定する画像としては３つの状況を想定します：　ノーマル / ホバー / 押されている
action | - action属性にはボタンの押された時の動作を指定します。
visible - ボタンのアクションの状況に応じて画像を切り替え時などの条件付けにtriggerの代わりに利用します。　ボタンを隠し、その際はマウスでの制御は無効になります。　トリガーがオンの場合はコントロールが可能になり、それにあったアクションが実行され、オフの場合はコントロールが隠れ、アクションは実行不可になります。
- visible="enable-master"
- visible="not enable-master"
- オン例：<button x="770" y="496" src="MUTE.bmp" action="audio-togglemute" visible="enable-master"/>
- オフ例：<button x="770" y="496" src="MUTE2.bmp" action="audio-togglemute" visible="not enable-master"/>
画像サンプル
定義例 | <button x="156" y="37" src="buttons/STOP-BUTTON.bmp" action="emu-stop" visible="not emu-stopped"/>

machine configurations dualbutton 文
命令説明 | - メインとサブが存在するボタンを制御すための命令文
src | - srcに指定する画像としては４つの状況を想定します： ノーマル / ホバー / メインが押されている / サブが押されている
direction | - direction属性にはメインとサブボタンの並び順を水平か垂直かを指定します。 標準はボタンが水平に並んだ状態になります。 - vertical - horizontal - 例： direction="vertical"
action | - action属性にはボタンの押された時の動作を指定します。 - action1にはメインボタンの動作 - action2にはサブボタンの動作
arg1x/arg1y | - arg1x/y属性にはactionで定義されたボタンに割り振られるメニューの表示座標を指定します。
arg2x/arg2y | - arg2x/y属性にはactionで定義されたボタンに割り振られるメニューの表示座標を指定します。
画像サンプル |
定義例 | <dualbutton x="49" y="32" src="buttons/RESET-BUTTON.bmp" action1="emu-resethard" action2="menu-reset" arg2x="80" arg2y="50"/>

machine configurations keycode 文
命令説明 | - ヴァーチャルキーボード用のテーマ作成時に MSXキーボード用のキーコードを定義します。
key code | - MSXい置けるキーコードを指定します。
使用可能なコード | f1 - f2 - f3 - f4 - f5 - stop -cls - select - ins - del - esc 1 - 2 - 3 - 4 - 5 - 6 - 7 - 8 - 9 - 0 - neg - circomflex - backslash - backspace - tab q - w - e - r - t - y - u - i - o - p - at - leftbracket - return - ctrl a - s - d - f - g - h - j - k - l - semicolon - colon - rightbracket - leftshift z - x - c - v - b - n - m - comma - period - div - underscore - rightshift caps - graph - torikeshi - space - jikkou - code - pause left - up - down - right num7 - num8 - num9 - numdiv num4 - num5 - num6 - nummul num1 - num2 - num3 - numsub num0 - numperiod - numcomma - numadd print
定義例 | <key code="underscore" x="228" y="84" width="17" height="17"/>

machine configurations image 文
命令説明 | - 一枚絵や無ステートの画像を配置
src | - srcにはファイル名を指定します。
画像サンプル |
定義例 | <image x="30" y="20" src="bitmap.bmp"/>

machine configurations led 文
命令説明 | - 点滅するLEDやオン/オフの要素を含む物に使われます。
src | - srcには無効の状態と有効の状態の２種類で構成します。
trigger | - trigger属性にはオン/オフの切り替えを発生させる要素の指定をします。
画像サンプル |
定義例 | <led x="30" y="552" src="DIGIBLUE.bmp" trigger="not emu-stopped"/>

machine configurations meter 文
命令説明 | - ミキサーなどのボリュームメーターの表現に使用します。
src | - srcにはメーターの音量の段階をグラフ形式で０から最大９９まで指定できます。
max | - メーターを何段階にするかをしていします。 srcで指定した画像の段階と同じでなければ、画像がずれて表示されます。
trigger | - trigger属性にはどのメーターに使われるかを指定します。
画像サンプル |
定義例 | <meter x="454" y="617" max="13" src="MIXER/METER-L.bmp" trigger="volume-master-left"/>

machine configurations slider 文
命令説明 | - マウスで操作可能な可変スライダーを定義します。
src | - srcにはスライダーで可変可能な位置や段階をグラフ形式で０から最大９９まで指定できます。
max | - スライダーを何段階にするかをしていします。　srcで指定した画像の段階と同じでなければ、画像がずれて表示されます。
trigger | - trigger属性にはどのスライダーに使われるかを指定します。
direction

- direction属性はスライダーがどの方向に可動するかを指定します。
sensitivity | - sensitivity属性はスライダーの可変度合いの調整するための数値を指定します。
画像サンプル
定義例 <slider x="71" y="58" src="SWITCHES/SLIDER-RENSHA.bmp" max="11" srcColumns="1" trigger="slider-rensha" action="slider-rensha"
direction="horizontal" sensitivity="3"/>

machine configurations text 文
命令説明 - 文字を表示したい部分にしようします。
src

- フォントに使われる画像はasciiの256からなるcharsetに準じています。　フォントの作成時に文字配置がずれると表示が乱れるので必ず、256個の文字で構成してください。
type

- ビットマップではなくシステムフォントを使う際に指定する要素で、type="native"でシステムのフォントを使用します。
- 事前にsrc文で文字表示範囲をビットマップで確保してなくてはなりません。　画面書き換えの際に正しくリフレッシュさせる為です。
width

- 一行にに表示する文字数を指定します。
align

- テキストの揃え方を指定します。 標準は左揃えになります。
- right
- left
- 例： align="right"

visible

- エミュの動作中と停止中で表示するテキストを振り分ける事ができます。
- visible="emu-stopped"
- visible="not emu-stopped"
- 例：visible="emu-stopped"
trigger

- テキストで表示したい要素を指定します。　textトリガーしか指定できません。
画像サンプル
定義例

<text x="67" y="7" width="6" align="right" visible="emu-stopped" src="ICONS/FONT-SMALL.bmp" trigger="text-cpuusage"/>
<text x="67" y="7" width="6" align="right" visible="not emu-stopped" src="ICONS/FONT-SMALL.bmp" trigger="text-vramsize"/>

ネイティブフォント使用時：
<text x="118" y="553" src="ICONS/ROMNAMEBG.bmp" type="native" fgcolor="99bb99" trigger="text-runningname"/>


blueMSX triggers （トリガー）

■ triggers （トリガー）

- トリガーはLEDや、有無ボタンやテキストフィールドい文字を表示するときに使用します

machine configurations
cpu-trace | - CPUトレース機能が有効時にトリガーされます
emu-paused | - エミュレーションがポーズにトリガーされます
emu-running | - エミュレーションの実行時にトリガーされます
emu-stopped | - エミュレーションの停止時にトリガーされます
enable-keyboard | - キーボード音が有効時にトリガーされます
enable-master | - マスター音が有効時にトリガーされます
enable-moonsound | - Moonsoundが有効時にトリガーされます
enable-msxaudio | - MSX-AUDIOが有効時にトリガーされます
enable-msxmusic | - MSX-MUSICが有効時にトリガーされます
enable-pcm | - PCM音が有効時にトリガーされます
enable-psg | - PSG音が有効時にトリガーされます
enable-scc | - SCCが有効時にトリガーされます
led-audioswitch | - オーディオスイッチの有効時にトリガーされます
led-caps | - CAPSのLEDが有効時にトリガーされます
led-cassette | - カセッテのLEDが有効時にトリガーされます
led-diska | - ディスクドライブAのLEDが有効時にトリガーされます
led-diskb | - ディスクドライブBのLEDが有効時にトリガーされます
led-frontswitch | - パナソニック系の前面スイッチが有効時にトリガーされます
led-kana | - カナキーのLEDが有効時にトリガーされます
led-pause | - ポーズのLEDが有効時にトリガーされます
led-pauseswitch | - ポーズキーのLEDが有効時にトリガーされます
led-rensha | - 連射ターボのLEDが有効時にトリガーされます
led-turbor | - Turbo-RのLEDが有効時にトリガーされます
level-keyboard | - キーボード音の値をスライダーへトリガーします
level-master | - マスター音の値をスライダーへトリガーします
level-moonsound | - Moonsound音の値をスライダーへトリガーします
level-msxaudio | - MSX-AUDIO音の値をスライダーへトリガーします
level-msxmusic | - MSX-MUSIC音の値をスライダーへトリガーします
level-pcm | - PCM音の値をスライダーへトリガーします
level-psg | - PSG音の値をスライダーへトリガーします
level-scc | - SCC音の値をスライダーへトリガーします
pan-keyboard | - キーボード音のパンの値をスライダーへトリガーします
pan-moonsound | - Moonsound音のパンの値をスライダーへトリガーします
pan-msxaudio | - MSX-AUDIO音のパンの値をスライダーへトリガーします
pan-msxmusic | - MSX-MUSIC音のパンの値をスライダーへトリガーします
pan-pcm | - PCM音のパンの値をスライダーへトリガーします
pan-psg | - PSG音のパンの値をスライダーへトリガーします
pan-scc | - SCC音のパンの値をスライダーへトリガーします
port1-enable | - ジョスティックポート1が有効時にトリガーされます
port1-joystick | - ジョスティックポート1にジョイスティックが選択されている場合にトリガーされます
port1-keyboard | - ジョスティックポート1がキーボードとして設定されている場合にトリガーされます
port1-mouse | - ジョスティックポート1にマウスが選択されている場合にトリガーされます
port1-none | - ジョスティックポート1に何も選択されている場合にトリガーされます
port1-numpad | - ジョスティックポート1が数字キーとして設定されている場合にトリガーされます
port2-enable | - ジョスティックポート2が有効時にトリガーされます
port2-joystick | - ジョスティックポート2にジョイスティックが選択されている場合にトリガーされます
port2-keyboard | - ジョスティックポート2がキーボードとして設定されている場合にトリガーされます
port2-mouse | - ジョスティックポート2にマウスが選択されている場合にトリガーされます
port2-none | - ジョスティックポート2に何も選択されている場合にトリガーされます
port2-numpad | - ジョスティックポート2が数字キーとして設定されている場合にトリガーされます
slider-emuspeed | - 現在のエミュレーション速度をスライダーへトリガーします
slider-rensha | - 現在の連射ターボの値をスライダーへトリガーします
status-cartreset | - ロムの"挿入/取り出し後にリセット"が有効時にトリガーされます
status-casreadonly | - "テープを読み込み専用にする"が有効時にトリガーされます
status-deinterlace | - デインタレースが有効時にトリガーされます
status-diskreset | - ディスクの"挿入/取り出し後にリセット"が有効時にトリガーされます
status-hstretch | - 水平ストレッチが有効時にトリガーされます
status-record | - 録音中にトリガーされます
status-rfmodulation | - RF-モジュレータが有効時にトリガーされます
status-scanlines | - スキャンライン有効時にトリガーされます
status-vstretch | - 垂直ストレッチが有効時にトリガーされます
text-buildandversion | - ビルド番号とヴァージョン情報、クレジットのテキストを表示します
text-buildnumber | - ビルド番号のみ表示します
text-controlsport1 | - ポート1の接続情報を表示
text-controlsport2 | - ポート2の接続情報を表示
text-cpuusage | - cpuの固有率をパーセントで表示
text-emufrequency | - 動作中マシンのMhzを表示
text-framespersecond | - FPSの表示
text-machinename | - 選択されたマシン名を表示
text-ramsize | - 選択されたマシンのメインメモリ容量を表示
text-rommapper1 | - スロット1に挿入されてるロムのマッパータイプを表示
text-rommapper1short | - スロット1に挿入されてるロムのマッパータイプを省略して表示
text-rommapper2 | - スロット2に挿入されてるロムのマッパータイプを表示
text-rommapper2short | - スロット2に挿入されてるロムのマッパータイプを省略して表示
text-runningname | - 実行しているイメージ名(cart/dsk/cas)を表示します
text-scanlinespct | - スキャンラインの割合をパーセントで表示
text-screentype | - 現在のスクリーンモードの表示
text-screentypeshort | - 現在のスクリーンモードの省略して表示
text-version | - ヴァージョンのみ表示します
text-videobrightness | - 明るさの値を表示します。
text-videocontrast | - コントラストの値を表示します。
text-videogamma | - ガンマ値を表示します。
text-videosaturation | - 彩度の値を表示します。
text-vramsize | - 選択されたマシンのvramメモリ容量を表示
using-fmpac | - FM-PACの使用時にトリガーされます
using-megaram | - メガラムの使用時にトリガーされます
using-megarom | - メガロムの使用時にトリガーされます
using-moonsound | - Moonsound使用時にトリガーされます
using-msxaudio | - MSX-AUDIO使用時にトリガーされます
using-msxmusic | - MSX-MUSIC使用時にトリガーされます
using-rom | - 通常ROMの使用時にトリガーされます
using-scc | - SCC使用時にトリガーされます
video-brightness | - 明るさの使用時にトリガーされます
video-contrast | - コントラスト使用時にトリガーされます
video-enable-mon1 | - モニター1使用時にトリガーされます
video-enable-mon2 | - モニター2使用時にトリガーされます
video-enable-mon3 | - モニター3使用時にトリガーされます
video-gamma | - ガンマ使用時にトリガーされます
video-rfmodulation | - RF モジュレータ使用時にトリガーされます
video-saturation | - 彩度使用時にトリガーされます
video-scanlines | - スキャンライン使用時にトリガーされます
volume-keyboard-left | - キーボード左チャンネル用の音量表示
volume-keyboard-right | - キーボード右チャンネル用の音量表示
volume-master-left | - マスター左チャンネル用の音量表示
volume-master-right | - マスター右チャンネル用の音量表示
volume-moonsound-left | - Moonsound左チャンネル用の音量表示
volume-moonsound-right | - Moonsound右チャンネル用の音量表示
volume-msxaudio-left | - MSX-AUDIO左チャンネル用の音量表示
volume-msxaudio-right | - MSX-AUDIO右チャンネル用の音量表示
volume-msxmusic-left | - MSX-MUSIC左チャンネル用の音量表示
volume-msxmusic-right | - MSX-MUSIC右チャンネル用の音量表示
volume-pcm-left | - PCM音源左チャンネル用の音量表示
volume-pcm-left | - PCM音源右チャンネル用の音量表示
volume-psg-left | - PSG音源左チャンネル用の音量表示
volume-psg-right | - PSG音源右チャンネル用の音量表示
volume-scc-left | - SCC音源左チャンネル用の音量表示
volume-scc-right | - SCC音源右チャンネル用の音量表示


blueMSX actions （アクション）

■ actions （アクション）

- これらのaction属性はボタンなどに割り当てる事でき、menu属性は表示されるメニューのx/y座標を指定しなくてはなりません

machine configurations
audio-decreasevolume | - ボリュームを下げます
audio-increasevolume | - ボリュームを上げます
audio-setmute | - モードをミュートにセットします
audio-setrecord | - 録音モードにセットします
audio-setstereo | - ステレオモードにセットします
audio-togglemute | - 音をミュートさせます
audio-togglerecord | - 録音を開始/停止させます
audio-togglestereo | - ステレオ/モノラルを切り替えます
cart1-insert | - ROMスロット1挿入ダイアログを呼び出します
cart1-remove | - ROMスロット1からロムを取り出します
cart1-setautoreset | - "挿入/取り出し後リセット"のオプションをセットします
cart1-toggleautoreset | - "挿入/取り出し後リセット"の有無を切り替えます
cart2-insert | - ROMスロット2挿入ダイアログを呼び出します
cart2-remove | - ROMスロット1からロムを取り外します
cas-insert | - カセット挿入ダイアログを呼び出します
cas-remove | - カセットを取り出します
cas-rewind | - カセットを巻き戻します
cas-save | - カセットの内容をセーブします
cas-setautoreweind | - "挿入後巻き戻す”をセットします
cas-setposition | - "テープ位置セット”ダイアログを表示します
cas-setreadonly | - "テープ読み込み専用にする”をセットします
cas-toggleautorewind | - ”挿入後巻き戻す”の有無を切り替えます
cas-togglereadonly | - ”テープを読み込み専用にする”の有無を切り替えます
diska-insert | - ディスクドライブA挿入ダイアログを呼び出します
diska-insertdir | - ドライブAのディレクトリ挿入ダイアログを呼び出します
diska-quickchange | - ドライブAの高速ディスク入れ替えを使用する
diska-remove | - ディスクドライブAを取り出します
diska-setautoreset | - "挿入/取り出し後リセット"のオプションをセットします
diska-toggleautoreset | - "挿入/取り出し後リセット"の有無を切り替えます
diskb-insert | - ディスクドライブA挿入ダイアログを呼び出します
diskb-insertdir | - ドライブBのディレクトリ挿入ダイアログを呼び出します
diskb-remove | - ディスクドライブBを取り出します
dlg-about | - "blueMSX"ダイアログを表示します
dlg-apearance | - ”その他”ダイアログを表示します
dlg-audio | - サウンドダイアログを表示します
dlg-controls | - コントロールダイアログを表示します
dlg-emulation | - ”エミュレーション”ダイアログを表示します
dlg-help | - ヘルプを起動します
dlg-language | - 言語設定ウィンドウを呼び出します
dlg-machineeditor | - マシン構成編集ダイアログを表示します
dlg-performance | - パフォーマンスダイアログを表示します
dlg-ports | - ポート設定ダイアログを表示します
dlg-settings | - ファイルダイアログを表示します
dlg-shortcuteditor | - ショートカット構成編集ダイアログを表示します
dlg-video | - ”ビデオ”ダイアログを表示します
emu-decreasespeed | - エミュレーションのクロックを5%減速させます
emu-increasespeed | - エミュレーションのクロックを5%加速させます
emu-normalspeed | - 標準クロックの3.579Mhzに戻します
emu-quit | - blueMSXを終了します
emu-releasemaxspeed | - エミュレーションのクロック最速化を解除します
emu-resetclean | - クリーンリセットを実行します
emu-resethard | - ハードリセットをかけ、MSXを再起動します
emu-resetsoft | - ソフトウェアリセットをかけます
emu-setmaxspeed | - エミュレーションのクロック最速化を実行します
emu-stop | - エミュレーターの停止
emu-togglecputrace | - CPUトレースの有無を切り替えます
emu-togglemaxspeed | - エミュレーションの全速力動作の有無を切り替えます
emu-togglemousecapture | - マウスのキャプチャー
emu-togglepause | - エミュレーターの再生/ポーズを切り替えます
level-keyboard | - キーボード音の値をスライダーへ返します
level-master | - マスター音の値をスライダーへ返します
level-moonsound | - Moonsound音の値をスライダーへ返します
level-msxaudio | - MSX-AUDIO音の値をスライダーへ返します
level-msxmusic | - MSX-MUSIC音の値をスライダーへ返します
level-pcm | - PCM音の値をスライダーへ返します
level-psg | - PSG音の値をスライダーへ返します
level-scc | - SCC音の値をスライダーへ返します
menu-cart1 | - ROMスロット1のドロップダウンメニューを表示します
menu-cart2 | - ROMスロット2のドロップダウンメニューを表示します
menu-cassette | - カセットテープのドロップダウンメニューを表示します
menu-controlsport1 | - ポート1のドロップダウンメニューを表示します
menu-controlsport2 | - ポート2のドロップダウンメニューを表示します
menu-diska | - ディスクドライブAのドロップダウンメニューを表示します
menu-diskb | - ディスクドライブBのドロップダウンメニューを表示します
menu-file | - ”ファイル”のドロップダウンメニューを表示します
menu-help | - ”ヘルプ”のドロップダウンメニューを表示します
menu-options | - ”オプション”のドロップダウンメニューを表示します
menu-reset | - "リセット”のドロップダウンメニューを表示します
menu-run | - "実行 "のドロップダウンメニューを表示します
menu-specialcart1 | - ドライブA”その他"のドロップダウンメニューを表示します
menu-specialcart2 | - ドライブB”その他"のドロップダウンメニューを表示します
menu-tools | - "ツール”のドロップダウンメニューを表示します
menu-windowsize | - "ウィンドウ”のドロップダウンメニューを表示します
mouse-capture | - マウスのキャプチャーを切り替えます
pan-keyboard | - キーボード音の値をパンへ返します
pan-moonsound | - Moonsound音の値をパンへ返します
pan-msxaudio | - MSX-AUDIO音の値をパンへ返します
pan-msxmusic | - MSX-MUSIC音の値をパンへ返します
pan-pcm | - PCM音の値をパンへ返します
pan-psg | - PSG音の値をパンへ返します
pan-scc | - SCC音の値をパンへ返します
port1-setjoystick | - ジョスティックポート1にジョイスティックを有効にします
port1-setkeyset | - ジョスティックポート1にキーパッドを有効にします
port1-setmouse | - ジョスティックポート1にマウスを有効にします
port1-setnone | - ジョスティックポート1に何も挿されていない状況を有効にします
port1-setnumpad | - ジョスティックポート1に数字キーを有効にします
port2-setjoystick | - ジョスティックポート2にジョイスティックを有効にします
port2-setkeyset | - ジョスティックポート2にキーパッドを有効にします
port2-setmouse | - ジョスティックポート2にマウスを有効にします
port2-setnone | - ジョスティックポート2に何も挿されていない状況を有効にします
port2-setnumpad | - ジョスティックポート2に数字キーを有効にします
screenshot-large | - 大きい画質でスクリーンショットを実行します(544 x 480ピクセル）
screenshot-normal | - スクリーンショットを実行します
screenshot-small | - 縮小画質でスクリーンショットを実行します（272 x 240ピクセル）
slider-emuspeed | - エミュレーターの動作速度、周波数の値を可変させます
slider-rensha | - 連射ターボの値を可変させます
sprite-setenable | - スプライト表示/非表示の切り替え
state-load | - CPUステート保存されたファイルのロード
state-quickload | - クイックロード CPUステート簡易保存を復帰します
state-quicksave | - クイックセーブ CPUステートを簡易保存します
state-save | - CPUステートをファイルに保存します
switch-audioswitch | - パナソニックMSX-AUDIOの内蔵ソフトのオン/オフ切り替え
switch-frontswitch | - パナソニック系のMSX2+の前面スイッチのオン/オフ切り替え
switch-pauseswitch | - pauseキーのオン/オフ切り替え
switch-setaudio | - パナソニックMSX-AUDIOカートリッジスイッチをセットします
switch-setfront | - パナソニック系のMSX2+の前面スイッチをセットします
switch-setpause | - pauseキーをセットします
theme-pages | - 表示するテーマを指定します
video-brightness | - 明るさの値をスライダーへ返します
video-contrast | - コントラスト値をスライダーへ返します
video-enable-mon1 | - モニター1使用を切り替えます
video-enable-mon2 | - モニター2使用を切り替えます
video-enable-mon3 | - モニター3使用を切り替えます
video-gamma | - ガンマ値をスライダーへ返します
video-rfmodulation | - RF モジュレータ使用切り替えます
video-saturation | - 彩度の値をスライダーへ返します
video-scanlines | - スキャンライン値をスライダーへ返します
window-fullscreen | - フルスクリーンに切り替えます
window-normal | - 画面を２倍モードへ切り替えます (640x480)
window-setfullscreen | - フルスクリーンにセットします
window-small | - 画面を通常モードへ切り替えます （320ｘ240）
window-togglefullscreen | - フルスクリーンに切り替え


Trainer トレイナー詳細

■ blueMSX Trainer （トレイナー）

blueMSXには強力なトレイナー機能が搭載されています。　トレイナーとは改造ツールの一種で、メモリエリアの参照や改造コードの探索とその利用が可能なります。

実際に改造コードを検索するにはある程度ハードウェアとソフトウェアの知識が必要となりますが、トレイナーはなるべくそういった作業をシンプルかつ簡単にできるようにデザインされています。

事前の注意点としては、改造コードがすべてのマシン上で再現できるわけではありません。　例としてあげるのであれば、MSX1など内部構造が他のMSX規格と異なり、メモリマッパーは非搭載ですが代わりに通常のRAMを使用します。

トレイナーのダイアログには2つで構成されています。

中央が2ページに分かられたタブが設けられています：
Memory
Active Cheats

左の部分には7つのボタンが設けられています。

machine configurations
Reset trainer | - トレイナーをリセットします。
Snapshot | - 選択されためもりのスナップショットをとります。
Search | - Compare mode (比較モード）で指定した値を検索します。
Compare | - 2つのスナップショットをCompare mode (比較モード）で選択したモードで比較します。
Active / Deactivate | - 入力された改造コードの有効と無効化
Pause | - エミュレーションにポーズを掛けます。
Resume | - エミュレーションを続行します。


Trainer メモリー内部の探索

■ メモリー内部の探索

■ 改造方法の発見方法？

- 最初にエミュレーターから何かのソフト（ゲーム）を立ち上げます。
- 次にトレイナーを起動させます。　ショートカットはRCtrl+RSft+T
- 画面左に配置されているボタンの中から”Snapshot"を押し、最初のスナップショットを取得します。
- "Active memory bank"という項目から情報を得たいメモリエリアを指定します。（RAMまたはVRAMのみ編集可能です。）
- 次に”Compare mode"から比較方法を選択します。　選択オプションは3つでLESS(少ない) / Equal（同じ） / Greater（多い）になります。
- "Search”ボタンを押して、検索したい値を入力します。
- もう一度”Snapshot"をおして、二つ目のスナップショット取得します。
- "Compare"ボタンを押して、最初に取ったスナップショットと二回目に取った物を比較します。

トレイナーから自分で改造コードを探す手順はこんな感じになります。　スナップショットとは実行しているソフトのメモリ内容のある瞬間を切るとり、一時的にトレイナー内に複製保存するようなコンセプトです。　たとえばRPGゲームなどで、レベルアップする前の状態からスナップショットを取得し、レベルアップ後にもスナップショットを取ったとします。　そういった場合には必ず、パラメーターに差が生じる分けですから、パラメーターが記録されているメモリ内にも変動が生じます。　トレイナーはその変動の差を比較照合する事により、改造項目（アドレスと値）を発見するツールです。

■ 発見した項目を改造に適用する方法？

改造用の項目（アドレス）を発見できたら、表示されている行を右マウスクリックを押し、"Add Cheat"とメニューを選択します。

"Despription"の項目には改造内容の名称をインプットします。
上のサンプル画像では、MSX1で動作中の”Athletic Land"に無制限のライフを適応する改造データが表示されています。
マッパーメモリを搭載するマシン（例：MSX2)では改造用のアドレスが違って来る事が十分ありえます。
総合的にいえば、使用されているマシンによって該当するアドレスの探索が必要があるかもしれません。


Trainer 改造コードの使用方法

■ 改造コードの使用方法

■ ゲームに改造コードを読み込むには？

- 最初にエミュレーターから何かのソフト（ゲーム）を立ち上げます。
- 次にトレイナーを起動させます。　ショートカットはRCtrl+RSft+T
- 画面左に配置されているボタンの中から”Snapshot"を押し、最初のスナップショットを取得します。
- タブを”Active cheats"に切り替えます。　右に上に配置されているフォルダアイコンを押し、（Tool/Cheatsフォルダー内）改造コード専用ファイル(拡張*.mcf)読み込みます。

標準ですでに多くの改造コードが収録されており、拡張子*.mcfが付いてます。

すでに170以上にも上る、改造コードの発見と登録にはBiFi氏(Albert Beevendorp)とVampier氏（Patrick van Arkel)が積極的に行い、blueMSXでも使用出来る様に用意、テスト、そして提供してくれました。　この場をお借りして両者に感謝したいと思います。

これらの改造コードは適用するソフトが無改造（つまりオリジナル）であれば、blueMSX上で正しく動作するはずです。

■ 改造コードを適用してゲームを続けるには？

- 上の続きから、適用したい改造コードが読み込まれたら、ウィンドウ内に改造可能な項目が表示されます。（複数または一項目）
- その中から、適用したい項目を右クリックし、サブメニューから"Enable"を選択します。　（選択されていると、チェックマークが付いています。）
- 必要に応じて、"Activate"ボタンを押し、改造コードを有効化します。

■ 改造コードのセーブ方法は？

- "Acrive Cheats"タブの右上に表示されている、フロッピーアイコンを押してます。
- 後はセーブ名を指定すれべ、拡張*.mcfファイルとして保存されます。

machine configurations
Enable | - 選択された改造項目を有効にします。
Add | - 新しいコードを直接追加します。（メモリを探索せずに）
Modify | - 選択されたコードの編集をします。
Remove | - 選択されたコードを消去します。
Clear All | - ウィンドウ内に表示されているコードを全て消去します。
Enable All | - ウィンドウ内に表示されているコードを全て有効にします。
Disable All | - ウィンドウ内に表示されているコードを全て無効にします。
Execute Once | - 選択されたコードを一回だけ実行します。


Debugger デバッガ詳細

■ blueMSX debugger （デバッガ）

blueMSXには強力なデバッガ機能が搭載されており、エミュレーターと同時にご使用いただくことができます。
デバッガの起動はショートカットのRCtrl+RSft+Dから呼び出せます。

一部のデバッガのコマンドは直接エミュレータ側に反映します。
エミュレーターの実行、ポーズ、ポーズ解除とリスタートがデバッガ側からも制御可能です。

デバッガは"全て停止"（ショートカット：Crtl+Alt+Break）状態にする事で、機能の全てが利用可能になります。
BiFi氏のブレイクポイント命令もサポートしています。（アセンブラからbpを指定）

エミュレーション停止する事により、デバッガ側の5つのウィンドウに各自情報が表示されます。

■ 逆アセンブラ

逆アセンブル画面には現在実行されいてるコードが表示されます。

黄色い矢印マークが 現在のステートメントアドレス位置になります。

塗りつぶされた赤い円のマークが有効化されたブレイクポイントを表します。

空白の赤い円マークは無効化されたブレイクポイントを表します。

外部ラベルのシンボルマーク(asMSXやTNIasmクロスアセンブラーなどで利用されている）はウィンドウにて表示/非表示が可能です。

■ CPU レジスタ

CPUレジスタの色々な値を参照する事ができます。

またアクティブなFLAGS（フラッグ）も表示されます。これらに変更を加えると、結果がAFレジスタに反映されます。

■ コーススタック (CALLSTACK)

実行されたコードにおける、呼び出されたスタックが表示されます。

マウスでコールを選択すると、逆アセンブラのウィンドウも連動して情報が更新されます。

■ スタック (STACK)

このウィンドウはスタックに保存された、あらゆる値を表示します。

■ メモリ

このウィンドウにはメモリ内の様子をHEX方式とアスキー表記（右）で確認する事ができます。

またドロップダウンメニューからは、任意のメモリエリアの表示指定の切り替えができます。　アドレス欄に値を入力する事により指定のアドレスから表示する事ができます。

このウインドウからメモリ内容は直接編集する事も可能です。

シンボル名（asMSXやTNIasmクロスアセンブラーなどで利用されている)はアドレスを参照する為に利用する事が可能です。


Debugger デバッガ メニュー

■ デバッガ メニュー

こちらではデバッガで使用されているメニューの一覧を記載してあります。

■ ファイル メニュー

machine configurations
シンボルファイルのロード | - asMSXやTNIasmクロスアセンブラーなどで利用されているシンボルファイルの読み込みを行います。
終了 | - デバッガを終了します。

■ デバッグ メニュー

machine configurations
実行 | - エミュレーションの開始 / 実行を行います。
全て停止 | - エミュレーションを停止させて、デバッガ側に情報を表示します。
デバッグ中止 | - エミュレーションとデバッグの両処理を中止します。
リスタート | - エミュレータにハードリセットを行い、デバッグ処理も中断します。
ステップ イン | - 逆アセンブラにおいて、次のコードに移動します。
ステップ オーバー | - 逆アセンブラにおいて、次のコードに移動し、サブルーチンをフル速度で実行します。
ステップ アウト | - ステップ オーバーモードから抜け出し、エミュレーションを継続します。
カーソルまで実行 | - エミュレーションをカーソルが配置されたアドレスまで実行します。
シンボル情報表示 | - 外部ラベル表示の有効 / 無効を切り替えます。（asMSXやTNIasmクロスアセンブラーなどで利用されているシンボル)
移動 | - 指定された、アドレスまたはラベルまで移動
ブレイクポイントのセット / 除去 | - カーソルで指定されているアドレスにブレイクポイントのセットと除去を切り替えます。
ブレイクポイント有 / 無 | - カーソルで指定されているアドレスのブレイクポイントの有無を切り替えます。
ブレイクポイント全消去 | - 全てのブレイクポイントを消去します。
ブレイクポイント全有効化 | - 全てのブレイクポイントを有効に切り替えます。
ブレイクポイント全無効化 | - 全てのブレイクポイントを無効化します。

■ ウィンドウ メニュー

machine configurations
逆アセンブル | - 逆アセンブラウィンドウの表示を切り替えます。
CPU レジスタ | - CPU レジスタウィンドウの表示を切り替えます。
スタック | - スタックウィンドウの表示を切り替えます。
コールスタック | - コールスタックウィンドウの表示を切り替えます。
メモリビュアー | - メモリビュアーウィンドウの表示を切り替えます。

■ ヘルプ メニュー

machine configurations
デバッガについて | - デバッガのバージョンについての詳細情報を表示します。


Debugger デバッガ ツールバー

■ デバッガ ツールバー

こちらではデバッガで使用されているツールバーの詳細を記載してあります。
一覧の説明はアイコンを左から順番に機能説明を表記してます。

machine configurations
実行 | - エミュレーションの開始 / 実行を行います。
全て停止 | - エミュレーションを停止させて、デバッガ側に情報を表示します。
デバッグ中止 | - エミュレーションとデバッグの両処理を中止します。
リスタート | - エミュレータにハードリセットを行い、デバッグ処理も中断します。
次のステートメント表示 | - 逆アセンブラにて次のステートメントアドレスまで移動します。
ステップ イン | - 逆アセンブラにおいて、次のコードに移動します。
ステップ オーバー | - 逆アセンブラにおいて、次のコードに移動し、サブルーチンをフル速度で実行します。
ステップ アウト | - ステップ オーバーモードから抜け出し、エミュレーションを継続します。
カーソルまで実行 | - エミュレーションをカーソルが配置されたアドレスまで実行します。
ブレイクポイントのセット / 除去 | - カーソルで指定されているアドレスにブレイクポイントのセットと除去を切り替えます。
ブレイクポイント有 / 無 | - カーソルで指定されているアドレスのブレイクポイントの有無を切り替えます。
ブレイクポイント全有効化 | - 全てのブレイクポイントを有効に切り替えます。
ブレイクポイント全無効化 | - 全てのブレイクポイントを無効化します。
ブレイクポイント全消去 | - 全てのブレイクポイントを消去します。


Debugger デバッガ ショートカット一覧

■ デバッガ ショートカット一覧

こちらではデバッガで使用されているショートカットの一覧を記載してあります。

machine configurations
F5 | - エミュレーションの開始 / 実行を行います。
F8 | - 外部ラベル表示の有効 / 無効を切り替えます。（asMSXやTNIasmクロスアセンブラーなどで利用されているシンボル)
F9 | - カーソルで指定されているアドレスにブレイクポイントのセットと除去を切り替えます。
F10 | - 逆アセンブラにおいて、次のコードに移動し、サブルーチンをフル速度で実行します。
F11 | - 逆アセンブラにおいて、次のコードに移動します。
Ctrl+G | - 指定された、アドレスまたはラベルまで移動
Shift+F5 | - エミュレーションとデバッグの両処理を中止します。
Shift+F9 | - カーソルで指定されているアドレスにブレイクポイントのセットと除去を切り替えます。
Shift+F10 | - エミュレーションをカーソルが配置されたアドレスまで実行します。
Shift+F11 | - ステップ オーバーモードから抜け出し、エミュレーションを継続します。
Crtl+Shift+F5 | - エミュレータにハードリセットを行い、デバッグ処理も中断します。
Crtl+Shift+F9 | - 全てのブレイクポイントを消去します。
Crtl+Alt+Break | - エミュレーションを停止させて、デバッガ側に情報を表示します。


Trace Logger トレースロッガー

■ トレースロッガー (Trace Logger)

トレースロッガーはデッバガと連動し、asMSXなどのDEBUGコマンドを介してで出力される特殊なデバッグメッセージをログとして表示するウィンドウです。

実際のMSX側に出力されるメッセージとしてではなく、特殊な命令群の為デバッガのみが認識できる仕組みになっており、特に新しくMSXのソフト開発を行う際には役に立つ機能の一つです。

■ File Menu (ファイルメニュー）

machine configurations
Log to File | - トレースロッガーで記録されたログをテキストとして保存します。
Exit | - トレースロッガーを終了します。

■ Edit Menu (エディットメニュー）

machine configurations
Select All | - トレースロッガーの内容の全てを選択します。
Copy | - トレースロッガーの内容をコピーします。
Clear Window | - トレースロッガーの内容を消去します。

■ Help Menu （ヘルプメニュー）

machine configurations
About | - トレースロッガーのバージョン詳細を表示します。


blueMSX 使用許諾条件

■ 使用許諾条件とライセンス

このソフトウェアを使用と動作させた結果につきまして、作者は一切の責任を負わないものとします。ご使用の際には、必ず自己の責任にて動作させるようお願いいたします。

使用許諾

blueMSXは、個人的使用においては制限なく使用することができます。

blueMSX v2.0以前のバージョンの注意事項
blueMSX2.0以前の物はMarat Fayzullin氏のfMSXのソースコードを一部で使用しています、したがって営利目的の使用に際しては制限がございます。　Marat Fayzullin氏の許可無く配布する事はできません。
blueMSXIのバイナリを雑誌CD-ROMに収録するなどの、営利目的でのバイナリ再配布の場合には事前の連絡をお願いします。

MSXとMSXのロゴはMSXアソシエーション の商標です。 blueMSXとの関連性は一切ございません。


■ キーボード構成編集

blueMSXにはキーボード構成編集機能がv2.2から追加され、これよってキー配列が異なるPCとMSXのキー配列をユーザーの好む配置にアレンジする事ができます。

キーボード構成編集にデフォルトのキー配列はエミュレートされているMSXのBIOSを基準とした設定になっています。　当然MSX側にはPCキーボードには存在しないキーが存在し、それらは暫定的に常時使用しないキーなどに事前に割り振られています。　（キーボードについて詳しく知りたい方はキーボードの仕様を参照してください。）

キーボード構成編集は３つのダイアログから構成されています。　一番上のドロップダウンメニューにはマッピングスキームが選択でき、これらのスキームはすべて"Keyboard Config"サブディレクトリに保存されます。

中央部分はバーチャルキーボードになります。　初期状態ではターボＲのキー配列が基礎になっており、MSX機種の中で使用する全てのキーが収められいる事から基本キーボードとして採用する事にしました。（ターボＲの内蔵ソフトのみで使用するキーも含め。）　将来手的は他のキーボードの種類もサポートする予定です。

一番下の部分は3つのボタンがあり下記で簡単な説明をします：

machine configurations
保存 | - 編集したキーボード構成を保存します。
別名保存 | - 編集たひキーボードを新規または、別名で保存します。 元の構成は上書きされません。
閉じる | - キーボード構成編集を閉じます。 保存されていない場合は警告が表示されます。

■ 構成の編集方法

ここからはキーの割り当て方法について解説します。　MSX側のSELECT（セレクトキー）にPC側のPageUpキーを割り当ててみましょう。

machine configurations

ステップ１：
- バーチャルキーのSEL (MSX側のSELECT）キーをマウスでクリックします。
- すると左の画像のように点灯するはずです。
- この段階で割り当てるキーの待ち状態になります。

- すでに割り当てられているキーが存在する場合は対象キーに表示されます。
ステップ２：
- 次にPC側のPageUpキーを押します。
- この時、通常は三角のマークが表示されます。　理由は元もとPageUpにはMSXのSTOPキー割り当てられており、空白になったからです。

ステップ３：

- 最後に割り振られたキーが機能しているかチェックします。
- キーボードのPageUpをマウスでクリックし、対象キー"PRIOR"と表示されれば成功です。 "PRIOR"はユニバーサル仕様のPageUpキーの事です。

- この状態だとMSX側のSTOPキーが空白になっているので、逆にPC側のENDキーを今やった方法で割り当てて見れください。（元々SELECTキーが割り振られていました。）

その他：

どうですか？　見た目以上に簡単だったと思います。　他にの用途してはblueMSXは接続されているDirectXデバイスを自動的に認識しますので、MSX側のキーボードに、ジョイスティックのボタンを割り振る事だってできます。　ゲームをなどで、キーボードとジョイパッド間を行き来せずにパッドだけで遊ぶ事も可能にします。　構成を別名で保存しておけば、ゲームを遊ぶ時だけに事前に作成したスキームに切り替えるだけです。

- ｖ2.3からは標準で日本語のキーボード配列でスキームが選択されており、多くの場合に再設定する必要がなくすぐにお使いいただけます。
- 登録されているスキームを切り替えたい場合は、ドロップダウンからお好みのスキームを切り替えて”閉じる”ボタンを押せば自動的に切り替わります。　（保存の確認ダイアログが表示されますが、”いいえ”で終了してください。）